WARNING! Game breaking bug spotted (error 3006)

General Discussion
Prev 1 3 4 5 26 Next
I buy a game to play it, not to help the creater of the game to fix the game? omfg, test the game before you sell it... This is like !@#$...

3006 ERROR

First rule of testing: it's physically impossible to test every possible combination in a program. It is to be expected in every game or program that ever was or ever will be. Try to multiply the number of classes by the number of items, by the number of slots, by the number of followers, by the number of acts, by the number of possible completed quest permutations, by the number of inventory slots, by the number of skills, by the number of runes, by the number of sockets, by the number of gems. Take that number, say it takes a second to test it (which it doesn't) and realize planet earth haven't been around that long.

Then realize you have tested the tip of the possible bug iceberg

You know, to be all fair in this argument. This is not a rare completely obscure bug. It happens while doing a very mundane task withing the first hours of the game. Not like it was at the end and happened while in the far corner while spinning and spamming a skill and opening the menu. THis kind of bug shoul;d have been founf in Alpha.
Also I do believe someone said this was reported in closed beta. So there goes your middle of the night and programmers are asleep answer.
Also it is people like you that do NOT complain about anything and only defend a game that make games now a days less ready and done as they used to be on release. You sound like a souse that just got the crap beat out of you defending that same spuse saying "They didn't mean it. Don't arrest them"
I am of course pissed. I started the thread in Tech Support when this happened to me about... 5 hours ago. I honestly didn't expect this issue to be so "popular", but it stands to reason as it is a very simple action that most players have a high chance of doing at some point in the game.

That this escaped beta is unthinkable. A more likely situation is that it was overlooked. It got reported (several people have said it was reported in open/closed beta) and they simply forgot about it. Now I'm not going to rage too much, hoping the American servers come up in 2 hours so I can get at least a temporary fix for my addiction, but I am disappointed with this launch fiasco.

And no, not every game has such glaring problems on launch day.
i very much agree with hersalis. games being published while not done are an issue that is becoming more an more poplar as it seems (no offense blizzard guys you are not the worst by far [hi EA hi swtor...]). but i really think this bug could have been fixed. it's a) not incredible uncommon, i am b) pretty sure it must have occured in the beta and it is c) not something that prevents a player from gettin an achievement or some funny unimportant stuff, it prevents players from playing at all.
I Have same problem, cann not play now
This just happened to me. Why didn't i read this before...

I was playing DH, had just killed Jondar and accepted the Templar to tag along. Gave him a dagger from my inventory and tried to give him the shield I had equipped. Then the game died. I could still move around though. Restarted game and got error 3006.

Going to work now and hoping this will be fixed tonight.

Fix the damn 3006 NOW.
6 hours passed. game still not playable. good going blizz
joining a public game, i had a long long loadscreen. after a few minutes i ended d3 with alt+f4.
but now i have the same problem: starting d3 -> error 3006

bluepost would be great
joining a public game, i had a long long loadscreen. after a few minutes i ended d3 with alt+f4.
but now i have the same problem: starting d3 -> error 3006

bluepost would be great

same problem here
Blizz know of this issue and trying to fix it , but apparently it isnt trivial problem.

I tried to join a public game with my witch doctor but i did a "force quit" during loading and since i ALWAYS got error 3006 on European servers....
Is Blizzard aware of this ?

BUMP. I also cannot connect anymore and i didnt even touch my templar. THX BLIZZARD
I'm getting that error trying to retrieve the characters list.....I havent even got to make my char yet
Hey Laurelin, we are aware of this issue and are working on a fix.

The current workaround is to not give the Templar any gear until after you accept him as your follower through the UI pop-up.
I am also getting this error 3006, but when logging in it gets to "retrieving hero list..." and then times out error 3006.

Join the Conversation

Return to Forum