achievements bugged.

Technical Support
my lvl13 wizard has some bugs, im pretty sure i have a templar, but it doesnt show in the achievements, even gold looted is still at 0/10000, i've already slained king leoric, but still no achievemnts.

can anyone help?
Similar issue. Done the criteria for several achievements, not a single one awarded yet.
I lost almost all my achevments after relog. Hope it'll be fixed.
Same here, i dont get a singel achivment after i disconnected 4 hours ago, didnt notice befor i reached act 2
I'm in act 2 at level 18 with 0 achievements.
Not even one achievement.
Defnitely bugged.
I have another issue....i passed normal difficulty and went to nightmare then decided to wait for a friend and redo some bosses in order to obtain more achievements and what I found out later is that all my achievements were missing besides the ones i did .....
same here amidst act 2 zero achievements. did the campaigns coop and my friends got all the achievements. any solution?
I too keep loosing my achievement everytime I relog. Before I had 110 Achievement Points and now after relogging I have 70. Several of the Story ones are missing after they were earned.
I've also had this. Relogged and a while later I noticed I was missing all of my achievements but 2. Many of them I can't earn again, such as "To the Smithy!" and "Level 10". This is terrible.

I contacted support. I hope they can do something about it...
same here,very frustrating,blizzard come on,you can do better than this...
Same here, playing my Demonhunter for 5 hours now and not 1 achievements yet while my real id friends on their Wizards keep getting achievs.

Please investigate and fix it asap, don't wanna be level 20+ soon and not have any achievement -_-
im level 12 and i didint get even single achi
Ran through act 1 3times this morning going for all the lore books, was missing only like 7 from all of act 1... Got to act 2 and lag kicked in so i relogged (client restart), now first thing i notice when logging back in is that i just got an achievement that i swear i got like 9hours ago - not slept yet and ive been achievement 'whoring' as i go along to get the most out of every act then to see it whiped clean has completely demolized me into redoing it :(
Several people lore books I have on my list aren't shown as complete in my achievements. For example: I have all of Lachdanan's scrolls, but part 5 doesn't show up as completed for "A Quick Study".
achievements do seem bugged, completed act one and did not get the achievement, in fact, it did only track the very first qeust.
just finished the game under normal, still no achievements, any clues blizzard?

Join the Conversation

Return to Forum