Micro stutter and FPS drop fix (intended for AMD/ATI)

Technical Support
1 2 3 11 Next
TABLE OF CONTENTS
1.1 - Introduction
1.2 - For who is this fix?
1.3 - History

2.1 - Making sure your computer is healthy
2.2 - Understanding Vsynch

3.1 - Checking for micro stutter and FPS drop
3.2 - Setting the maximum fps of your video card
3.3 - Checking for solid FPS
______________________________________________________________________

1.1 - INTRODUCTION
You have a modern and healthy gaming PC and it runs recent games without a problem. When you play Diablo III the FPS seems to be good, but it doesn't feel that way. It feels "choppy". Another thing that can happen is that the FPS will suddenly drop and after a few seconds pick up again.

I spent two or three evenings tweaking my computer and Diablo III after the launch. This guide is the result of those sessions. It has solved the problem for me and because of that I decided to share this information with fellow players of Diablo III.

The fix seemed to work for a number of people, for others it made the problem slightly less and for some it did nothing. Those are the facts. I'm going to try and explain how this works as best as I can and hope it works for you too.
______________________________________________________________________

1.2 - FOR WHO IS THIS FIX?
This guide is for users of AMD (former ATI) graphics cards.
This guide is not written specifically for NVIDIA or other vendors.

Your computer meets the recommended specs or better. You can check this website to make sure that your computer at least has the recommended specs: http://www.systemrequirementslab.com/cyri/

Your computer is modern and up to date. Your computer must be able to play recent games good or very good. This means that if you bought the computer 5 years ago it will not give you the best performance that is available today.

This fix does not make the game or your computer run faster or better.
This fix is meant to give you a stable and smooth experience.
______________________________________________________________________

1.3 - HISTORY
There have been some replies in this thread that involve NVIDIA. I don't own that brand. I have a Radeon HD 5970 which is AMD/ATI. The fix involves using software that was only tested with a AMD/ATI card.

There have been some replies with people that ask if this will work on a very dated computer. You need to have at least the recommended specs before you try anything else. So the answer is it will probably do very little for you.

Finally, some replies are like "doesn't work" without any additional information like computer specs and what they have tried. Nobody can help you that way.
______________________________________________________________________

2.1 - MAKING SURE YOUR COMPUTER IS HEALTHY
Like I said in the introduction, the first thing you should do is make sure your computer is healthy. There are many guides on the internet about this topic and this thread would be hundreds of pages long if I had to list everything here.

Here is a small summary of stuff to check:
- Windows Update and hardware drivers up to date.
- Virus and spyware free.
- No unneeded background programs (media servers, sharing, etc.) when playing.
- Install Diablo on your fastest harddisk or your Solid State Drive (SSD).
______________________________________________________________________

2.2 - UNDERSTANDING VSYNC
Vertical Synchronisation will match your FPS to your monitor Refresh Rate. Most monitors have 60Hz so that's 60 FPS. There are also monitors with 59Hz and 75Hz so when you use Vsync those are the max FPS you will get. I highly recommend using Vsync because it prevents Screen Tearing.

In Diablo you can find this option in the Graphics section of Options.
On your computer you can find this in the Catalyst Control Panel.

Here are two pictures from my system:
picture 1: http://i.imgur.com/czOfW.jpg
picture 2: http://i.imgur.com/g9fOE.jpg

Note 1: if you override Vsync with your driver, Diablo cannot adjust it. So make sure that Vsync is set to "application" or "always on" in your control panel.

Note 2: your computer must be able to do at least 60 FPS but preferably higher like 80 or more.
Setting Vsynch will only match/limit it to your monitor refresh rate.
______________________________________________________________________

3.1 - CHECKING FOR MICRO STUTTER AND FPS DROP
- Start a game and press CTRL+R.
- Check the top left corner of your screen for a FPS counter.
- You will most likely see it bounce rapidly between two numbers, like 59 and 60.
- Play your game and when your FPS drops, stop right there!
- Check the counter: it will frantically show all kinds of numbers. Even if you have Vsync on, if you look carefully you will sometimes see higher numbers than your refresh rate.

Video: http://www.youtube.com/watch?v=jSZbdrBFvn0
You can see the fps bounce eventhough Vsynch is on my 60Hz TV.
______________________________________________________________________

3.2 - SETTING THE MAXIMUM FPS OF YOUR VIDEO CARD
The program I use to do that is called MSI Afterburner. You can download it here: http://event.msi.com/vga/afterburner/download.htm

You can do some other stuff with this tool, but here are the steps needed to cap your max FPS:

Part 1: adding Diablo III to the list
- Start menu > MSI > On-Screen Display Server.
- A little icon with "60" on it will appear in your tray, click it.
- Click the plus sign at the bottom left.
- Browse to your game directory and select "Diablo III.exe".

Picture: http://i.imgur.com/VGBTk.png

Part 2: setting maximum FPS
- Select "Diablo III.exe" from the list.
- Now click the wrench icon at the top right.
- Framerate limit: "60" or your preferred Refresh Rate (check your monitor specs).

Picture: http://i.imgur.com/HhMlG.png

You have to start this tool each time you play Diablo by the way. So if you restart your computer the next day, start this tool also. You can also switch it to "Start with Windows" if you want.
______________________________________________________________________

3.3 - CHECKING FOR SOLID FPS
- Start Diablo and press CTRL+R.
- Check the top left.
- No more bouncing numbers but solid FPS.

Video: http://www.youtube.com/watch?v=MEx8-6u2vLI
______________________________________________________________________

EDITS
1.) Intel i7 930 / 6GB / Diablo on SSD / Radeon HD 5970 Catalyst 12.4.
2.) Added note about Vsynch driver override.
3.) Added videos and pics.
4.) Decided to rewrite and restructure post.
______________________________________________________________________

This did it for me, I hope this helps you too! :-)
I've played for a couple of hours after I posted that.

Zero drops, no stuttering, perfect Vsync.

#edit: this was my first reply to the original post, which I have edited for readability at a later date. The core solution remains unchanged.
This seemed to help quite a bit! Thanks!
This was working only in 15-20 minutes unfortunately...
After that, micro stuttering returns just like usual. I have enough, this game is going back to the store. :(
Seems to work for me, thanks
So it will work only for ATI users?
I tried MSI afterburner and rivatuner (msi afterburner seems to be based on that one) but doesn't work for me :'(
Even tried capping at 30/40/50 fps but besides sluggish gameplay it continues to stutter nomather what settings I use.

Q6600@3Ghz
4GB Ram
W7 64 bit
AMD HD6850
Asus PK5 Pro Mainboard

Tried uninstalling realtek audio drivers as well es these seem to cause stutter from time to time but doesn't seem linked to that either.

No vsync at all and playing with in game fps limiter solves nothing either besides adding a huge amount of screen tearing added to tyhe stuttering..

Thanks for the tip though!

I'll install on my laptop to see if that one does it any better.. (dell latitude i-5 with intel HD3000 graphics)
Sorry, thanks for trying, but fixes nothing
Great post, I have not tried it yet(3006) but I will!

Good iniative.
@HApRooT: great!

@Alanthar: hmm, did you maybe restart your computer or log off? In other words, was the MSI icon still in your tray?

@Faelya: alright!

@Pakcop: I don't own a NVIDIA card, but I know there is a control panel in the software that can limit FPS too. Here is a picture: http://oli.new-lan.de/wp-content/uploads/2012/01/nvidia-inspector.png

@verso113: if your Diablo is set to Vsync, maybe you override it with your GPU driver? Try to make sure the driver is set to "application" vor Vsync and in Diablo turn it on.

@Legion: that's too bad. What card do you use if I may ask?

@Atwa: okay!
@Pakcop: I don't own a NVIDIA card, but I know there is a control panel in the software that can limit FPS too. Here is a picture: http://oli.new-lan.de/wp-content/uploads/2012/01/nvidia-inspector.png

Yeah, i know about nvidia inspector. Gonna try both of them today. Will try some more new fixes. Thx for response anyways.
Hello,

Thanks for posting this, this is something we're looking into at the moment, I'll update as soon as I hear anything more about this issue.
Doejeding you are pretty much awesome.

I think I'm having the same problems as you described here, although my fps resets to 59 too fast for me to see any other number.

But let me get this straight:

I tried your solution and looked through the forum, and there is still no fix to this problem?
@Fangz: there are also 59Hz monitors, check the specs for your brand/model? 59 FPS is perfectly fine when in Vsync. As for a fix in Diablo: Blizz already gives the "Max frames" setting in the Graphics Options. It looks like you need to do it on a driver level, unfortunately...
Hello,

Thanks for posting this, this is something we're looking into at the moment, I'll update as soon as I hear anything more about this issue.


So the stuttering issue is being looked into because it's making my game absolutely unplayable. I'm playing in Slow motion basically while everyone else can cross an entire map I'm "standing still" on their screen, this makes it frustrating as mobs can kill me easy since they all seem to teleport around the screen.
gameplay improved - ati radeon 5730 mobile here. will post results after more time.
my Notebook specs:
Intel Core i3-370M (2.4GHz, 3MB Cache, 64-bit, 32nm, 35W)
Nvidia GeForce GT 540M, 1024MB DDR3
4GB (1x4GB) DDR3, 1333MHz

I've fps stuttering and drops too. I've tried everything but nothing helped...
This was working only in 15-20 minutes unfortunately...
After that, micro stuttering returns just like usual. I have enough, this game is going back to the store. :(


It might be someting else with your PC, stop blaming the game because we don't have an idea what the heck is the problem.

ALL of you people have diffrent problems with stuttering and FPS drops, stop blaming the fix and stop claiming you have the same problem.

The RESULT is similar, but the CAUSE of the problem is not the same ... some of the whiners even have their own problems with their PCs which get similar results, stop jumping the conclusions.

Everyone of those laptop guys ofcourse get improvements from things like this, capping the FPS releases some resources for the system, it doesn't directly fix the source of the game-driver specific problem.

EDIT: also why to use external utility for capping maximum FPS if you have the same setting inside D3 options. :S
Tried it. FPS now dont get higher than 60, yet stuttering still presents and when im fighting/killing big packs, fps drops to 15-20 and after few secs it goes up again.
@Okonomiyaki: okay, good to hear and post back if it stays good.

@Stewox: I made this post because for me, it doesn't work with the in-game setting, but does with the tool. *shrugs*

Join the Conversation

Return to Forum