Your login information is incorrect. Please try again.

Technical Support
Your login information is incorrect. Please try again. (Error 3)

I allready made a ticket about this but its been about 5days now & im all out of patience.

When authenticating credentials this is the message I get, wich obviously is not the case. I can logon to wow & into battle.net with ease, but D3 refuses to cooperate with me.

I have read similar posts on the US forums bit did not find any here so I'm starting one myself.

Apparently resetting the account from blizzards end has proven successful for most.

Please Blue on this.
Oh yes, please don't let me be the only one. I am pushing and starting Threads about this again! Not to be rude, but if I am not the only one with this problem, then we may get the Blues attention!

Edit: Btw., I already created 1 Thread here in the EU forums about this and answered on another ;)

What works for some people is this: Create a new Account for your Win7 as Admin, log out of your main account, switch to the newly created, start D3, LogIn (should work for many but not for me -.-), then switch back to your main Account and it SHOULD work.
What I have tried to do is:

-Changing passwords
-Reset game preferences in D3 Launcher
-Run D3 as admin & accepted the EULA as admin
-Forcing D3 to update itself by Deleting the cache folder inside diablo 3 folder and Diablo III.exe
-Deleted the agent file within D3 folder , and the agent folder inside ProgramData>Battle.net folder to force an update on that.
-Upgrading router firmware
-Updating ethernet drivers + all outdated drivers
-Re-installed Diablo 3

-Flashed Bios ( needed an update anyways )
-Formatted SystemDisk
-Reinstalled Win7
-Reinstalled Diablo 3

-Defragmented HDD's ( Why not )
-Ran a traceroute on D3, went smooth.

Think that pretty much covers everything I can do on my end, could really use a blue on this.
Yes, Changing PW does not work, tried that, too.
For me it was like 3 hours of nothing works, then suddenly it worked. But I did nothing for it. Just got lucky. Then today: Same problem again. But you can try out what I wrote you in my "Edit" above.

Oh, btw., the method I mentioned came from a blue.
Shown here: http://us.battle.net/d3/en/forum/topic/5889450934?page=1#8
Allready tried the Admin Account method :)
Ok, I can confirm this workaround now!
Tried it out again, this time it worked. Because I don't use an authenticator, I just had to answer the secret question.
Oh, well...sorry that it did not work for you :/
Had the same problem. This time I got lucky I guess...
Anyways: This still is an annoying problem and I like it fixed. I do not want only a workaround just to play this game!
Strange, now it works. seems like the issue is solved.
This is a pathetic excuse for a security system. Nothing I have tried works - there is no customer support. At this point, all I want is a refund.
I am having the some problem, I have tried everything and nothing works. My ID and p/w work fine I was able to confirm I didn't get "hacked" or anything. But, when I put in my authenticator I get error 3. It won't let me put in a ticket, anywhere that needs a authenticator password doesn't work. I also can't call for help because for hours I just get "our hold que is full" and it hangs up on me :/
This is retarded, I just got this game today and this is what happens?. I changed my password like 5 times, even did the password reset... All my log in attempts have just come up with this error.

Anyone get through yet?
Anyone having problems with this for me it was that I had peerblock running, a sort of IP firewall and it doesn't like battle.net. Can either add each of the blocked IPs to this or exit. Gave me "Your login information is incorrect. Please try again. (Error 3)" when it had nothing to do with my login credentials!
Hello,

This error may occur due to the EULA or TOS not showing correctly, or because of issues with the login itself.

Please check the following two articles:
http://eu.battle.net/support/en/article/error-3
http://eu.battle.net/support/en/article/error-315300

Also, if you have an Authenticator, please resync it then try again.

Join the Conversation

Return to Forum