FPS, Input Lag and Rubberbanding since patch

Technical Support

We are still investigating some issues related to stuttering and our development team are working on that, but there are other steps we need to check.

Please make sure your Drivers are up to date. This includes Chipset and Sound drivers:

Run a Scandisk and Defrag on the hard drive where you have the game installed:

Go to the Diablo III folder and then Data_D3, then PC and then MPQs and delete the Cache folder in here.

Make sure no other applications are interfering:

Then try the game again, and see if this issue persists.
You say your team are looking at the stuttering (which i dont have now i have a new custom desktop), but what about the rubber banding?
Are you looking into that too?

Its quite annoying when the elites already drag you back to eat you and then you rubber band ......
The rubberbanding thing is 100% server side, so we all need tons of good luck waiting for that fix :(
@Freld wont help me at all - my gfx card is ATI/AMD based and not Nvidia, though it might help others.

@Lurdlespor Win7 does a weekly defrag for me and both disks report 2% defragmented, which I'd say is pretty much normal - I've not done a scandisk yet (not sure if it's something that's being done for me by Norton or Win7 as it's not really something that I check so I'll do that today. As for drivers, the only one I was missing was chipset driver as noticed by another poster, but adding this has had no noticeable effect on either the game or other programs that I use.

As for background programs, yes, here are usually a few running in the background, and I notice that as soon as I try to record using MSI Afterburner's free tool (which works fine on WoW and SWTOR) my fps drops through the floor. I don't know if this is because of the 'max background fps' interfering and thinking that the game's not the main screen while the video capture is running, but it makes showing the faults I have a lot more difficult.

I'll update as soon as the hdd's have been scanned for faults, but as Blackadder46 has mentioned, none of these fixes would appear to resolve the rubberbanding issue, which is the main cause of unnecessary elite-pack death.
yea drivers defrag all basic stuff done graphic turned into minimal and still lag when some monsters load in and what you call it .. rubberthinging :/
I have had Stuttering, Key Lag, and Rubberbanding since the last patch 1.0.3

My system meets the recommended specs and I have not had any problems with any other programs/games.

Diablo 3 was running fine with the highest settings before the patch, now issues occur on average every 3-5 seconds. I have provided a list below of all the steps I have tried to correct the problem.

Recommended by the Blues in these posts:

So I Have:
*Updated all drivers (They were already current)
*Ran Scandisk and Defrag
*Deleted the Cache Folder
*Turned off all unnecessary background programs
*Disabed Windows Drive Indexing (for all files and subfolders)

I found this post and tried the things Ethereal Mog Suggested:

So I:
*Rebuilt the battle.net folder
*Deleted the D3Prefs.txt file
*Changed Settings with all variations on Hardware Class and Trilinear Filtering

I also tried these things posted throughout the forum:
*Turning off Shadows
*Running Windowed
*Uncheck Framerates
*Lowering Graphics and sound settings to lowest settings
*Disabling Sound

I Just found this post and did what Edstroyer suggested:

So I:
*Transferred MPQs folder to USB drive and set the symbolic link

It seems to be running smooth again with Graphics/Sound at default settings

Previously I would do one of the things mentioned above and the issues would improve slightly for about an hour or two and then go back to running poorly. Occurrences would typically be every 3-5 seconds when bad and 6-10 seconds when improved. This MPQs folder fix seems to have almost completely eliminated my problems. Time will tell (fingers crossed)

I hope this helps someone else, or gives Blizzard some info to work with. Many thanks to all the people posting and working to help out!

I forgot to mention that Latency/Lag has not been an issue for me. I know some people are experiencing similar issues due to "Lag Spikes". As Edstroyer stated it's important we don't confuse the two (Post-patch problems and Lag Spikes) have been Separate issues for folks with different resolutions.

I have kept an eye on Latency since purchase around May 20th. (Roughly time wise) The first two weeks I got a dependable 30-35ms, 2 weeks later it was 60-70ms, two weeks later 95-105ms and that's were it stayed. Though I still had smooth gameplay at 100ms BEFORE the patch. I occasionally get Lag Spikes but they are few and far between, thus not a problem for me so far.
I dutifully went through all the suggestions and the rubberbanding and stuttering issues are still there with no change.

The only thing that did seem different was the input lag - for about 3 minutes every time I pressed a button 1-4 the appropriate spell triggered correctly, after about 3 mins though I was back to pressing buttons multiple times in order to get the spell to cast.

I suppose you could say then, that clearing the cash has resolved this issue but frankly I won't be logging out to clear the cash every 3-5 minutes so back to the drawing board and try again.
I hate that for D3 to run we, as players, are apparently supposed to do a series of complicated things instead of...you know...just starting up the game an logging in.

In all seriousness it is the job of Blizzard to do those things. They're the ones who have expert developers working for them but for some reason players are expected to metaphorically do gymnastics just so they can play? All because of a sh***y patch?

My game has been unplayable since the patch. I refuse to believe it is my machine at fault because every other game and software I own runs perfectly.
Installing the latest drivers......DOES NOT WORK!!!!!!!
For me the game is unplayable to. Rubberbanding and i'm lagging with every move I make.
Before the patch came out I could play the game on max settings without any lag/rubberbanding/fps lagspikes at all. I've updated every driver but nothing helps or work.

W7, I7-3820, 16GB ram, Gforce GTX 680 2GB
There's a new sticky post regarding a possible workaround for the stuttering probs.
For those not familiar with the term, 'workaround' means 'I can't get through to anyone who can actually be bothered to fix it, so here's something you can try for yourself'.

anyway - here's the link...

bump - again...
It's amazing when you can get some Blizzard support staff who go way beyond what you would expect in order to resolve an issue successfully, that the same company will also leave you hanging for 2 weeks trying to get an answer apart from 'check your drivers'.

I am also experiencing significant fps drops whenever i get into a fight - this is with the lowest graphic settings, and occasional 'rubber banding'. Pre patch - i was playing on the highest settings without any issues.

I was working through Act 3 Inferno pre patch. That is now impossible for me, despite the nerfs.

Because of this, i havent bothered playing in over a week and until this issue is resolved, it is pointless for me to spend anytime on this game.

EDIT: And yes, my machine is routinely defragged, drivers are current, OS patched up to date, on a 60mbps fiber connection, Diablo 3 cache cleared yada, yada, yada...
yet another bump...

How many more of these pointless thread updates do I have to do before:
a) YOU FIX YOUR F=====G GAME!!!! or
b) I get banned for trolling in which case you get to ignore me forever.

I'm a paying customer, why do I feel like that really doesn't matter to you?
ofc, the conversation will then follow something like...
......... /blue : 'cos we gave you your game for free!

and yet, if I stop paying for wow, I lose access to diablo as well?
......... /blue : correct

so I pay annually in order to get access to both and yet you think in some way this is not some kind of subscription / payment plan for the game?
this is the response from my support ticket referring to this thread...

Firstly I do sincerely apologise for the wait time; the forums team have been inundated with requests and issues and are working very hard to answer all posts.

If you have a question of a Technical nature or Billing, please call us so that you are able to speak to a representative live on the phone. This should cut down your wait time significantly and while I personally dread waiting on a phone line for half an hour with repetitive music in my ear, it is much more gratifying to wait to talk to someone with knowledge and experience, rather than wait a week or so for a second step email.

Therefore if the steps that I post below do not help with the rubber banding and the PPS/input lag you are experiencing, please call our Technical Support line and we shall be very happy to assist further!

Also I have noticed your previous ticket of praise to my fellow colleague James. Thank you for the report and I shall most certainly pass on this praise to management and close that ticket for you.

I see nothing that could d cause a major issue in your files, other than that you are running McAfee firewall and antivirus. I recommend de- installing both and using Windows Defender/Microsoft Security Essentials as they are the best on the market at the moment and will not disrupt any programs or gameplay.

Remember to run Diablo III in the default window, then adjust resolution but use Full screen mode, Not windowed mode as this is causing some systems to have severe Input lag and mouse issues.

Other than that, please follow the steps below and hopefully we can come to a solution to this issue!


Attempt to create a new Windows Administrator account and install from the new User account. Plaese follow the instructions here:


Locate the folder where your installer is. You’ll find a file with a “.part” extension on it.

Installer Tome *.MPQE.part in the Installer directory for example. Removing the ".part" extension and running the installer again (on the same folder so you don't have to download everything again) should fix this issue for you, as the installer thinks the files are incomplete. Make sure you’re logged in as an administrator.

Fix 3:

In many cases, booting Windows in Safe Mode with Networking will make the computer more stable. This can often allow users to bypass problems with installation or patching.

Windows XP/Vista/7

Shut the computer down completely and turn off its power.
Wait 30 seconds, and then turn the computer on.

The computer begins processing a set of instructions known as the Basic Input/Output System (BIOS). What is displayed depends on the BIOS manufacturer. Some computers display a progress bar that refers to the word BIOS, while others may not display any indication that this process is happening.
As soon as the BIOS has finished loading, begin tapping the F8 key on your keyboard. Continue to do so until the Windows Advanced Options menu appears.

Using the arrow keys on the keyboard, scroll to and select the Safe Mode with Networking menu item, and then press Enter. The computer should boot in safe mode with networking and prevent any other programs on the system from interfering with the installation or patching.

If you have any additional questions or concerns, please reply to this ticket and we'll get back to you as soon as possible :)

Kind Regards,
Marc C.
Blizzard Entertainment Europe

I have Norton I.S, not McAfee, since I've paid for it for the next 9 months I'll not be changing it any time soon. I will be testing these fixes in the next day or so, and I'll update here, but really..? Are Windows Defender /MSSE the best on the market? or just the best of the free ones?
fix 2 was easy to check - there's no .part files in the d3 folder or any of the subfolders.

fix 3, booting in safe mode..? since this is just an extension of 'is there something else running that's messing with the game?' I'm tempted to ignore this step, but I'll be a good little customer and go through all the steps that are given to me...
Chiming in to report more of the same. Since 1.0.3 hit, I get rubberbanding, "micro-rubberbanding" (as in, can't immediately walk away after some skills finish their animation, character seems to be jittering in place), and various input lag moments with skills like Vault, where I press the keys and absolutely nothing happens.
this is the response from my support ticket referring to this thread...

Firstly I do sincerely apologise for the wait time; the forums team have been inundated with requests and issues and are working very hard to answer all posts.

If you have any additional questions or concerns, please reply to this ticket and we'll get back to you as soon as possible :)

Kind Regards,
Marc C.
Blizzard Entertainment Europe

I have Norton I.S, not McAfee, since I've paid for it for the next 9 months I'll not be changing it any time soon. I will be testing these fixes in the next day or so, and I'll update here, but really..? Are Windows Defender /MSSE the best on the market? or just the best of the free ones?

Hey Shadowbright,
Thanks for posting the info you're getting. I haven't created a ticket since I figured this was a widespread issue, it didn't even occur to me.

Just to add some info and support, I thought I would try what they recommended as well giving you some backup. I posted above everything that I have done so far which greatly improved my ability to play up to inferno act 1 anything after that I just get killed due to key lag, rubberbanding, etc... Still annoying to have these issues though, especially since everything was great before the 1.0.3 patch.

Recommended by blizzard:
1. I already run an administrative user account so no need to do that one
2. Checked for *.part file, not there (probably cause cd install idk???)
3. Safe Mode. I agree this is a redundant step for the same reason but I did it, and no difference.
4. I am running Comodo it's free and always worked for me. But I disabled it and enabled Defender and Microsoft Security Essentials (no improvement)

So I hope they help you further and that I might reap the benefits. But I won't be holding my breath or progressing in Inferno till then...

Join the Conversation

Return to Forum