Technical Support
1 2 3 13 Next

While playing Diablo III you may experience an issue where your hero is reverted in position, usually by a few seconds (also known as 'rubberbanding'). This is an issue we are aware of and we are in the process of investigating the cause.

This thread is intended for our players to leave feedback for us, as well as providing a place for us to provide further details as they become available. Other threads related to 'Rubberbanding' will be closed and redirected here, to contain all relevant information in a centralised thread.

If you have been experiencing this issue since the Beta or launch of Diablo III, please check the following connectivity troubleshooting article:

If you have been experiencing other performance related issues, please check our article here:
I have only really started having this issue in the last week-ish. Playing on the Asian server it seems worse, for some reason.

Ty for update.
11/07/2012 09:46Posted by BadandMad
I have only really started having this issue in the last week-ish.

I was going to say the same, I only started experiencing it in the last 1-2 weeks, but it's not severe. No changes to my setup or GPU drivers at all during this time.
I have only experienced this since the original release of patch 1.0.3, which was 2 weeks ago i think?
It happens on both my laptop and now my new desktop....
I run everything on max, have no other issues, latency is between 30 and 50 consistently.
It does appear to happen more and worse when i first start up the game or an area, although it is pretty random, even happens when going back over a map that i have already opened and cleared....

Machine is:
win 7 64bit
i7-3770k CPU @ 3.50ghz (8 CPUs), ~3.5GHz
120gb SSD (game and os system on here) other 2tb hard drive for other stuff...
3GB Radeon HD7950
16GB ram
Liquid cooling and 4 fans

Internet connection is constant at 16 download and almost 1 upload...
Blackadder46, what happens if you move the Diablo III folder to your 2TB HDD instead of the SSD? We've seen some players have issues when it's on an SSD, it'd be worth testing this out.
win 7 64bit
i7 2600K
500GB hard disk. D3 is not on windows disk, but the gaming hard disk.
Sapphire Ati Radeon 6850 1 Gig
4 GB Ram

Since patch 1.03 I was heaving this rubberband problem, but only for 2 secs in a game of an hour. Now, since patch 1.03b, I am having major problems with rubberbanding. I just started a game and I am experiencing terrible rubberbanding every minute. I am not able to play the game at the moment...
I didn't have any problems before the 1.0.3 patch, could still SSD be a problem?

I'm not to keen on longer loading times, but it's an acceptable temp-solution to change to an HDD. I really hope this gets fixed asap though.

Edit; Just to provide some more info:

CPU: Intel 2600K w/oc
RAM: 16GB 1600MHz
GPU: 560Ti (ASUS)
SSD: C300 RealSSD
Happen to me all the time since 2-3 lastest patch update!

Before it didn't happen. Using lastest OS X update and SSD forceGT

This occur only for Demon Hunter and Monk! When using Smoke Screen, Vault and Tempest Rush
This happens to me at least once an hour, and has since I first tried the Beta during the stress test weekend. Seen it on all classes.

Macbook Pro (2010)

CPU i7, 2.66 (I think)
GPU GeForce GT 330 M

When I come to think of it, it probably happens more often with DH and Monk.
This has nothing to do with a SSD, as I'm sure this easily happens with any HDD too.

Rubberbanding has gone from very occasional to severe after 1.0.3 patch for me, in which multiple rubberbanding issues were supposed to be solved.

It doesn't happen too often, mind you, but when it happens, it usually bands a way bigger distance or do so multiple times fast.

I recently only played a demon hunter, so this is mostly noticable when using Smoke Screen and trying to stutter step immediately after. Not implying this does not happen for melee classes as much, as my friend kept complaining on his barbarian quite often.

Win7 x64, Intel i5-2500k @4.5GHz, 8GB memory, MSI 560Ti 448-cores (304.48).
Connection is at 100mbps both ways.
System, a lowly laptop;
Win 7 64bit
Intel Core 2 Duo P8400 2.26ghz
4gb memory
GeForce 9600M GT
50mbps cable

I have had issues with rubberbanding since the release of the game, usually during peak hours. Have not noticed it getting worse since 1.0.3 and is usually much better now than near the release time but the servers are also a lot quieter.
This morning I was having intermittent small jumps but at the moment the game is virtually unplayable due to 4-5 second jumps.

In my experience it has been busier times that have caused the problems. I am guessing people downloading the patch are causing the current issues although it surprises me that the people updating should affect the game servers so much.
To be honest and after some researching i dont think that is going to change anything.
I am also reluctant to start moving folders around the drives incase something goes even more pear shaped than the rubberbanding effect.

My reasoning is simple
Before patch 1.0.3 i was using a 6 year old laptop to play, it barely met the min specs but played ok.
After the patch i was still using my laptop to play because my new desktop was in the process of being built to spec.
The rubberbanding happened on the laptop after patch 1.0.3 and that laptop does not have an SSD drive.
So 10 days ago i got my new desktop
The first thing to go on the machine apart from the O/S was Diablo
The rubberbanding was identical to the laptops.....

Whatever optimization you did in patch 1.0.3 had the knock on effect of causing rubberbanding to a wider audience.

I seem to remember quite a few years ago that Ultima online suffered the same problem
They released a patch and caused mass rubberbanding for everyone.
It took a while to sort, but they did it.

Taking a leaf out of their book i would just ask one thing, please keep this channel of communication open, keep us updated, ask us for machine specs, trace routes, whatever is needed to solve the problem
Things go pear shaped when you dont communicate with us, walls of silence will breed threads of hate.
So long as players know you acknowledge the problem and are making headway to solve it then people will stick with it.....

CPU: intel i5 2550k @ 3.30Ghz
GPU: nvidia GTX260 core 216 @ 650Mhz
HDD: several 7200rpm drivers from various vendors (WD, Hitachi and Seagate)
OS: Win 7 64bit / Ubuntu 12.04 64bit

I have only recently bought D3. Patch 1.0.3 had already arrived when I bought and downloaded the game. I have it running on both Windows and on Linux by using Crossover (wine + magic pixie dust).

On the Windows side of things, the game is on a separate HDD from the OS and I see rubberbanding issue. They're not happening all the time but they happen enough times to get annoying.

On the Linux install, I've had the game on the same partition as the main OS. Rubberbanding occured as often as it does on Windows. I've created and ext4 partition on another HDD (1TB Hitachi - around 400GB ext4 partiton), and moved the whole .cxoffice folder there and created a symlink because Crossover expects the mentioned folder to be in my home dir. Rubberbanding still happens, again, as often as I see it happen on Windows

Before the mob outside readies its torches and pitchforks and starts chanting "go away nab, we no support Linux", let me just point out that rubberbanding occurs independent of the platforms I've ran the game on.

Problems happen with or without the router I usually use to connect to the internet.
I have this issue on two desktop computer other has SSD and other has HDD.
Sometimes it happens rarely sometimes really often.
I've been getting rubber banding pretty much since the game came out, it's not all the time but it happens enough to be annoying, and it gets me killed a fair amount.

i5 3570k
GTX 680
15/1.5mb connection
around 50ms most of the time
I am just leveling a new demon hunter up and am in act 4
On 3 occasions when the pillars collapse i was rubberbanded back exactly as the pillar collapsed....seems like an animation thing...
Havin this problem ever since the 1.03b patch update. The game has been fine before the patch.
Rubberbandin after first 1.0.3 patch.
And latest patch made it even worse.
Some script affecting lag compensation so its not laggy but rubberbanding?
This too:
Rubberbanding started after 1.0.3 patch. (not often and not really disturbing)
Latest patch made it alot worse. Now it's disturbing.

Radeon 6770M
7200 rpm HD
100/10 Mb connection
(no energysaving, full high-performance settings)
Going back to something i mentioned above about Ultima Online having the rubberbanding issue i managed to find this on their wiki page...
I cant rightly remember if this was the rubberbanding issue i was refering too, but it does open up something to look into
I havent tryed this but my chars wear boots with "movement speed"
Is it possible the same is happening on Diablo as was happening on UO?
Here is the bit from the wiki
Speed walking

Speed walking was accomplished via a program called UO Extreme. It sent player movement packets to the server without waiting for the server to send "successful movement" packets back. Because the client would only allow you to move a few steps without receiving these success packets from the server, players with high latencies (dial up users, Europeans playing on servers located in North America) were faced with a noticeable pause every few steps when attempting to move. Speed hack allowed these users to play the game normally. However a downside existed, as the server did still check if movement was allowed, and if it turned out not to be allowed (due to a player or creature moving in the way) the server would send back a "movement rejected" packet, and the client would suddenly "rebound" you back to where the failed movement had occurred.

Join the Conversation

Return to Forum