Micro-stuttering fix fresh from the US

Technical Support
all credit to Maccus from NA

Enjoy :)

tl;dr: see 11)

I had the Micro Stuttering Problem and i've managed to 100% fix it so i thought i'd share how. firstly lets look at what i tried -

These things may have helped slightly but did not fix, found from other threads with the same problem -

1) Opened D3Prefs.txt and changed HardwareClass "1" and DisableTrilinearFiltering "1"
2) Run in Compatibility Mode Windows XP Pack 3 and as Administrator
3) Task Manager, Show all Processes, right Click Diablo3.exe - Set Affinity....Turn OFF Core 0
4) Task Manager, Show all Processes, right Click Diablo3.exe - Set Priority High or Realtime
5) Freshly Reinstalled Graphics Drivers
6) Turn on/off indexing on my SSD Hard Drive
7) Changed and tried numerous settings in game / Nvidia Control Panel Settings
8) Performed various Windows 7 tweaks on my hard drive settings
9) Created a RAM drive and put some of the game files on it
10) Ran the game files from USB stick

Some of the above helped, but did not fix the micro stuttering.

I KNEW it was caused by access of game files and hard drive access.

No matter how many tweaks i tried, i could not ELIMINATE the stuttering until............................................

11) I simply turned off real time protection on my anti virus software. (microsoft security essentials).

Basically whenever the SDD was being accessed, real time protection was scanning them for viruses etc, and thus the game files were being accessed multiple times whilst they were trying to load in game.

Such a simple fix. Game is now 100% smooth with no stuttering at all.

Hope this helps some people, who like me, tried everything but the obvious.
Nice, i will try this once i get home.
didnt fix :(
It works. nr. 11. Just disabled MS essentials and oalala, no fps loss. Thanks
Just dropping by to say thanks for posting this! It worked for me! I still get the occasional hiccup, but overall it's a much smoother experience!

A definite improvement.
The only thing that works for me is using D3Overrider to force proper Vsync with tripple buffering. The in-game Vsync just completely fails, capping fps at 50 instead of 60 and causing all sorts of stuttering.
all credit to Maccus from NA

simply turn off real time protection on your anti virus software. (microsoft security essentials).

Basically whenever the SDD was being accessed, real time protection was scanning them for viruses etc, and thus the game files were being accessed multiple times whilst they were trying to load in game.

Such a simple fix. Game is now 100% smooth with no stuttering at all.

If you have a PC setup that can run any other game on high/ultra settings, yet have trouble with D3(micro stuttering during scrolling, etc), then this is all you have to do. Compatibility mode (Windows 2000 worked best for me) smoothed things out a bit, but nothing came as close to this. I'm sure RAMdisk is the next best method, but takes some time and know-how.

Just put the diablo 3 executable and/or the diablo 3 folder into your exceptions for anti-virus and anti-malware protection. That way you can leave the real-time protection on for everything else.
I just have to walk around a little bit to see if it's still there. My first Leap after starting a new game ALWAYS comes with a stutter. Micro stutters ruin the game for me. I hoped Blizzard had fixed it by now...
NONE of these fixes work. My computer is more than good enough. Many other games run smooth.
Maybe this is a stupid comment but why doesn't this game load more data directly from RAM memory, or use memory in a smarter way or something?

It seems like every little 'new' bit of data has to be loaded from harddisk first, causing stuttering while playing... It only plays smoothly when performing the same action, encountering the same type of enemy, or walking around the same place for the second time........ Everything that is 'new' causes stuttering
Same as before, not working.

Might be working for people with bad/slow harddrives. I've got this stutter with a SSD and very decent hardware, D3 is the only game with this problem. It's completely unplayable, stop fixing AH and Class balance, get your !@#$ together first and remove problems like this blizz.
Guys! if you have 16gb of ram you can simply do what i did and create a ram disk of say 8 Gb and mklink the mpq folder there!

the easiest way is the amd radeon ram disk, which will save at pc shutdown and load at pc boot automatically transparently after the first setup.

I already have there all the WTF, Cache, Interface and Screenshots (no more freeze when you screenshot) of World of Warcraft and i am very happy with it.

For lower ram systems i recommend doing a 1.5gb Ram disk and mklinking there the sound.mpq! Why? in my stuttering/short freeze i realized the problem was not at the actual effect freezing (from a newly seen npc ) but the sound of the effect. By adding the sound.mpq i had a perfect experience.

If you try the sound mpq mklink and the performance is way better, i see no reason to search the problems in graphics but in sound ^^.

Also, you don't need a usb flash like i read at some threads, you can just mklink the whole mpq folder to another hard disk, i tried that solution too, it works perfectly.
Old thread, but I just disabled AVG (anti-virus software), and after 1 year, I finally have this fixed!
no fix for me ;/
Wow!!! At last.

No lag
No rubberbanding
No WW disconnects
No micro stutter
100% smooth

I recently switched to Avast from AVG. Avast has a right click option in system tray "Avast shield control" to disable shielding. The difference is amazing. This post needs to be a sticky!!
Ok 1 thing that ive not seen in these posts so far is to set pagefile to RECOMMENDED, not even system managed, this helped me alot along with other things like to set like hardwareclass etc, do not set the priority to realtime as this can cause system instability, above normal or high at max, plz let me kno if u find the pagefile works for u :)
Only so much u can do for 1 game, its up to blizzard to fix it NOT U xD
playin on intell core 2 E4300 1.8ghz, 4g ram, ati HD 4670 with nps
FPS r as high as 85 in some areas all high setting (not smooth shadows)

BTW im WW barb, never had WW disconects but i pull full screen an even WW across the screen with full fury just to see wat happens an all is the same :) gl ppl
Thanks solved all issue for me!!!!!
22/08/2012 12:25Posted by ShakeNBakeUK
the Micro Stuttering Problem and i've mana

ooh SWEEEEET JESUS finally the game is playable for me :I

thanks a bunch
I've done everything and still have this micro-stuttering.

Using Windows 7 64bit, had the same on an E5800 and now Q8200 processor, 8gb ram, HD4850, only stutters when new info is loaded from the drive (does seem to be when accessing the sound files). I don't have actively enabled scanning running on my AV/spyware software, it's not something else like DEP causing this (Data Execution Prevention)?

Also could have Blizzard got around this issue by splitting the entire Sound.MPQ file into individual files? Obviously when the game accesses the MPQ file it's decoded by the D3 engine and the part of the sound it needs is played back (seemingly this is where the delay is, something interfering with that process). If all is immediately available then that might get around it?

It is odd though that Warcraft's game engine uses MPQ files as well and my rig plays them fine through that engine.

Join the Conversation

Return to Forum