Cannot install battlenet: Error code: BLZBNTBTS0000004A

Technical Support
I recently had problems logging in battlenet (never logged straight in. Usually it took atleast 3 tries) , playing games in hearthstone (could not find a match or it didn't let me access the menu at all) and connecting to diablo 3 servers.

These problems started only couple days ago.
To fix this I tried to re-install battlenet, but apparently It's unable to connect to the servers.

I have tried all of the steps in this troubleshoot: https://eu.battle.net/support/en/article/BLZPTS00006

- I have tried to install without active Antivirus/ Antimalware
- I have tried to install without any active programs in backround (mscofiq, untick "load startup items + disable all exept microsoft services in boot)
- I checked registery HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Microsoft/Windows/CurrentVersion for errors, but didn't find one (not 100%sure though)
- I Checked Windows firewall if it was blocking anything
- I'm using a wired connection
- Help pls :(
EDIT: I have updated Adobe Flashplayer and my graphics card drivers
Hi Joulumieli!

Thank you for contacting us.

If your issue spans across more than a single game, then I would definitely start with general general connection troubleshooting.

When it comes to antivirus, I would strongly recommend uninstalling it and restarting PC before testing login again.

Make sure to disable proxy settings too, as described in the article.

Best regards
Thank you for your reply,

-I uninstalled my antivirus, restarted and tried to update the launcher,

- I checked the proxy settings as described and it was already disabled.

-I did a full virus scan with Malwarebytes and it came clean.

-I checked the Windows hostfiles as guided in the troubleshooting,

- I also flushed the DNS

-Rebooted the router/modem and after this it started to download yay!- suddently it stopped and told me "trouble tranferring the data, we will try to do this automaticly"

-So I tried once again to launch the installer and this time it actually installed the launcher and the games seem to run fine. (my god I should have tried to boot the modem FIRST not the last thing)

-I reinstalled and updated my avira antivirus and I will post results if the games work
UPDATE: Seems to work just fine :) thank you for help and hope this helps somebody else

I thought id write this down clearly if some unfortunate soul might have the same problem :)
Okay so I'm on a military base and I cannot restart the modem (don't have access to it). Am I just screwed?
04/02/2019 13:05Posted by Sarphis
Okay so I'm on a military base and I cannot restart the modem (don't have access to it). Am I just screwed?
Hi Sarphis,

You might want to contact your network administrator and check with them if this is something they can assist you with. I would also recommend you try other steps as well though, the ones that you can do yourself on your computer - you'll find them here.

Note: I'll be locking this thread now as it was created in 2015 and links posted back then are not active anymore. Should you have further questions, please do not hesitate to open your own and we'll be happy to help. :)

_____________________________________________________________
Feedback? Click here! https://www.surveymonkey.com/s/Vyraneer

Join the Conversation

Return to Forum