[SOLVED] Could not connect to the Battle.net service.

Technical Support
Whenever I try to start my HearthStone (via the Battle.net Beta launcher) I get the following message.

Could not connect to the Battle.net service.
More help: BLZBNTBGS80000011 (3003)

From what I have read so far is that thise error code means that the servers are busy or under maintenance.
From seeing the forums people are playing on the Europe servers so I'm pretty sure that ain't it.
My account has the beta key activated (since yesterdaymorning) and I've downloaded the right launcher.

I've also done the thing where it says to untick "Keep me logged in".
I've put the next line in the config file (right place) as it was suggested in another thread. (Env = "beta.actual.battle.net")
I've basically tried most solutions offered on the forums. But it still won't launch.

Sidenote: it does launch when I change to Asia (Europe and America won't work) but then when it starts up it says that the sprites are working on it and has to close down...

Any solutions?!


Please provide us with the following information:

- the type of internet connection you're using (satelite, radio, 3G, landline)
- connection between your computer and your modem/router
- operating system you're using
- security programs you're using
- trace route report

Instructions on how to create a trace route can be found here.
Thanks for the response.
I'll try to answer as good as possible.

* Internet connection: landline (90Mbps, speedtest). Very stable connection.
* Connection computer and router: UTP (17meters, I know this shouldn't make a difference)
* OS: Windows 7 Ultimate 64bit
* Security Program; AVG (tried connecting with AVG enabled and disabled, no difference)
* Hardware drivers are up to date, same goes for the software and OS ones and the firmware of the router.

I would like to do a trace route report, but only WoW, Starcraft and Diablo are listed.
And google does not appear to be my friend in searching for the Hearthstone IP address.
Try creating a new Windows user account with administrator privileges and then try to start the game using that newly created user account to see if the issue persists.
I must say this was one thing I haven't tried yet before.
Sadly both my administrator and user account (with admin privileges) can not connect and still giving the same "3003" error.

For the record, on my account it says the following.

I assume this is the correct reading (key was accepted obviously ;))

Starcraft works and WoW should work (although since last month my wow isn't active anymore due to personal reasons)


This is fine. :)

Have you tried uninstalling Hearthstone together with Battle.net Desktop App and then reinstall both again to see if that helps?
I just tried that. Deinstalled and made sure that there were no existing register values that connect to the programs (using ccleaner)

Then installed the Battle.Net launcher (from my account) and it prompted me to log back in.
I got the same error message from the first and previous post.
Clicked "continue offline" to be able to actually installed Hearthstone and this went well.

Although there is a red bar on the bottom saying "We couldn't connect you to Battle.net. Some games and features may not be available."

Loggin in using the blue button that says "Connect" isn't working as it just gives a timeout timer and displaying the same message after.
has there been a solution to this. Im getting the same problem and even talked to blizzard on the phone for 30 mins doing a load of stuff to attempt to fix. We could not even find the cause of the problem
So far... nope.
Still getting the same error, and I have also figured out it's not accountbound.

I have a Warcraft account and a Starcraft account. A couple days ago I got a Beta key for my Starcraft account too so I joined in.

Tried logging into Hearthstone and getting the same error :/
Really frustrating that Blizzard has given me 2 Beta (working) beta keys and both of them are not working. Then I thought it had to be my computer and went over to a friend, tried there and couldn't get it to log in. Still the damn (3003) error...

If you find any solution, feel free to share cause this is annoying the hell out of me :/

When I click on "Asia" instead of Europe / America it lets me log in Battle.Net beta.. but when I attempt to start a game it's the Sprites that have prevented me to log in
Also mailed Blizzard a log for my issue (as they request on the forums somewhere). A week ago without answer so doubt they know a solution
I have this very same problem on mac.
18/10/2013 20:30Posted by Timmy
Hey i found the solution for the problem if u still need it

My friend, you are the only person who could help me with this issue.
No clue how you found out this was it but nevertheless... you did something Blizzard employees failed to do.

This was indeed my problem, thank you very much!!
can i have this support too? :s i am having the same problem...
I had the same problem and Timmy's solution worked like a charm! Thanks mate!
I am indeed having the same problem as you guys, though my hosts file was normal, and this didnt work.
Anyone help?
Same as me, my hosts file was normal yet i am still having the same problem?

In fact at the moment i have issues from logging into my battle.net overlay - it tells me there is a network error and then Hearthstone isn't even on my list of games!

Is this a problem everyone is having or?
Going to lock this as it's related to an older, different issue.

The current issue doesn't have a workaround, we're working to fix it. Please see our main sticky, here:

Let me know how I'm doing!

Join the Conversation

Return to Forum