Battle.net installation stuck at 0%

Technical Support
So I recently encountered the issue with heroes of the storm where it got stuck on waiting for other installations to finish, and I tried everything to get things working again, and as a last effort I tried selective startup combined with uninstalling battle.net client. But now that I uninstalled it, I can't seem to be able to redownload it, as it is simply stuck at 0% and won't move no matter what I do to it.
Helllo,

Can you try creating a new administrator account in Windows, logging into that, and then see if the installation proceeds there?

Let us know if that doesn't help at all.
___________________________________

Let me know how I'm doing!
https://www.surveymonkey.com/s/Lurdlespor
Hey! So I tried doing this but unfortunately now when I try to download the app it gets stuck on "updating battle.net" and doesn't move anywhere from that.
28/11/2015 08:04Posted by AuguryOfRuin
Hey! So I tried doing this but unfortunately now when I try to download the app it gets stuck on "updating battle.net" and doesn't move anywhere from that.


Hi. ^^

Delete Battle.net cache and tools folder
http://battle.net/support/article/6141
http://battle.net/support/article/6504

Disable proxy settings:
http://battle.net/support/article/7300083

Disable antivirus and firewall temporally. Close and uninstall applications like Hamachi or Tunngle.
I don't have any battle.net folders on my computer, I cleaned everything up when I uninstalled it. My antivirus is not reacting to it neither is my firewall, I've checked. And I don't have Hamachi or tunngle
Hello AuguryOfRuin,

28/11/2015 13:31Posted by AuguryOfRuin
I don't have any battle.net folders on my computer


Could you please double-check if you have Battle.net and Blizzard Entertainment folders in %programdata% (to reach it, press Windows + R keys, type %programdata% and then just hit OK)? If you do, delete them both and start the download once again.

Please make also sure your Windows secondary logon service is active and all required ports are open.

_________________________________________________________
Feedback? Click here! https://www.surveymonkey.com/s/Vyraneer
I got the desktop app downloaded but now I'm having trouble installing heroes of the storm. It says it's having trouble fetching the data...
When I removed those folders blizzard and battle.net the download worked by then after that first install it goes to the second install and is stuck at 0%
im stuck with the patch at 404 mb and i tried absolutely every step presented in every thread of this kind nothing worked so far and im waiting on the next auriel update to see if it works cause last time i had this problem a new patch came along and it downloaded easy the way it was supposed to.
Same
Deleting the Battle.net Cache Folder
Updated: 1 week ago Article ID: 34721
Relevant Games:
A corrupted cache folder can cause issues with some Blizzard games. Deleting this folder will not affect your game data and may resolve issues caused by outdated files.

Windows
Mac
Windows
Close open Blizzard programs.
Press Ctrl+Shift+Esc to open the Task Manager.
Click the Processes tab.
If agent.exe is running—or Blizzard Update Agent in Windows 10—select it and click End Process.
Navigate to the folder containing the cache directory:
Press Windows Key+R to open the Run dialogue.
Type %ProgramData% into the Run field and press Enter.
If a Blizzard Entertainment folder exists in the directory, right-click it and select Delete.
Restart the Battle.net desktop app and relaunch the game.

Join the Conversation

Return to Forum