Low FPS on good PC suddenly.

Technical Support
1 2 3 14 Next
I used to be able to get an average of 100fps, now I'm suddenly getting 70, dropping down 40 sometimes in fights.

I have the newest drivers; it's not an overheating problem; changing settings does nothing.

Any suggestions?

Specs:
GTX 970
FX 8320
8GB RAM
I experienced the same thing this morning.
Havent had any issues and always run at around 150fps.
Now, suddenly without me doing anything (such as drivers) its down to around 20-30...

edit:
Scratch that, turns out I had updated my drivers (290x) and with that it defaulted some clock and power settings...
Works as it should now again at 150+ fps
I've been getting overwatch FPS dips randomly since I updated to the "overwatch supported driver"

Might rollback to the one I was on, had no issues with overwatch FPS then. Makes me laugh how their "new" driver is worse for the game, yet it being released to support it!

Lmao.
Been getting FPS lag for no reason at all also

I also have the GTX 970 and just updated drivers.
I dont think its the driver, i played with the latest driver from nVidia without any problems first few days. This crazy fps stutter has just started happening recently for me.

Im pretty sure they changed something and it has caused some form of percormance leak or something, there is absolutely no other reason with the game working fine earlier :/
28/05/2016 12:58Posted by Frozeni
I dont think its the driver, i played with the latest driver from nVidia without any problems first few days. This crazy fps stutter has just started happening recently for me.

Im pretty sure they changed something and it has caused some form of percormance leak or something, there is absolutely no other reason with the game working fine earlier :/

Yeah I agree, I believe they accidently "broke" something in the small patch that was added.
I dont use nvidia, im amd... so it's an amd driver.

Regardless, this wasnt an issue for the drivers i had before, i rolled back and now the issue seems fixed so far.

The overwatch ready/support drivers from AMD are what is causing my random FPS drops, so maybe blizzard messed up if AMD and NVIDIA having issues with their new drivers, idk...
So it seems I have the same problem as you guys. I was able to play the beta no problem everything ultra now I`m on medium have turned down or even off most of the things I can in the AMD controll panel and my fps are horrible. So long as noeone is around it is mostly (random drops to 30ish) fine (60ish) but as soon as some other player is around my FPS beginn to drop. The more action the lower the drops (5-15ish)
AMD FX-9590
AMD Radeon 290X
16GB RAM
Win 10
Same problem for me guys, i already set the lowest settings on everything, but still big fps drops in matches, it's so annoying.
Hello,

Can I please ask for DxDiag reports from those affected by poor performance?
battle.net/support/article/request-for-system-files-dxdiag-msinfo-and-error-reports

We can use that info to investigate further, thanks in advance.
___________________________________

Let me know how I'm doing!
https://www.surveymonkey.com/s/Lurdlespor
DXDiag Link:

http://pastebin.com/raw/3MTt2Yuq
http://pastebin.com/raw/69urkE58

Issue since 26/05.
My DxDiag link
http://pastebin.com/z0rAG70w

no problems with the beta, but now i have huge fps/audio stutter every match and i tried to update and downgrade my drivers. nothing change
http://pastebin.com/6ZjexMJE

issue since 1 day after launch
http://pastebin.com/HWXDmpVs

issue since 1 day after launch, ive play overwatch at closed beta weekend invite...no problem then, so i buy the game and this !@#$ happens!
My DxDiag - same problem with fps as other players.
http://pastebin.com/QNvtwUfR
My DxDiag.

The game ran perfect during the beta, I have 100gb of recording, and not a single one of the videos I recorded during the beta had an FPS drop. But now it's dropping to 20 FPS everything 10-15 seconds.

I can play on the highest settings, and lowest settings and my FPS is the same, and still drops. All drivers updated, no overheating as I thought that could of been the initial problem, but my CPU doesn't really go above 50, nor does my GPU.

I am noticing a small trend of AMD FX processors and GTX 900 series cards having this issue.

http://pastebin.com/LK5cEZUD

Thanks.
Upgraded to a GTX 970 today only to run into this problem.

DxDiag + System Info
http://pastebin.com/VxCqGJE9

Just a note: This isn't just FPS drops, there are times where both the video and audio stutter at the same time.

Join the Conversation

Return to Forum