no characters visible in game

General Discussion
so i was playing ranked

get in the game, can't see anything really... just arrows moving around (like the ones that indicate where your team are)... and i could hear sounds and get shot/killed

after 10 minutes of that, characters start loading and I can see other players etc.

wtf?

is OW just buggy or was BNET getting DOSed or something? lost a ranked match because of that bull!@#$
Did you start the game and then immediately go to ranked?

It happens to me sometimes too, when I start the game and instantly go play a game my characters don't load for a while
You might need more RAM. Check your RAM usage (ctrl+shift+escape) then start game and see where it's at.
I had the same issues until I went from 4GB to 8GB. :)
Open Task Manager and see what's running in the background, if there's something chomping your resources it'll take longer for models to load.

You can also go through the gallery pre-load models and speed things up.
24/11/2017 06:27Posted by Agon
Did you start the game and then immediately go to ranked?

It happens to me sometimes too, when I start the game and instantly go play a game my characters don't load for a while


yeah, pretty much... subsequent games worked fine

as for needing more RAM, i have 8GB and a 4GHZ processor (pretty high end computer)

when I looked at task manager it was overwatch eating up all the resources (cpu and disk usage were 100% i think?)... think the game gets in a buggy state

Join the Conversation

Return to Forum