Starcraft II Technical Support

07 May Additional languages Hi guys, Is there any chance to get the single player in Czech or Slovak language? Or at least let community to translate the single player and bring ability to use these community translations? My daughter recently started to play SC2 (yay!) but she does not understand english much. We are from Slovakia. I know that we are a small market to be interesting, but there was some community translation to the Czech language. CZ & SK understand each other, so CZ language would be perfectly fine. Many thanks! nereusden0 07 May
06 May Ranked/Unanked buttons not working. Hi, I can't play the game today. It loads and all of the buttons work except for the ones at the bottom of each page which allow you to begin a match. The Unranked, Ranked and Maps buttons are greyed out (as they would usually appear when clicked and searching for an opponent). This problem affects all pages such as 1v1, 2v2, 3v3, 4v4, Co-Op, Campaign. All sections of the SC2 in game landing page. The buttons in the top menu and the options menu work just fine.MrHappy1 06 May
05 May Anyone here playing on HD 620 ? Yo, I'm running an i3 7020u, 4gb ram and hd 620. The game runs like crap. I mean, it runs ok on low (40+ fps when few units around), but when 200v200 units, I get 10-15 fps. Micro is basically impossible and I die. How much fps you get on HD 620, and how much RAM you have ? God bless.realFuture0 05 May
11 May Custom announcer problem in arcade Recently i bought the Lowko announcer, I like playing arcades, mostly Monobatles, and others. However even when equipped in this arcade the announcerd does not work properly. Why? Should be working no matter the game type, money well spent right? What can i do?MrKilljoy2 11 May
14 May Unable to unlock new achievements due to WOL:BRUTAL Key message: Would it be possible from Blizzard side to implement a patch where bnet just checks if you have completed "Liberty Completionist: Brutal" and, if so, sets all achievements of the category "Wings of Liberty: Brutal" (and all other difficulties) to completed? (Alternatively: remove them. Other campaigns already do not contain them) I have finished "Liberty Completionist: Brutal" (Complete all 29 Wings of Liberty campaign missions on brutal difficulty.): https://imgur.com/a/o2cIIds Therefore, we can conclude that I completed all 29 Wings of Liberty campaign missions on brutal difficulty However, the "Wings of Liberty: Brutal" and the "Wings of Liberty: Hard" achievements have a different opinion. They are not convinced that I completed all missions on brutal difficulty: https://imgur.com/a/yXxh3os Sadly, I am unable to convince them that I did. I replayed the Liberty campaign multiple times on brutal difficulty without any progress in this achievement so far. It even looks like it locked the completed 5 mission step, but forgot the 5 missions again: https://imgur.com/a/4j87JZK This prevents me from getting all achievements for Wings of Liberty, which prevents me from getting the new "all" achievements. In summary: I am unable to unlock the Wings of Liberty: Brutal achievements. Therefore, I am missing 4 achievements in this category. Therefore, I am unable to unlock the new "Give Me Liberty" achievement Therefore, I am unable to unlock the new "Visit the Koprulu Sector, They Said" achievement In total, due to the unlockable Brutal achievements, I am unable to unlock 6 achievements. It would be really nice if there can be some bugfix, because the situation gets a bit sad now with more achievements depending on the brutal achievement. Would it be possible from Blizzard side to implement a patch where bnet just checks if you have completed "Liberty Completionist: Brutal" and, if so, sets all achievements of the category "Wings of Liberty: Brutal" (and all other difficulties) to completed? (Alternatively: remove them. Other campaigns already do not contain them)reh2 14 May
05 May StarCraft 2 exit crash Hi don't know if anyone else is having this problem but recently when I exit the game I can't do anything as it is frozen, the only way to get out of it is to restart the pc or sign out and it's very annoying.WarLord43 05 May
05 May Co-Op refuses to start. Judging from in-game chat, there are multiple people with this issue at the moment. In my case, it goes like this: Two players form a party for Co-op missions. Both players declare they're ready and get marked as such. The game shows "Initializing Co-op" The game shows "Searching Co-op", which is clearly a bug, since the missions only allow two players and so a party of two never has to search for more players. The game undoes the ready state for no reason, deciding that both players are no longer ready, and the cycle repeats until players give up. Will this be fixed soon? The game is literally unplayable, and unlike on the Factorio forums, this is not an ironic joke. Dear Blizzard, if you enforce one version and reliance on central servers for everyone, those servers must not break, especially not twice within less than two weeks.Vandroiy2 05 May
16 May Stutter on "Dark Whispers" Hey. I get this serious stutter every two seconds or so on the aforementioned single player mission (First Protoss prologue mission). Starting roughly the moment Kerrigan's base is revealed and her army attacks. The stutter stops completely when she is finished with her attack, and her base is covered by FOW again. The stutter is not connection related, I went offline and it does the same thing. Played through both WoL and HotS with no problems at all. And also played through this same mission and the Protoss campaign a year earlier, with absolutely no problems. For now it seems mission-related. I've tried a couple of solutions, like running the 32-bit client, running in windowed fullscreen, disabling all unnecessary background programs and services etc. All the latest drivers are installed. Graphics settings have no effect on the stuttering. Also tried the "scan and repair" -function. Any ideas would be greatly appreciated, since nothing obvious seems to solve this particular issue. Intel Core i5-2320 - 8GB GTX-560 TiBloodInEyes4 16 May
16 May Why is this? I purchased my copy of SC2WoL before it was free and i got no skins ?crynet3 16 May
03 May Zeratul coop commander graphic bug Hello Blizzard, im a big fan of your game, specially for your extreme care for details in units, campaing and SO much more. Im a guy that loves such things, and now ive found some bugs in zeratul coop commander. 1.When the passageway structure is about to finish building, it shows a bright white color that none of the other structures show upon their completion, and then, it goes back to its normal dark green color. 2. When summoning a tesseract monolith on the battlefield, there is no building animation, only a stuck frozen image of an initial warp and then, suddenly, the monolith appears. Would love to have this two pesky bugs out of the way please. Many thanks in advanced!!!!!jose3 03 May
03 May Very Disappointed in Blizzard... I am Very Disappointed in Blizzard... I have had my Ultra Wide monitor for over a year now and I can't play StarCraft 2 with its native resolution. And the only response they provide "oh its unfair" its a video game! not the Olympics, Even though to that I say I don't care about competitive gaming, there is Single Player, Coop Games, Unraked PVP and keep 16:9 restriction for your medal and whatnot. Wake up Blizzard its 2019 ! You are stuck in the past!Belus3 03 May
02 May Cannot make custom game in MacOS When I try to make a game to add friends or AI, maps will not load. When for some reason they do, I will not go farther than the circle that keeps spinning forever. I am playing under MacOS High Sierra. Mojave is not a solution, since I tried updating. I uninstalled the game couple of years ago when this same issue began, and it seems not to be solved even today.AngerFist0 02 May
03 May Rearranging command card I don't know if this is the right place to ask, so excuse me in advance if I put it in the wrong place. Hello, I've recently been told it's not possible to rearrange the command card in this game like it is in Warcraft 3. One huge reason why I've not come around (even though I tried several times) is that the control layout is notably different. I can't grow comfortable with the default arrangement, I feel like I'm playing on a controller or a similar device that I'm not used to. Would it be possible to add this feature to the game at this point? It's very important for me and a few of my friends who play RTS daily, because without a control layout we understand we can't really make it work. We keep making stupid mistakes like building the wrong units or buildings, even pressed the Detonate key [Z] on my Baneling group when I wanted to follow (Z is my move command in Warcraft 3). It's really frustrating to deal with this. I don't know the implications this might have or if it's even possible to do right now, but I believe asking is worth a shot. Thanks in advance.Abaddon2 03 May
01 May does starcraft 2 use tcp for 1v1 game data Do starcraft 2 use only udp for game data ? I found tl article which says it uses only udp https://tl.net/forum/starcraft-2/117158-some-notes-regarding-sc2-networking And than i found some computer science paper that says it uses udp aswell. http://choongsoo.info/docs/starcraft2.netgames12.pdf That would be great, because you can't disable nagling in windows 10. I used wireshark to capture packets and there are only ack and psh packets for tcp, which is strange, because i just read it used udp for game data and tcp only for downloads and battle.net and i had both battle.net and agent.exe off. So what are all those ack packets for. Strange.IIIIIIIIIIII1 01 May
01 May Entering the lobby problem Hi! I have a problem with the game on my PC. When I try to make private lobby, start 1vs1, start actually any game, it says 'entering the lobby' and circle moves all day long and nothing happens. I tried some tips from forum with connection settings, reinstalling game, running the game or battle.net launcher as an Administrator and still nothing helps. Can I somehow solve this? Thanks for any help or tips!RooTy2 01 May
01 May Commanders level 0 Installed Starcraft 2 now on my new computer, and when I logged in after not playing for a while.. All my commanders are level 0?Mrcookie5 01 May
01 May Commander Deleveled To Level 5?? StarCraft 2 Free Commanders ( Kerringan / Reynor / Artanis ) capped level. "you must purchase this commander to continue level up"?? Anyone Know about this?? StarCraft 2 WDYM?TheOneFox33 01 May
30 Apr [BUG] Co-op xp partially reset Just finished a mutation that showed by Abathur go from level 13.5 to level 14, when I clicked off the stat screen he reverted to level 13 flat, no xp progress at all, 0/120000 (and all other commanders are reset to the beginning of their current level) Reset the game to see if it would update my levels to where they should be and it didn't. Real pain to level as it basically took away a good few hours of work on my characters.Lycial10 30 Apr
29 Apr Crash on startup So after a fresh install of windows, my game cannot make it past authenitcating. I have tried all of the troubleshooting steps regarding crashing to desktop but it did not help.Marc9 29 Apr
29 Apr SC2 2560×1080 resolution support I need 2560×1080 resolution support for StarCraft 2 for my Ultra Wide monitor Blizzard please fix you game, its 2019.Belus2 29 Apr
28 Apr Old unused account with campaign Hello, I assume that this is the best place to ask about this but if not please tell me where I have to go... Quite a couple of years ago I bought HoTS and used the code on my fathers account since he had WoL, now I still have the physical copy of HoTS and after finishing the WoL campaign I wanted to start on the next one, however the digital key has already been used. I would like to know wether or not it is possible to use the physical copy of the game or transfer the campaign from the other account to mine to enable the HoTS campaign or am I just out of luck?Area1 28 Apr
27 Apr Co-op Mutation in EU is down I can't play mutation in EU. I asked in chat if I was the only one. I wasn't. A lot of people also experienced this issue. While hovering PLAY button i get this message: "Not available while game is initializing game mode." Please bring last mutation. Cheers :)Thought5 27 Apr
26 Apr BattleNet can't locate SC2 So today, when I turned on my BattleNet app, it says that SC2 is not installed (and it is). I go to locate game, select the correct folder and then the button Install Changes to update. I click update, and it says 'Something went wrong between our server and your client. Give it another shot.' an the Update button switches back to Install. Is this something related to some kind of Maintenance which is not reported in the app itself? Or is it something related to my installation?ErgoProxy29 26 Apr
25 Apr Stutter with Great internet/specs I have 7 cores/Nvidia GTX 1070TI I have tried to pathping/trace I have tried running compatibility mode with windows 7 I have tried running it as 32 bit w/without compatibility I have lowered graphics (Was not the issue anyways) Can anybody help, I would really like to enjoy this game, its a bit hard to with constant lag stutters. ...Physcozerg4 25 Apr
25 Apr Unable to locate or re-install the game Earlier today when the connection issues started happening the game crashed on me and ever since my battle.net is no longer able to find the game in the folder. I've tried to use the scan for games option or just the locate and select my starcraft 2 folder, both result in the Unable to Locate Game error (error code BLZBNTAGT00000AF0). A solution given on the error page is to run it from the game folder itself through the .exe, this gives me the exact same error. So I figured I would just re-install the game, and when I try to delete the old starcraft 2 installation through my control panel it takes me to the battle.net client asking me if I want to uninstall, which is instantly aborts due to not being able to find it. So can I still try something to make the battle.net client find my installation and if not, how can I delete this old installation? And if I have to re-instal the game, I own the legacy of the void on cd, does installing from this install most core game files such as wings of libery and heart of the swarm? Because that would reduce the total ammount of data I have to download by alot. And installing from a disc is a lot faster than downloading for me. Thanks in advance!Drynix18 25 Apr
25 Apr How much RAM it consumes ? Hi, can someone who's running the game on high settings or above tell me how much RAM Sc2 consumes ? I'm running on 4GB at the moment and it really hurts, I'm planning to upgrade and want to see if I can get away with only 8GB or I have to go higher. Thanks.realFuture6 25 Apr
25 Apr missing forum post Hey, I created a new topic a few minutes ago in this forum, but it doesn't show up anywhere.Legacy3 25 Apr
25 Apr Please fix the "Entering Lobby" bug Step to reproduce: 1) Enter an Arcade mod, leave before the end ("Victory" or "Defeat"). 2) Try to enter another Arcade mod or create a lobby. 3) You're stuck until you're logging out or exit the game. The bug is here for a looooooooooooooong time and it's the most annoying one. Could you please finally do something about it? ThanksNucreum1 25 Apr
24 Apr Starcraft 2 big bug with install/update Starcraft 2 says to install my game or locate it, I got to locate I select the Starcraft 2 folder and click ,,ok". It says update, I click update it says waitign on another installation or update and then it says something broke. 3 days ago I played the game fine. If anyone can help It would be very much appreciated. Thx in advance!ThePigeon18 24 Apr
24 May sieged tanks wont stop killing own building Hi I'm not sure if its a bug or not, but its really annonying. When playing terran and selecting all tanks (sieged and unsieged) and misclick on your own building - and you immidiately after click on move/attackmove and "free area" the tanks keeps attacking own building.. this means that you can accidently kill own or allies building because you missclick. cant remember if clicking "S" or "H" would stop it.AverageGamer4 24 May
23 Apr Co-op Commander dont get experience Ive played two matches co-op, without getting any mastery experience. I've played at my maxed out commanders Stukov and Tychus. But none of the matches added any experience to my mastery level. Both games were victories, no connection issues that i could see. The first game the other player dropped out in loading screen, but the second game both me and the other player was in the game until the end. Can you please check what is wrong. So i dont waste more time into rewardless gamemode. :/ Edit: Saw that on US server there were people with this problem, but no response from blizzard yet on those posts. Regards RuggeRugge6 23 Apr
22 Apr 2 ACCOUNTS, 1 LOGIN ANNOYANCE EU When I log in starcraft 2 using battlenet launcher it always go to a account where i have no achievements nor levels in coop. I logout inside the game, put my password again and im present with a windows called "Select A Game Account" with two options: Starcraft II1 and Starcraft II2. My progress is all in Starcraft II1. But the damn game ALWAYS connect to the Starcraft II3 account and i have to always logout and log in the Starcraft II1 account. How can I make the Starcraft II1 account the main one, the priority, so i don´t need to be annoyed to logout, input password, etc just to play the damn game every time i go play. The same issue was published in the US BattleNet Forum and there was no solution for it except deleting the second accound. Seems like I am having the same problem.....Palladin0 22 Apr
21 Apr Max resolution for SC2 Recently I bought a new 34'' Widescreen monitor. All ready and excited I launched SC2, only to find out it did not support the new 3440x1440 resolution that my new monitor had. A little bit disapointed, but.. fine. Today I re-installed WarCraft 3, only to find out that a game from 2002 did support the higher resolution. What's up with that? Why does SC2 not support it?TJL9 21 Apr
20 Apr Bought HOTS Physical copy but code already claimed? Hi there, I was wondering if since the WOL campaign is free if I could just buy the HOTS game, I've already done so but the authentication key won't get claimed. Did I need to have bought the WOL game now to use the HOTS game?Keesh1 20 Apr
19 Apr Problems with APM counter - remastered skin Hellow, I met a problem with not working APM counter during the game. I have chosen the remastered version of my interface in game but for some reason the APM counter always show "0". Basically I would like to have an option to see my APM during game, without using some kind of 3rd party application. Is there a possibility to have that kind of APM counter in sc2, am I doing something wrong and that`s the reason why it is not working properly, are there some kind of special options that I could not find? Of course I tried to check every options in game several times without success, I was also searching a bit on forum and also trying to find some kind of tutorial on YT but didn't work out. Here is link to the image. https://imagizer.imageshack.com/img924/2068/sHgIjf.png Thank you for help. Best regards, Soul P.S. If someone want to answer to this topic saying why I need APM counter in game, than please save it for your self. The topic is not about using it or not but about having an option to see it when you need.SoulOfDark2 19 Apr
19 Apr Mouse Click stops working Hi I've recently just started palying the game again after a few years out. I'm playing on quite a dodgy old laptop with an Intel HD3000 graphics card (I only mention this because I have a feeling poor performance may have something to do with the issue). As I'm playing, left and right mouse clicks become more and more unreliable. Hovering the mouse of a unit will highlight the unit but I'm unable to select it by clicking. If I click a bunch of times it will eventually work. Moving workers in vespene geysers is particularly unreliable for some reason. I'm using Windows 10, all graphics settings in SCII are at their lowest. The laptop is connected to a monitor which means the game is possibly trying to run at a higher resolution than I have windows set to (I don't really know if that's a thing, I ain't technically gifted haha).Jockmcplop0 19 Apr
19 Apr Sound issues since Windows 10 Dear i've seen some posts before about starcraft 2 and sound problems. I tried alot of the workarounds allready without succes. I'm using a headset tried usb and bluetooth but both have the same issue. when i start the game everything is fine, after a while i'm getting static, and it grows worse untill eventually all the sound disapears after i shut down the game i take the issue also to windows. Before the game everything is fine, and i only have it in starcraft 2. tried repairing my files, dx diag finds no issues, i have the latest drivers. Also checked the enhancements (loudness equalization)of the device and unchecked allow applications to take exclusive control of the device. I also turned off the diagnostic service in windows 10 but i have no luck in fixing the thing anyone got any ideas?Deathstroke2 19 Apr
19 Apr Auto-casting with rebound grid keys Auto-cast abilities (such as SCV's repair) can be toggled on and off by pressing Alt + ability key. I use a grid (QWERTY) key layout, but I want to rebind the repair key ("C" by default) to, let's say, "V". But when I press Alt + V, auto-cast doesn't toggle, and when I press Alt + C, it still does work, even with a hotkey rebound. The auto-cast is stuck with "C" and I can't find separate binding for auto-cast anywhere. My question, is there a solution for assigning repair auto-cast to Alt + V or any other key or combination?Parapheen0 19 Apr
16 Apr Drag scroll jump bug Windows 10, i7-8750H, GTX 1050, SSD Samsung MZ-76Q2T0BW. Drag scroll randomly jumps huge distances. Reducing mouse polling rate to 125 helps a bit, but it is still unplayable. ----- Rebinding "Drag scroll" to a keyboard button does not help. Changing mice and usb ports does not help. Changing windows cursor settings does not help. Changing windows compatibility settings for sc2 does not help. (High DPI settings, disable fullscreen optimizations.) Changing in-game graphics to the lowest or the highest does not help. Enabling/disabling Vertical Synchronization does not help Enabling/disabling "Reduce mouce lag" does not help. Changing priority of the starcraft process to the lowest or realtime in task manager does not help. Changing processor affinity for the starcraft process to a single cpu core does not help. Disabling Nvidia in-game overlay does not help. ----- Same issue with more details on US battle-net: https://us.battle.net/forums/en/sc2/topic/20771107519 ----- A video demonstrating this bug: https://www.youtube.com/watch?v=Ap19Ftq610g ----- Same issue in LiquidSnute's twitter: https://twitter.com/liquidsnute/status/949682788105687043?lang=enkoR0 16 Apr
13 Apr Can not reach... Can not request issue. Filled in all, but I can not request my issue. (game offline). If I can not fill in and send, then I want to send to page "can not send". But where is that page?! :) Really annoying not be able to get information/help! Is this info coming forward? I do not know....Bandit1 13 Apr
12 Apr test a test please eraseBlowDevilUp1 12 Apr
12 Apr Low microphone level in-game I have a Steelseries Arctis Pro 7.1 headset and the microphone is very low in-game. There is no issues with the microphone since discord and other applications doesn't have this problem. I have tried to mess around with the settings both in-game and in windows without any luck so far. Anybody have a solution?Frederik1 12 Apr
12 Apr Received previously earned achievement again. The Feats of Strength achievement for purchasing a co-op commander Karax was on my account for a while since I owned him previously, but today I received a notification about this achievement again. Thought it's just a visual bug, but the achievement has actually shown in my recently acquired list on 11/04/2019, and it has overwritten the previous achievement in the category itself, as there's only one. I think it may be somehow related to issues with the 100% campaign achievements added yesterday, which I didn't receive yet for whatever reason, but that's just guessing.ḺiXyFØx1 12 Apr
12 Apr Game randomly started stuttering Out of nowhere the game now stutters every 10 seconds or so for about 1 second i have not changed anything on my PC in the morning it was fine and now it stutters.When it does my GPU drops to 0%. Its only starcraft 2 CPU and Ram are fine My hard drives have plenty of space I have updated all my drivers Its not an overheat problem iv reinstalled the game I have disables all overlays Specs: 6GB Nvidia 980 TI AMD Ryzen 5 1600 16 GB of RAM @ 2933MHz halpDarkZephyro4 12 Apr
12 Apr Twitch prime loot I got the first one, but Swann: Machined Bundle still didn'a appear ingame...Itharael1 12 Apr
15 Apr No Feats of Strength after Patch 4.8.4 I completed every campaign on brutal, got every campaign-achievement and completed every Nova mission and accompanying achievement. According to the Patch Notes for Patch 4.8.4 I should have gotten all Feats of Strength associated with this. Yet, they do not show up when I log into Starcraft II with installed Patch 4.8.4. I tried logging out and in, no change. I'm on the European server if that makes any difference.iago9 15 Apr
10 Apr Bug report (Starcraft 2 Heart of the Swarm Campaign) Hi! I found a bug in Sc2: HotS Campaign at mission 2 (Back in the Saddle). When Kerrigan and Raynor have to defend the Tram Engines, the HP at the top of the screen (when any unit hit the tram) drops instantly -300 HP.Crafting3 10 Apr
10 Apr Bug report co-op after 4.8.4 After this new update, Vorazun's recall in co-op does't work ... After i used it, my units only got transparrent :) I got a print screen but i don't know how to post it ..Jonaka1 10 Apr
09 Apr Fake mobile game advertisement on Instagram Just came across this rather funny ad on instagram on a random game called ''Zombie Strike'' ... that zombie looks awfully alot like Kerrigan... i don't know i might be wrong you guys should take a look.. I don't think they asked Blizzard for permission either. screenshot: http://prntscr.com/n9608s This might not be the place to post this, but i just wanted to bring this up.DoctorThrax1 09 Apr
09 Apr Mouse inactive Since updating to macOS Mojave, now v10.14.3, the game will load but the curser stays in the top left corner despite any mouse movement Any suggestions?Krylos1 09 Apr