Error 2:-1073741819

Starcraft II Technical Support
Hello!

I've got the folowing problem, when i tray to start starcraft2.

When i click the Battlenet client the play button i've got an error message. "Starcraft 2 failed. Close the program. The uppear another error message: "An error occured starting Starcraft II. Please try again. (Error 2:-1073741819)

I do the following:
  • Reinstall Starcraft 2 (about 5-10 times, allways to a different location)
  • Reinstall Battle.net client (5-10 times)
  • Every time when i unistall the client, and the game, clear the registry too. Every single registry entry which are contain the following words (Battle.net or Blizzard or Startcraft or SC2)
  • Update the video card driver
  • Run chkdsk, defrag,sfc.
  • Close the background programs, disable my firewall, and my antivirus program.
  • Run scan with Malwarebytes Anti-Malware (nothing found)
  • My other Blizzard game (D3) is working perfectly.
    The Starcraft editor is working.

    Any idea how can i solved this problem?

    Oh and i forgot. The SC2 is up to date.

    And sorry for my english :/
    Hey Drazdul,

    What happens if you run the Battle.net desktop app from a new administrator account?

    Creating a New Administrator Account
    https://eu.battle.net/support/en/article/creating-a-new-administrator-account

    Also, are you running the 32-bit or the 64-bit client? If you're running the 64-bit client, can you try the 32-bit client and see if you're still getting that error?

    Toggling 32-Bit Mode
    https://eu.battle.net/support/en/article/toggling-32bit-mode
    I tried both.

    The same error.
    OK, can you give these a try, then see what happens?

    1) Run in Administrator Mode.
    https://eu.battle.net/support/en/article/run-in-administrator-mode

    2) Run the Battle.net desktop app in compatibility mode for Windows 7/8.
    • Right-click on the "Battle.net Launcher.exe" file in "C:\Program Files (x86)\Battle.net\".
    • Select "Properties".
    • Open the "Compatibility" tab.
    • Check "Run this program in compatibility mode for" .
    • Select Windows 7 from the dropdown box.

    3) Even though you've already done several re-installs, try a Scan & Repair on the game files and see if it repairs any damaged files.
    https://eu.battle.net/support/en/article/repairing-blizzard-games

    4) Disable all non-Microsoft services and boot into a selective startup.
    https://eu.battle.net/support/en/article/shutting-down-background-applications

    5) Check for integrity violations → sfc /scannow

    6) A full re-Install of the game in another Windows user account (administrator).

    7) These suggestions → https://eu.battle.net/support/en/article/battlenet-error-2

    I hope that any of these suggestions help you resolve your issue, or at least give you a clue as what to do next. If it doesn't help at all, I'd try contacting support directly.

    Contact Blizzard Support
    https://eu.battle.net/support/en/help/
    Its all stupid advice is bullsh1t...
    Im spend so much time for search and solve this problem. And no results...
    If u have "greatest" radeon vodeocard and once update this fking magic divers to 15x version just rolldown to version omega 14.12. Im do it and starcraft2 (and hots) can run again! (win7 x64)
    I change to 32 bit and its works, but when i switch back to 64 bit is same error again.
    Locking this thread as it's from October.

    Can you please freate your own thread Amis, and let us know exactly what happens, and what steps you've tried?

    Thanks.
    ___________________________________

    Let me know how I'm doing!
    https://www.surveymonkey.com/s/Lurdlespor

    Join the Conversation

    Return to Forum