Maps wont load & Initializing game mode forever.

Starcraft II Technical Support
Starcraft doesn't load maps in costume game and when I try to play anything but campaign it just says "initializing game mode" forever.

I've had this issue for several years now. I just haven't cared to write a post as I thought it would be solved.
It all had been working for at least half a year after starcraft 2 came out. Im playing on an old laptop from 2008, but it runs diablo 3, wow, hots and starcraft 2 campaign on low settings just fine(except large raids in wow).

We can rule out router problems and reinstall fixes as I have done those things several times since this bug(I assume!) appeared.

I run windows 7 ultimate and have done so for a very long time. It has worked on this exact setup before.

I must be honest, im really disappointed in you Blizzard. Always heavy balance issues or weird bugs that apparently takes years to fix.

Using Broadband. Cable. Windows 7. Free updated version of Avast.

Oh I nearly forgot. I would like help with another issue(maybe the same you tell me). Im half the time having trouble logging in to starcraft 2. It started 6-12 months ago by some battlenet upgrade I think and I started sometimes having failed login attempts when trying to log into battlenet. Im not using the remember me settings. And now its gotten so bad that everytime I want to play Heroes of the Storm, Im logged into battlenet, press play, then it tries to login (in hots) and it fails, and I have to set region and write password to login. At rare occations, I even have to do it several times. Please tell me what you changed/why it is so and/or just fix it. :-/
Hi, I have the same problem. I made a post here 3 days ago, but so far no luck in anyone responding:

Is that maybe the same problem you got? Or some form of it at least. It is exactly as if there are connection problems/ slow connection in the menus. But it cannot be my connection as I play other games online without a problem. And I do remember when SC2 launched it use to work great and back then I had a way slower connection.

Anyway sorry I cannot help much, I decided to play SC1 mod and SC2 campaign in the mean time, guess I cannot yet be too bothered to try and troubleshoot it. But guess I should.
Hey Hume

Wow 3 years ago. Yeah I cannot play anything but campaign. It is really weird. All other blizzard games work fine 95% of the time.

Some techical support or troubleshooting too much to ask from you Blizzard? Pretty please. I bought all the Starcraft 2 expansions and the only thing I got from it was the campaign. Please look into this!

No, 3 days ago ha. Well at that point in time anyway. I saw some people suggesting changing your server region. Some others say changing it, logging on/off, then changing it back works for them. But then again it does not seem to work for everybody. And when you try and change it it says progress will not be carried over or something of the sort. So I haven't tried it myself yet. Not sure if you lose everything or not, why I haven't tried it.

I must say though I am surprised at how no Admin responds to this. To me it feels like kind of a big deal. Only other Blizzard game I play is Diablo, which does work fine. (along with anything else internet related) Just SC2.

Since we seemingly the only two with this problem on this forum, how do you connect to the internet? I know I use to connect directly with a landline. Now I use Wifi. Maybe we can get on some kind of common ground to why this happens to us.
Hey again

Yeah I use a landline (cable). But yes I have tried switching region, at first try I could log in and it did'nt help anything. Then I tried another region and then I couldn't login, stuck on authentication I think it was.
But I guess if I go log into SC2 now it can, but I will still only be able to play campaign.

Sadly, im not surprised they haven't answered. It's typical. But I hope they change my view on them and come help us out with this problem(s?) I think its something caused by Blizzard. Otherwise why does every other game work and why did SC2 work just fine for about a year after it was released, on this exact same computer, same operative system, same connection...

Help Blizzard!
So I'm taking it you're on Windows 7. Anyway, I just thought I would try running SC2 as Admin. Suddenly it actually worked fine! Could load maps on custom and everything. This could just be luck though, but right click and run as Admin and see if it works for you too?

Will have to test it for a day or two though since it might just be a lucky moment. Will see.
Hello everyone,

Please try to run the game as an administrator as Hume has suggested. Also please try and troubleshoot the connection following this link.

Take care.

Help me get to Exalted with the Blizzard faction
Hi Yes it worked! The running as administrator. Thanks! Amazing it was just that :O
I cant click the play, ready button or join lobby. They are all grayed out. Maps won't even load. I can't even play versus ai mode.
Win 10 machine here.
I port forwarded. No luck.
Set the game to launch as admin. No luck.
Set the blizzard app and launcer to also launch as administrator and restarted them - BINGO!

All maps appear and no errors
03/04/2017 11:10Posted by Blizzard
Hello everyone,

Please try to run the game as an" class="bml-link-url2">administrator</a> as Hume has suggested. Also please try and troubleshoot the connection following this [url=""]link[/url].

Take care.

Help me get to Exalted with the Blizzard faction
<a href="

This does not work. Please help!
So I could fix the problem. I hope this helps
1.In Network and Internet in Control panel
2.Internet options-->Connections tab--> Lan settings-->Disable automatically detect settings
Hope this works :)
Run blizzard app as administrator works for me!!!
when I run the starcraft app with administrator it just opens the battlenet app, back in circles I go:)
Still not solved. I can not play with friends, which was the intended purpose. I want my money back.

Join the Conversation

Return to Forum