installing of new version

Starcraft Remastered Technical Support
I have brought the remastered version when it was first memtioned. how do I install it now
I have bought the remasterd version. How do i install it?
Same here - pre-purchased.

SC remastered and shows in my games list as 'available now'.

Click on available now - the only option to appear is 'purchase'. If I click on purchase it say 'hoorah' you're fully upgraded and chucks me back to where I started.

So, same question as above - now several days after launch - how do you actually play the game??
How can i play good old version. Game stopped, cant start it.
just click at the cross on the ad that appears when you select starcraft in the app.
So, same question as above - now several days after launch - how do you actually play the game??
same here got the icon on desktop .starcraft is in the blizzard app but no remasterd version showing . will not let me start the game at all starcraft eather.

any help would be appreciated
I have the same issue. Pre-Purchased the game and I cannot see the game in my account
Same. Who knows?
same here
Ahh well never mind, Remastered was a nice idea. Doesn't appear to work and zero comments to help from support - Paypal refund initiated.
Just bought the game, and it wont install. My app only tells me to buy the game, and I already did?? Kinda frustrating to head in to play the game, only to be held back cause it don't work.
Same here, bought it pre-order but cant play it like you guys.
Same here. Pre purchased the game but now even the old game I cannot open. Tried going to support but seems running around in circles. This is frustrating. Good thing I wasn't the only one with problems.
Bought starcraft remastered, logged ont the app, instead of getting the option to install I get the question if I want to buy it. Very frustrating

@Support please advise
Same as everyone above. Bought the game and downloaded the game as instructed.... game doesn't start, just brings you back to the buy game page. Please advise.
Ok, guys, let me help you all out here. It's strange NO ONE of the moderators here came to the rescue.

What you are describing I experienced myself. Well... almost; since the first time I installed it I was already playing the old one, and then continued along, it took a while (until I exit and restarted it a day later), to notice what you are all experiencing now. Indeed, at first glance, it would seem buying the remastered and then installing it gets you in a loop, where all you see is 'click to buy' after which it says you already bought it (which is correct), which then brings you back to the original window. No way to actually PLAY the game, since no 'play' button is to be seen.

The answer is, and keep this good in mind: what you see when you open the Blizzard app is *AN AD*. Yes, in their infinite wisdom and urge to let you buy the remastered game, they placed an advertisement right there and then. Thus, IN the window of the Blizzard app, they had the fantastic idea of filling it completely up with a screen-ad with the "Relive the rush" on it, and THAT is what you see.

Since it fills the complete (inner)window of the app, it looks like it's all there is to it, but it just covers up the rest. The way to get rid of it, is to click on the orange cross in the upper right corner of the screen (that is to say, of the ad in the screen). Then it goes away, and you see the *actual* stuff under it in the app, and there, there is a play-button. Click on that, and your game starts (click on F5 to get the remastered version if you start in the old Starcraft).

So click on your icon or blizzard app, and when it opens click away the screen IN the app (with the orange cross on the right). Problem solved.

Join the Conversation

Return to Forum