"not available while initializing game mode"

Starcraft II Technical Support
Hello..
Yesterday after a match my game stopped working, i can play the campaign but multiplayer stoped working.
i can see the custom rooms but they have no pictures of the game or the names of the players and i cant join none of them..
When im trying to play co op the ready buttom is grayed and i cant press it.
when i put my mouse on it, it says : " Not available while intializing game mode".
( Same for versus) .
hi

my one also doesn't work ,
i am getting sad
Same problem.
Marked As Solution
Heya,

Please check your ports for me, and make sure they are configured correctly. If you have any security applications active, disable that for now (temporarily).

Before testing it again, check that you run the app with Administrator rights.

If that still does not help out, try switching to 32-Bit Mode.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi
it happened to me as well but fixed itself after waiting for a while.
Nenyasqi thanks, it worked when i disabled my security applications and started it as adminstrator
Good to hear Snuper, thank you for the update! :)
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi
Hey i have this problem and i tried turning off security apps and using it in 32 bit mode. none of this worked and i dont have administrator access. id like to try the ports thing but ive absolutely no idea how they work can someone help?
Hey Im still having this problem and I've tried running in 32bit mode turning anti-virus apps off adding new ports for SCII nothing worked
32 bits, administrator, Antivirus firewall exception.. nothing worked..
Same problem I have. Do you find guys any solution to fix it?
hey there so the problem seemed to be solved for my by running the Battle.net app as an administrator, initially i was running the game as an administrator and didnt help it would just run the battle net app and nothing would change..

but running the app as an administrator helped

https://battle.net/support/article/24075

i hope this helps one of you guys as well
11/01/2018 14:33Posted by atomicbomb
Hey i have this problem and i tried turning off security apps and using it in 32 bit mode. none of this worked and i dont have administrator access. id like to try the ports thing but ive absolutely no idea how they work can someone help?
Hey Red,

I have had this issue as well for the last couple of weeks (since I done a complete system wipe then reinstalled it). I have to hit the change region button (but just select the same region) then I move over to the custom section and wait for a few minutes for it to load everything. unfortunately I have to do this every time, while its not a permanent fix it will get you back to play online.
hey blast,

thx for the response,ill be sure to try it out when i finsih downloading sc2 again ( i tried that as an effort to maybe clear the problem),i hope it does work :P,have a good day EDIT do you have to change the region from outside the game on battle.net or is there a way from inside the game?
YOU NEED TO GO TO C/PROGRAM FILESX86/STARCRAFT 2 (OR THE PLACE WHERE YOU INSTALL IT)

AFTER THIS, THERE IS A FILE NAMED SUPPORT64, CLICK ON IT.

AND IN THIS FOLDER, THERE WILL BE .EXE NAMED SC2SWITCHER_X64, RUN IT AS ADMINISTRATOR, AND THEN, IT WORKS FINE!
OH FFS Blizzard!

Just reinstalled the game after not playing for a year - 30 gigs download and was pretty excited, and i should have anticipated for something to go wrong....... uninstall, no time for this BS! I will go play an indie game for $5, at least that game starts LOL!
And now it locked me out of my own account for no reason... brilliant!
08/06/2018 23:15Posted by Bivom
YOU NEED TO GO TO C/PROGRAM FILESX86/STARCRAFT 2 (OR THE PLACE WHERE YOU INSTALL IT)

AFTER THIS, THERE IS A FILE NAMED SUPPORT64, CLICK ON IT.

AND IN THIS FOLDER, THERE WILL BE .EXE NAMED SC2SWITCHER_X64, RUN IT AS ADMINISTRATOR, AND THEN, IT WORKS FINE!


Thanks :) This worked for me
the most simple solution,turn off windows firewall,for me work 100%

Join the Conversation

Return to Forum