"Achievements Disabled Until Further Notice"

Starcraft II Technical Support
After Last Update - "Achievements Disabled Until Further Notice"

My avatar doesn't load. Co-OP progress doesn't load at all (Level zero everywhere). Cannot play the vs AI mode at all. The game remembers Campaign progress (probably due to save files or something), but achievements are all set at zero percent.

I've deleted entire battle.net cache folder (as I saw as a potential solution in another thread), but it did nothing. This has happened right after most recent 4.3.2 patch.

What would be the next step forward ?

Edit 1: I have run the Scan & Fix element of the battlenet app. It detected no corruptions at all, and said no fixing is needed. I've cleared Starcraft 2 permissions in the windows firewall so it asks for them again after launch (as I was suspecting maybe a part of the firewall doesn't let some packets through ? I don't know), but that wasn't it, same result. I've also turned off both windows and windows defender firewall entirely - still same result, achievements disabled, coop commanders are blank at level zero, achievements at 0%, avatars gone.

Interestingly, connecting to an americas account gives exact same results.
Hey,
This can actually be a connection issue, try the troubleshooting steps here.

_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh
For the remainder of this thread, I will note I am on windows 10, and I will be troubleshooting all of this with my firewalls down, both software, windows, and on the router. I have no antivirus software.

Update 2- I have reset many times my ethernet card (I am connected to the router with a cable) and it didn't help. I have followed the connecting troubleshooting guide, and I have flushed my dns and ip configuration using the command prompt. Still no success. I will try to restart my network device, but I am renting a room and it's a shared connection, so I have to time it right not to annoy my flatmates. I will edit this response once I will go through my router and wreck it apart and check some settings there.

Edit 1: Another interesting/intriguing point is, the "What's New" news feed on the left side as you launch Starcraft 2 is perfectly intact, with the newest news and such. Friend list is intact, and it shows people online, however all avatars are missing (not the gray default SC 2 blank avatar, just, empty frames) The issue persists still.

Edit 2: I have reset my router, once from the software side, and once from just powering down and turning it back on. No success. I've turned off and on my network card. No sucess.

Another two weird things. a) I have opened heroes of the storm. Yesterday I managed to play it with my friends, literally less than 24 hours ago. Now when I try to open it, it gives me "unable to download an authentication module. Please try again" every time. Tried launching it multiple times. b) When I click on my name here, on the forums, It doesn't let me see my own starcraft 2 profile. It says it's a redirection error.

Can you or anybode see my starcraft profile at all ? Is it possible it got corrupted somehow on the battle.net side?

I've asked my girlfriend who is connected on the same router to launch heroes of the storm. It went past authentification just fine.

Edit 3: I am thinking it's unlikely its a internet connection issue. I'm suspecting either a caching issue either in battle net app, or somewhere else, or its a profile corruption. My next steps are gonna be reinstalling and uninstalling the game, and the battle net app.
Hey Kefe,
Keep us updated on how the reinstall goes.

_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh
Alright. I have reinstalled just the battle net app first. After uninstalling it, I found every possible folder on the C: drive that had battle net, blizzard, starcraft, etc. in its name, deleted them manually. Reboot, then reinstalled battle.net app.

No change. Then, I have uninstalled starcraft 2 in the battle.net app. (Before that I've reset the game to default settings). Deleted the starcraft folder manually, then reinstalled it on a different partition, just in case. Fresh installation of battle net and starcraft later, the issue, exactly the same, persists. Heroes of the Storm still gives "Unable to download an authentication module. Please try again"

I'm a bit out of ideas. I will try a combination of hard-resets of router today - but I've checked its settings over, firewalls are off, stuff like MAC filtering or IP filtering is off. The only thing is that UPnP is on, which is fine. There are no custom DNS set on this machine or the router.

I will google the issue and the Heroes of the Storm issue a bit, maybe I will find some links there.
Edit 1: Starcraft: Remastered goes through just fine, can go into battle.net just fine there. No suspicious malfunctions. Maybe something with the last win 10 update and the way it handles software security went bonkers ? I'm not that well vexxed in Win10, just made a switch from 7.
RIGHT! As usual, it's the darkest right under the lighthouse.

My gf asked me to run the battle.net app in administrator mode. It's such a dumb idea, but I tried it. I launch it. I open starcraft. The game mulled about for a minute or two, but in the end, it DID fix itself, and everything was fine.

Then I relaunched battle.net app normally. Starcraft runs fine again.

I launched HoTs in normal mode. It gave again the auth. error. I close battle net app, and relaunch in admin mode. Hots goes past authentification, mills and lags for a minute or two, and then finally works.

Then I launched it normally. Works. I opened starcraft 2 in normal mode, the profile loaded, but when I went to mutations, a big "LOADING" circle appeared, and the mutation description and the icon just never loaded. Relaunching starcraft 2 through battle.net in admin mode let it load.

I guess something borked between battle.net and how windows 10 gives permission to modify the harddrive during software run time, as starcraft 2 downloads so much during it.

I've also found out my permissions and inhereited permissions look.... weird in my system. I'm gonna try to play around with that, and see if I can make starcraft 2 act normally in normal mode, and see if that was the reason.

Edit 2: I seem to have corrupted permissions on my system after some malware that I removed couple days ago. The basic System and admin accounts are fine, but there are two more SIDs permissions on everything, and they're inhereited, so I can't even remove them without turning everything off. I am not that good with permissions, I even checked manually the users folders and permissions seem to refer to groups or users that don't exist anymore.

Games work only if RUN in ADMIN mode, but issues return when trying to run them normally (Ie going to menu elements that weren't open in admin before hand. In other words, whenever the game wants to update its data, it borks). I will try to fix my permissions on my system in a way so I could achieve battle-net and starcraft 2 working normally in normal mode, so I can find the actual issue.

Edit 3: The issue persists. I'm 100% certain issue has something to do with users and group permissions.
"Achievements Disabled Until Further Notice"

Okey, after learning more about how permissions work in Win 10, how inhereited permissions work, and how battle net handles files and access to the hard drive, I found out what might've been the cause. It's something between my computer having a part of my user account corrupted, and the fact I've changed my system language from polish to english, so some folder names for my user accounts changed, while the registry changed some of its lines into english, with some of the newer stuff I've installed.

So I've installed battle.net after a fresh windows installation, THEN changed the system language to english, and then after one battle.net update, it just borked. There is probably some kind of mismatch between my registry and my user folders, but I cannot pin-point it exacly. I've been messing with my permissions, trying to exacly reverse-engineer the issue (the custom maps don't get fetched at all in normal mode, in admin mode they work fine. VS AI refuses to work in normal mode. I've been switching between two and experimenting with user security settings for different things)

Anyways. If anybody else ever googles this thread and finds a "Achievements Disabled Until Further Notice" issue, it will have to do with security settings and user accounts. You have to check Properties of your shortcuts, and battle.net .exe files, and check what account has what kind of acess to it (read write, full access, etc), and if something is suspicious there, try running it in perma admin mode.

Edit:! I've googled for a little registry script that adds "Take ownership" to your right-click menu in windows. You download it, add it to the registry, restart, and the option appears in your right click mouse menu in Win 10. It apparentley changes the ownership of selected files/folder/etc. to the current user. I've selected the entire battle.net folder (the one to which the shortcut on the desktop refers to), and I've run the "Change ownership". A command window popped up, did it's magic, and its done. Sadly, most things load, but initializing ladder and AI games very very often results in "Couldn't download map cache, please restart" error. So, sadly, no solution.
I have the same problems. Only Star Craft 2 have problems with connection. I play any other games from battlenet app without any problems. I reseted anything disabled all avast and win defender and still icant play SC2 MP
guys i fixed it. Follow this link below. you welcome. please say i love u when it works :)

https://us.battle.net/support/en/article/34721

https://us.battle.net/support/en/article/34719

Join the Conversation

Return to Forum