Can't download and install starcraft 2

Starcraft II Technical Support
Hi, I'm trying to download and install starcraft 2 using the blizzard launcher/installer. I have opened the launcher as administrator and after sitting initialising for maybe 5 or 10 minutes it come up with an error message saying I should run as administrator when installing. I have also tried restarting the computer after deleting the battle.net folder with no change. What can I try next to get it downloading and installing. I have also recently managed to update hearthstone and so the Internet connection etc is fine.
Thanks
if you have another pc, you could install it there and then transfer it over.
Hey Noremac,

It sounds like something might be blocking the Blizzard App from connecting and downloading the game properly. Go through the steps to close background applications and delete the Battle.net Cache and Battle.net Files before trying again.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi
I'm having a simliar problem. I think it might be something to do with the "location" of "my docmuents" on my system. I have found that if I relocate the path to "my documents" to my NAS drive Starcraft 2 wont install giving me the same issue that you have described but when I set the path to default everything is ok. Have you moved the path to "my documents" from its default location? If you have and have solved this issue how did you get around it?
starcraft 2 does not support NAS harddrives. the game needs to be either on a non NAS internal drive or a usb drive. even a memory stick or an SD card might work. usb based drives works for sure, i will test SD cards tomorrow.

Join the Conversation

Return to Forum