Stutter with Great internet/specs

Starcraft II Technical Support
I have 7 cores/Nvidia GTX 1070TI
I have tried to pathping/trace
I have tried running compatibility mode with windows 7
I have tried running it as 32 bit w/without compatibility
I have lowered graphics (Was not the issue anyways)
Can anybody help, I would really like to enjoy this game, its a bit hard to with constant lag stutters.

TRACEROUTE:
traceroute to 73.224.42.10 (73.224.42.10), 15 hops max, 60 byte packets
1 Blizzard Blizzard 1.487 ms 1.483 ms 1.483 ms Blizzard(24.105.18.3) 3.466 ms 3.484 ms 3.487 ms
3 137.221.105.12 (137.221.105.12) 3.047 ms 3.090 ms 3.090 ms
4 137.221.66.16 (137.221.66.16) 3.054 ms 3.055 ms 3.066 ms
5 137.221.83.66 (137.221.83.66) 7.964 ms 7.982 ms 7.986 ms
6 137.221.65.68 (137.221.65.68) 6.877 ms 8.672 ms 8.659 ms
7 137.221.68.32 (137.221.68.32) 8.652 ms 8.648 ms 8.644 ms
8 te-0-10-0-1-4-pe01.600wseventh.ca.ibone.comcast.net (23.30.206.153) 8.507 ms 8.524 ms 8.524 ms
9 be-11545-cr02.losangeles.ca.ibone.comcast.net (68.86.84.233) 9.878 ms 6.385 ms 6.351 ms
10 be-11523-cr01.houston.tx.ibone.comcast.net (68.86.87.174) 33.609 ms 33.608 ms 33.124 ms
11 be-11423-cr02.56marietta.ga.ibone.comcast.net (68.86.85.21) 45.252 ms 44.814 ms 45.973 ms
12 ae-79-ar02.westside.fl.jacksvil.comcast.net (68.86.95.50) 57.035 ms 57.044 ms 57.025 ms
13 68.87.164.114 (68.87.164.114) 59.652 ms 59.734 ms 59.714 ms
14 96.110.66.118 (96.110.66.118) 61.554 ms 61.786 ms 61.823 ms
15 c-73-224-42-10.hsd1.fl.comcast.net (73.224.42.10) 70.226 ms 78.257 ms 78.224 ms

17/04/2019 13:56:12 UTC
--------------------

PING:
PING 73.224.42.10 (73.224.42.10) 56(84) bytes of data.
64 bytes from 73.224.42.10: icmp_seq=1 ttl=51 time=72.2 ms
64 bytes from 73.224.42.10: icmp_seq=2 ttl=51 time=69.2 ms
64 bytes from 73.224.42.10: icmp_seq=3 ttl=51 time=68.6 ms
64 bytes from 73.224.42.10: icmp_seq=4 ttl=51 time=69.5 ms

--- 73.224.42.10 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2998ms
rtt min/avg/max/mdev = 68.690/69.954/72.292/1.421 ms

17/04/2019 13:56:12 UTC
--------------------

MTR:
Start: Wed Apr 17 13:56:13 2019 Blizzard 1.|-- Blizzard 0.0% 10 0.2 0.8 0.2 5.4 1.5 Blizzard 0.0% 10 0.9 0.8 0.5 2.4 0.5
3.|-- 137.221.105.12 0.0% 10 0.5 0.6 0.5 1.0 0.0
4.|-- 137.221.66.16 0.0% 10 0.5 0.6 0.5 0.7 0.0
5.|-- 137.221.83.66 0.0% 10 5.9 5.9 5.6 6.3 0.0
6.|-- 137.221.65.68 0.0% 10 5.7 7.4 5.7 21.3 4.9
7.|-- 137.221.68.32 0.0% 10 5.5 5.6 5.4 5.8 0.0
8.|-- te-0-10-0-1-4-pe01.600wseventh.ca.ibone.comcast.net 0.0% 10 5.7 5.7 5.6 5.7 0.0
9.|-- be-11545-cr02.losangeles.ca.ibone.comcast.net 0.0% 10 6.2 6.8 6.2 7.5 0.0
10.|-- be-11523-cr01.houston.tx.ibone.comcast.net 0.0% 10 33.4 33.6 32.3 34.6 0.3
11.|-- be-11423-cr02.56marietta.ga.ibone.comcast.net 0.0% 10 46.7 46.1 45.2 46.9 0.0
12.|-- ae-79-ar02.westside.fl.jacksvil.comcast.net 0.0% 10 57.1 58.1 57.0 63.0 1.8
13.|-- 68.87.164.114 0.0% 10 59.7 59.7 59.6 59.9 0.0
14.|-- 96.110.66.118 0.0% 10 61.5 61.6 61.5 61.8 0.0
15.|-- c-73-224-42-10.hsd1.fl.comcast.net 0.0% 10 69.6 69.3 68.5 71.9 0.9

17/04/2019 13:56:12 UTC
--------------------

you could check if energy efficient ethernet is turned on. if it is, turn it off, problem solved. if it is already turned off, i am out of ideas.
Since lotv patch every have massive fps drops. In hots game used to run on 60fps min... Cpu frequency matters since game is single core, it supports multithreading, but only one core gets maxed and other are almost untouched. And gpu is bottlenecked. Cpu overclocking helps. Also high speedram. https://wccftech.com/haswell-works-high-speed-ram-benchmarks-show-ddr31600-mhz/
So dumb this game used to run on geforce 8800 and core duo2 on 60 min. Now even high end pc have trouble to get min 60.
Hey Physcozerg,

You have gone through a good few steps already, thank you for listing those as well. There are a few more steps listed in the Starcraft II Performance Issues Support Article. Please go through all the steps listed thoroughly, and retest afterwards.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi
25/04/2019 14:12Posted by Nenyasqi
Hey Physcozerg,

You have gone through a good few steps already, thank you for listing those as well. There are a few more steps listed in the https://battle.net/support/article/19921?utm_source=internal-support_forums&utm_medium=posting&utm_campaign=BlizzardCSEU&utm_content=solution" class="bml-link-url2">Starcraft II Performance Issues</a> Support Article. Please go through all the steps listed thoroughly, and retest afterwards.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
<a href="https://www.surveymonkey.com/r/Nenyasqi


sry man but already the first step explained to check for overclock on nvidia cards is already weird
it s asking us to use a debug mode in the nvidia software to reset an overclock that might be there or not...that isnt how u usually check if a g-card is overclocked or not. this is very misleading for novices.

some of the generally recommened steps are only used for very specific platforms like laptops

and to fix the core issue the german written article doesnt work at all for me cause i dont have the option the article is asking me to do when i right click the game in the taskmanager

Join the Conversation

Return to Forum