perfomance is terrible

Starcraft II Technical Support
So annoying unless you have 5ghz cpu+ and 4400 mhz ram, game perfomance is terrible, drops under 30 in lategame and aracade 1fps. While in hots it was fine...
Great job platypus game, this game ran on 8800 geforce and core duo on 60 min.
My gpu is running only on 324 mhz while in the game. And i have 4.1ghz intel i7 3770. GEforce 780, 1600mhz ram.. And using prefer maximum perfomance. And gpu load doesn't exceed 32%.

BTW there is new option in variables.cfg graphicapi, i wrote there direct3D11 and it didnt rewrite upon launch. I though starcraft 2 doesn't support more than d9. Did anything changed ?

Question does nvidia control panel settings apply. Unless you pick sc2 exe v 44910 or how did that call. I know you have to do that for anti-alising to work. If could someone answer this could be nice ty.

I have much more perfomance since i increase details for cpu heavy stuff and other leave on lowest now 690mhz and spike to 70% usage i think. Stil in hots perfomance used to be much better 60 min almost. even in 200/200 fights!!! Ah no i though i may have more fps but now, still 28 fps in fight lategame... You get more cpu,gpu usage, but playing on higher details so exaclty same count as on lowest...

Lol watching polt stream and at 6 minute mark already drop to 47 fps. And he has to have powerfull pc, like at least 1080 and i7 overclocked right and highspeed ram. Right ? I am interested when he will be in 200/200 battle.
ram speed is not relevant. harddrive speed however is. as the harddrive loads the data, the ram stores it. loading from ram is faster anyway.
Hey IIIIIIIIIIII,

There are a lot of things that could be affecting your game performance, from hardware related issues to drivers and other applications active in the background. Let's start by going through the steps listed int he Starcraft III Performance Issues support article, and take it from there. Please make sure to go through all the steps listed thoroughly.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi
I know this all, i already tried everything posted in this link, i read even that guide, pinned on forums and nothing had any effect whatsoever. We all know problem is that game cannot utilize multicore cpus and gpu is bottlenecked. It is really annoying tho, because in hots game used to run fine almost 60fps min always. Except 200/200 with a lot of bannelings in army. I have no overheating what so ever. Parking disable and cpu is running in c0 on 4.1ghz. Enabled 7 cores, 1 disable. I already tried pretty much anything i could find and nothing helped whatsoever. Tried windows 10, fresh windows 7..
i had trouble running it on 1080 ti myself. it ran much better when i switched to 2080 ti.
I woun't buy 2080ti + 5ghz+ cpu + 4400mhz ram and overclocking them, to barely play on 60, maybe even with this not, when there are 200/200 army with a lot of banes with it, when this game is imbalanced yet. It used to run on geforce 8800 60 min on lowest, almost 60 on ultra. Devs broke the game since lotv patch 4.6... Graphic didn't changed or requirments. Devs broke the game... All devs today do this, because they get probably money from intel or nvidia, in cs go it used to run on geforce 460 and i5, on 144fps min on lowest and single core. And now not even 60 with multicore on geforce 780 and even pros had 25 fps at flowers... I don't know what they are doing, because graphics didn't change or anything, so they had to massively break something within the game. They want you to pay for geforce 1080 and even with it it wont work now, so you have to pay for 2080 and next year it probably wont work on 2080 so you have to pay again... I wouldn't awe, if they did this on purpose, they don't care about you, you are money for them, that's it! Saw pro games lie in ads for example for eizo etc.

LOOOOOOOOOL 120 supply vs ling bane and getting drops 15fps on lowest..........

I downloaded old heart of the swarm version 2.0.6 or something and i installed it on windows 7 32 bit and haven't even tweaked all the settings, unparked cores etc. And amassed 200/200 army supply with ling bane and a moved it against terran army and i had only drop to 49fps...Since LOTV performance is worse, there are various topic on the internet and post on forums descrbing this issue, since patch 4.6 and paradoxically lotv should bring better perfomance said blizzard...
LOL it has recommended requirments:
Intel® Core™ i5 or AMD™ FX Series Processor or better
NVIDIA® GeForce® GTX 650 or AMD Radeon™
While it is more likely geforce 2080, i3 84005ghz /i7 5ghz+, 3600mhz ram +
Since these are recommended requirments, game should run fine on these on low and still doubt game would ran on these, at all...
actually, requirements did change. when they added dehaka, the game became more demanding. changing an option in variables.txt makes the game run better however. this one: GraphicsApi=Direct3D11
Did you read what i said ? I already tried this and it had no effect whatsoever, i think it makes placebo effect. Because making game directx11 would require recoding whole game and doubt blizzard did that, never heard them doing it.
Dehaka isn't that for coop only ? How game became more demanding, graphics is same, same amount of units. + map design is important too, there were maps which run about 10-15 fps better. I remember for example that purple map was lagged as hell. And is so why blizzard didn't update their requirments. Because it didn't, it is same thing with cs go, it used to run on 460 and i5 single core on 144fps min and today it won't run even on multicore on 60 min, they broke something within the game. If you say it cannot run even on 1080 you see how badly optimized it is... Lol or if they really broke 1v1 for coop with dehaka, that would be amazing, i don't eve n know what to say............................
it is still a fact that it became more demanding when they added dehaka but, they might have optimised it afterwards(many patches after). i do not claim that it is optimal however. keep in mind that starcraft 2 is built on an ancient engine from around 2007 with no multicore support. it does however help to have more cores as they can run background tasks.
It is so stupid, because it used to run fine and now you need 2080 and 5ghz cpu and highspeed ram to be able get 60min... Broke it for 90% of people, i read so many thread from people complaining even with 1080 of low fps...
not highspeed ram. ram speed is not relevant. harddrive speed however is very relevant. starcraft 2`s data is heavily fragmented and as such, it takes a fast harddrive to load it quickly. it became too tough for my toshiba`s harddrive to load it fast enough and as such, i had to use an external harddrive.
Well you are not well informed, since haswell architecture gain massive fps. https://wccftech.com/haswell-works-high-speed-ram-benchmarks-show-ddr31600-mhz/
1600 vs 2400 10 fps mhz.
Main is to have good gpu, but since gpu will be bottlenecked. Only 2080 shows massive gain in fps. Before there for minimal to no advantage of having newer gpu.
I have ssd don't worry and even with hdd you can use preloader. It is lotv break perfomance, hots were fine!
I just installe windows preview build 1903 and seems less latency, gonna check gaming perfomance, but probably doens't do anything! Hmm and i have micro freezes every three second...
loading times is entirely based on harddrive read speed. i also got a massive performance boost by moving the game over from my slow toshiba harddrive to my seagate harddrive. let me explain one thing about ram: virtual memory. virtual memory uses harddrive space to compensate for the ram used by windows.
Yes, but harddrive has nothing to do with fps. Loading time isn't problem, never was, why you bring it up. Yes there is virtual memory, but it is almost never used, it doesn't depend on it, because it is to slow. It is only to compensate for fact that pc used to have 512 ram in old days. And i told you i have game on ssd, do you even read what i write ? Even if you have hdd you use preloader which loads everything into ram, so it really doesn't matter that much. Game on hadrive can cause only freezes, but have nothing to do with fps...
wrong, loading times is the problem. you never said that you have the game on an ssd before now. virtual memory is always used. you do have the option of turning it off but then you get less memory. i have an education in computer use.
I said that right before your previous post...

29/04/2019 10:48Posted by andreasasp
wrong, loading times is the problem. you never said that you have the game on an ssd before now. virtual memory is always used. you do have the option of turning it off but then you get less memory. i have an education in computer use.

LMAO are you trolling ? And why are you keep talking about nootebook all the time, if you have some old notebook with 2GB, than yes pagefile may slow you down. Besides pagefile has nothing to do with fps. It only may crash your game due to memory leak when you have it off. And playing on hdd may cause freezes,when it is loading, but not fps drops. I played game both on hdd and ssd with pagefile on/off and it had no effect on fps whatsoever and i never heard that pagefile would affect fps, nor i could find any proof about it. You talking about something completely irrelevant, problem is lotv since patch 4.6, a lot of people started having issues from this point and in heart of the swarm i have 50fps min untweaked, while in lotv drops under 30, even on freash system...
Lol i oced my cpu to 4.33ghz, which added only 2 fps...

I would like to hear from blizzard support again what they have to say about this ? I doubt there is anything i can do to fix this, it is poor game engine cannot utilize multicore and gpu is bottlenecked, i know all these guides and already tried all...
So garbage i have drops 22 fps lategame...
playing on a slow harddrive does cause drops in fps. i had massive drops in fps on my toshiba until i switched from using its internal harddrive to using my external harddrive. after that it ran smoothly.
I have never had fps drops on hdd, it can only cause freezes when it is loading, but never affect my fps whatsoever. I have exactly same fps on hdd and ssd. I used to play sc2 on hdd and had 56 min in hots... Even in lotv had installed game on hdd and ssd sometime and fps was exactly same...
Page file on hdd/sdd, on/off, game on hdd and ssd, no difference in fps whatsoever.....
If i could play on 800x600, but game doesn't work less than 1024x768 and in fullscren only on 1152x864...

Hello, no answer from tech support ? I already said i tried everything from these guides on forum and in version of hots 2.0.6 i have no problem with fps, but in lotv i get drops in lategame to 19 fps. I don't think there is anything i can do, game is simply broken from patch 4.6, for majority of people, started issues since then, even with much powerfull rigs tahn i have...
I was able to get huge fps boost by disabling hyper threading, didn't play much yet, but in replay lategame, when i had previously drop to 21 fps i had 40 min, which is still not good, but better. And on 40 only micro in lategame is pretty difficult. Even 1 fps drop under 60, you get dynamic lag and tearing...
Strange i already tried this in past and had no effect whatsoever... Lol i instatly get so much better since game was much more responsive in midgame... But it is so annoying, everytime when i want to play other game, i will have to go back to bios and enable/disable hyper theading... And i tried affinity to put only to cpu cores, not threads and i didnt do anything, only by disabling hyper-threding in bios i got better results and made sure it wasn't threads but cores.BUMP!
Can you answer blizzard ?
i just noticed that your cpu is overclocked. that is not supported. that can cause issues. try to clock it down to factory settings.

Join the Conversation

Return to Forum