Starcraft 2 custom melee mode is not working

Starcraft II Technical Support
I have windows 10 64-bit on my Pc.
My specs:
Gigabyte H81M-D3H
Intel Core i5-4460
16 GB Ram DDR3
Nvidia GeForce GTX 1060 3GB
WDC WD10EZEX-08WN4A0 1TB
Onboard Realtek Ethernet controller
(i am using the Eu-battle.net version, and the eu region)

I starting battle.net client, run the starcraft 2 game, but in the Custom-->Melee panel I cannot see the maps, sometimes there are some maps in the panel, but when I click the create lobby button, the "entering lobby" text is appearing and that's all, no working, it cannot start any game. And after this, my internet shut down, slow down, and it is killing my internet connection, after that, I cannot use the internet, and I have to restart the windows 10. I tried a lot of things but didn't work. After the windows restart my internet connection is fine again.

Anno I had a same issue with this game. But anno I could fix it, --> I used 360 Total Security Antivirus, I deleted this antivirus program, and installed Nod32 antivirus, and after that it worked. But now in 2019 this method is not working.
SC2 not able to download the maps, I don't know why, I have no access to maps.
I tried in offline mode, but in offline mode didn't work too.
Can Anyone help me?(sorry for my bad english...)

Join the Conversation

Return to Forum