Starcraft 2 big bug with install/update

Starcraft II Technical Support
Starcraft 2 says to install my game or locate it, I got to locate I select the Starcraft 2 folder and click ,,ok". It says update, I click update it says waitign on another installation or update and then it says something broke. 3 days ago I played the game fine. If anyone can help It would be very much appreciated. Thx in advance!
blizz agent down cant reinstall\update, sc2 wont loading as well.

im played sc2 less than hour ago.
23/04/2019 20:48Posted by SlayeR
blizz agent down cant reinstall\update, sc2 wont loading as well.

im played sc2 less than hour ago.
SlayeR you have same problem, so it is not only me?
i guess, need to wait untill blizz fix all
23/04/2019 20:55Posted by SlayeR
i guess, need to wait untill blizz fix all
I almost got a heart attack, I thought Its only me
It's a worldwide problem. Afther the patch, no server worked. Ther error is BLZBNTAGT000008FC. The patch must have done something with the game clients. Cannot open any of Bliz games, nor find it manually. Something went rong with the new patch.
Alexandermon Thx for the quick answer and for the explanation
yeah same here, its freaking annoying.
well i can understand that a patch can !@#$ up the particular game it was meant for but not it screwing up all the other games....

Actually, after a restart of pc, i could start it fine, but when i exit and try to start it again, the issue reappear.
i am experiencing the same issues. when will it be fixed?
23/04/2019 21:25Posted by stefystefy
i am experiencing the same issues. when will it be fixed?


Blizzard are quick to fix global issues, so VERY soon, or in the nextg couple of hours
when it say that something broke, it means that you are using incompatible hardware. i have the same problem on my amd a4.
23/04/2019 20:45Posted by ThePigeon
Starcraft 2 says to install my game or locate it, I got to locate I select the Starcraft 2 folder and click ,,ok". It says update, I click update it says waitign on another installation or update and then it says something broke. 3 days ago I played the game fine. If anyone can help It would be very much appreciated. Thx in advance!


yeah and making more posts of these will hlp with what?
alright for win10 user like me, u can try this:
open taskmanager (i m using german keyboard so it s strg+alt+entf for me)
close all bnet related programs
restart bnet launcher and wait a moment
ur sc2 should now have the update button again, updating the game worked properly for me now and i have now my play-button back...without reinstalling the game or messing with the registry
Marked As Solution
24/04/2019 08:29Posted by Yawgmoth
alright for win10 user like me, u can try this:
open taskmanager (i m using german keyboard so it s strg+alt+entf for me)
close all bnet related programs
restart bnet launcher and wait a moment
ur sc2 should now have the update button again, updating the game worked properly for me now and i have now my play-button back...without reinstalling the game or messing with the registry


I got a support ticket, and it had to do with me loging from another device that was veryvery different from my pc I am currently using. I got a link from ticket to install a patch, and it just updated by itself.
24/04/2019 10:00Posted by ThePigeon
24/04/2019 08:29Posted by Yawgmoth
alright for win10 user like me, u can try this:
open taskmanager (i m using german keyboard so it s strg+alt+entf for me)
close all bnet related programs
restart bnet launcher and wait a moment
ur sc2 should now have the update button again, updating the game worked properly for me now and i have now my play-button back...without reinstalling the game or messing with the registry


I got a support ticket, and it had to do with me loging from another device that was veryvery different from my pc I am currently using. I got a link from ticket to install a patch, and it just updated by itself.


or i didnt have latest patch, either way it worked.
24/04/2019 08:29Posted by Yawgmoth
alright for win10 user like me, u can try this:
open taskmanager (i m using german keyboard so it s strg+alt+entf for me)
close all bnet related programs
restart bnet launcher and wait a moment
ur sc2 should now have the update button again, updating the game worked properly for me now and i have now my play-button back...without reinstalling the game or messing with the registry

Waooo Thank a lot , for me it was enough . Good luck for everyone.

Join the Conversation

Return to Forum