Co-Op refuses to start.

Starcraft II Technical Support
Judging from in-game chat, there are multiple people with this issue at the moment.

In my case, it goes like this:
  • Two players form a party for Co-op missions.
  • Both players declare they're ready and get marked as such.
  • The game shows "Initializing Co-op"
  • The game shows "Searching Co-op", which is clearly a bug, since the missions only allow two players and so a party of two never has to search for more players.
  • The game undoes the ready state for no reason, deciding that both players are no longer ready, and the cycle repeats until players give up.


Will this be fixed soon? The game is literally unplayable, and unlike on the Factorio forums, this is not an ironic joke. Dear Blizzard, if you enforce one version and reliance on central servers for everyone, those servers must not break, especially not twice within less than two weeks.
Update: now, we were able to play some rounds. Since I don't see the complaints in the chat either, I guess it's fixed?
04/05/2019 22:49Posted by Vandroiy
Update: now, we were able to play some rounds. Since I don't see the complaints in the chat either, I guess it's fixed?
Happy to hear that Vandroiy. There were some issues last night that affected a few players, this has since been resolved. Sorry for the trouble caused.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi

Join the Conversation

Return to Forum