What the hell happened with the log in ?

StarCraft II General
Up until a week ago i could login without any problem. Now all of a sudden i get a language pack crap and cannot login. I bought a french game version of the game ( because in fukin bruxelles thats all i could find at that time ) but switch the english. No problem with that till today. Nice way to hype me about playn starcrat 2 blizzard ...
I reside in Bucharest, Romania and have the english pack. I have the same problem, says i need "an authorised language pack " ...
I wouldn't worry to much Anubis, this will is a temporary bug. We'll be able to play again soon. It's just a bug
how soon is that soon, is still bugged
Same problem here, French version of the game, living in Chicago, can't login and same error message.
Same... cannot login, bought the game in the Netherlands, everything default.. settings are on enGB. Why ? Does this mean I can get my money back too if I can't play?
Blizzard sucks with all these things to make people buy several copies of the same game in order to play it. They only care about money. And the only ones this ever hurt the the legit people.
Same problem here. Had the game for over 2 years, played without a problem. Now I get this language pack stuff all of a sudden. Blizzard don't seem to be in a hurry, the first post was 13 hours ago and it's still a problem.
Tried to log in just a second ago and got the language pack error, normally play every day and never had it before, anyone know if blizz are sorting this?
Bought the game online and still I get this problem. Blizzard needs to get this !@#$ sorted out, its ridiculous..
same problem for me......
Maybe some wiz programmer changed the encryption parameters on the languages file and now SC2 can't decode it lol
same here...from Romania (Bucharest)
Greece - Same here.

I'm running it on Xubuntu so at first I thought that something got screwed up with wine, but thank god no :P
Guys, please go to this thread for help.
http://eu.battle.net/sc2/en/forum/topic/6444125342
same happened me yester day, i just restarted the whole game and it worked.

Join the Conversation

Return to Forum