You need an authorized language pack from Blizzard

Starcraft II Technical Support
Same issue. Game worked fine until yesterday evening
Impossible to login in this evening.
Last mod played: Desert Strike

variables.txt >
localeidassets=enGB
localeiddata=enGB

current country = BE
language settings on b.net account= US

A fix 'd be nice :-)
Thanks
^. Nice going for screwing up my evening.

@Vlord; If your SC2 account is actually US, your language settings should be enUS, not enGB?
Well, I think I will wait for Blizzard to fix it. At least HotS BETA works fine.
Same problem here.
And me aswell ;S just wanted to go ladder but nope...
Damn, nothing helps! Blizzard, fix ASAP!
+1 same here and i reinstalled the game and this still goes on...i gues just waiting for a fix
+1 same
Russian language works. Change Variables.txt in Documents area to ruRU
localeidassets=ruRU
localeiddata=ruRU
Same issue here, tried endless fixes posted here and all around the internet, re-installed the game, contacted support and still not fixed. A fix would be nice.
waiting for fix
yep, russian seems to work, but the main menu background is corrupted (like low-res effect) and the custome maps are not loading...
Lool works on Russian language as Gashblister said
XD Would never have expected it
hello
The following message is displayed on the game was at check-in, "you need an Authorized language pack from Blizzard Entertainment"

Please help me I paid for the game I want to use
blizard please fix this, it's really annoying
Problem occuring here as well, it's also a fresh install, done 20 minutes ago.
I haz problemz with ze authorized language pack from Blizzard aswell.

Seems like its going to be a night's sleep without the evening sc2 game. ='(
blizzard rulz
WHAT THE F U C K!

I tried some ideas and solutions, but nothing works!

FIX IT PLEASE!
im finally playing now!

changed it in ruRu then got a little russian update and it works lol

Join the Conversation

Return to Forum