Unresponsive keyboard and other issues

Technical Support
Hi,

I have two problems

1) when I play WoW I notice that sometimes my keyboard is not responding correctly. Like when I want to walk forward by pressing W nothing happens. I have to press W several times before my character starts walking.
The same with other keys,e.g. enter when I want to post a message.

This only happens in the game, outside of WoW my keyboard is working fine! I PvP a lot so this is pretty annoying!

2) I have my laptop hooked up to a bigger monitor. What is weird is that when I launch WoW while my monitor is connected to my laptop, the resolution of the game is 1280x1200. When I change it to 1920x1080 WoW crashes.
If I start WoW on my laptop, without the monitor connected to it, WoW starts fine in 1920x1080. I can than hook up my monitor to my laptop and play in 1920x1080 on the bigger screen.

These two issues seem to have appeared after I installed a new driver for my video card. I never had these issues before!
My videocard is a geforce 850m, driver version 337.88 (if that is of any help)

If someone has got a solution I would really appreciate it!
Thank you
Hi,
1) Are you using your laptop keyboard or an external one? if external is it wireless?

2) In game you have the option to select which monitor to use to display on do you change that?

3) GFX driver updates can go wrong sometimes, it can help by UNinstalling all your GFX drivers, reboot and install the drivers fresh.
Did you manage to resolve the keyboard issue? out of the blue i started having this issue 2 days ago and i haven't changed anything with my MSI laptop.
I have found the issue for your keyboard not responding!!! the issue is caused by the latest geforce experience driver enabling shadow play for your computer. This causes a bug with warcraft as shadowplay s running over the top of warcraft so your keyboard becomes unresponsive.

if you go into geforce experience and click the shadowplay icon in the top right corner you can switch it off.
Thanks so much, its been bugging me so much!
I can confirm, Shadow Play caused my keyboard to become unresponsive ingame. Disabling Shadow Play resolved the issue 100%.
I can confirm this. Thank you for this post, this issue was bugging me for days. Solved it 1 hour before raid starts.

Disabled Shadow Play and everything is fine!

Thanks!
I have he same issue, I have a Asus laptop.
I haven't checked if Shadow play is the reason, but I really hope so. Then this problem will be easy solved.
23/12/2014 22:02Posted by Stonedcold
Disabling Shadow Play resolved the issue 100%.
Confirmed
Thank you Sooooooo much!!
THANK YOU!!! i never would have thought of shadowplay as the reason to this problem.. but i switched it off and it worked afterwards.. THANKS!!!!!!
I wanted to record myself playing wow using this nvidia feature! Well boo-hoo...

L.E.: However if you stop shadowplay start wow and then start shadowplay back on it won't cause the keyboard to become lazy. I jsut tested this by healing people in ORG.
Than you so much !!! The shadowplay was the issue
For me it was CamStudio, but same problem, and shutting it down fixed it. Putting this here in case anyone else searches for same issue.
Anyone knows if this can be fixed without turning off shadowplay? Kinda was expecting to record progress raids so turning it off isnt really an option for me. Thanks in advance
20/08/2014 15:56Posted by Hydrol
I have found the issue for your keyboard not responding!!! the issue is caused by the latest geforce experience driver enabling shadow play for your computer. This causes a bug with warcraft as shadowplay s running over the top of warcraft so your keyboard becomes unresponsive.

if you go into geforce experience and click the shadowplay icon in the top right corner you can switch it off.


Thank you, this solved my keyboard problem.
Same problem, same solution, thx ;)
20/08/2014 15:56Posted by Hydrol
I have found the issue for your keyboard not responding!!! the issue is caused by the latest geforce experience driver enabling shadow play for your computer. This causes a bug with warcraft as shadowplay s running over the top of warcraft so your keyboard becomes unresponsive.

if you go into geforce experience and click the shadowplay icon in the top right corner you can switch it off.


Hydrol.....I actually love you.
Was this close to uninstalling World of Warcraft entirely and re-downloading, where have you been all my life.
i know this thread is for other question, but if you want to record through shadowplay in fullscreen mode(like me on notebook) and have same keyboard lag, you should to disable HARDWARE CURSOR setting in ADDITIONAL SETTING menu in game
05/10/2016 14:47Posted by Кивьери
i know this thread is for other question, but if you want to record through shadowplay in fullscreen mode(like me on notebook) and have same keyboard lag, you should to disable HARDWARE CURSOR setting in ADDITIONAL SETTING menu in game


This seems to have solved my problem! Thank you very much!

Join the Conversation

Return to Forum