long term FPS drop

Technical Support
Recently i entered an area with around 200 - 300 people in a small space, naturally my fps dropped. But, usually i get around 70 FPS on ultra, but ever since then my FPS hasn't returned to normal and i only get 20 - 30 FPS on fair settings. Is it something with my computer, or something i can fix in game or game files?
Had the same , well almost, I have an i5 processor and was using a brand new AMD ATI Video Card, radeon R7, 260x with 2GB on board, my frames should have stayed at 60 solid in all settings, but found that I was often down to less than 10 when in Garrisons or in instance quests. Reverted to older NVidia card, and I am back to beaing able to run in part ultra with 50 - 60 FPS all the time. I think Blizzard have made some changes as my crappy FPS on the ATI card happened suddenly, then would clear up, and then would return. Changed back to an older Nvidia card and my PC is rock solid again.

Quick test was to rename the Addons folder to something like 'old-addons' and let the game software build you another folder, see what its like, if you are still getting huge drops in FPS, restore the original folder as its obviously not an add-on issue for you. If your FPS improves when using a stock install with no extra add-ons, then you may have an add-on giving you a problem. Some addons are causing some FPS issues for certain.
I'm still anger Blizzard. They make too heavy game for people's PC.
Same me happened. I used ultra and FPS pretty runs in MOP. Then worst WoD....wtf
I think its a blizzard thing, ever since patch 6.0.2 everyone has had major FPS and lag issues, they failed to fix this for WoD, and they admit that WoD wasnt even ready to be released either.
But since WoD Ive had such a issue with FPS, just anywhere in game, yeah my computer could be upgraded but it more than meets the minimum requirements as stated by blizzard.

My garrison is the worst, even though im the only person there, its like launch night, 15 FPS, sometimes 20-25fps if im lucky, and thats with most of my settings on low. Its really stopping my enjoying the game and already cancelled by sub.
09/12/2014 21:03Posted by Jadeofarc
I think its a blizzard thing, ever since patch 6.0.2 everyone has had major FPS and lag issues, they failed to fix this for WoD, and they admit that WoD wasnt even ready to be released either.
But since WoD Ive had such a issue with FPS, just anywhere in game, yeah my computer could be upgraded but it more than meets the minimum requirements as stated by blizzard.

My garrison is the worst, even though im the only person there, its like launch night, 15 FPS, sometimes 20-25fps if im lucky, and thats with most of my settings on low. Its really stopping my enjoying the game and already cancelled by sub.


Indeed. I got much pain. Hope Blizzard hear us about suck fps. Fix better runs fps and ultra graphics
Thanks this really helped i can now run ultra again.
My pc can play on high in post settings easy i turn draw distance and shadows to good tho but after tuesday i get rapidly fluctuating fps no matter how low my settings are i just don't get it and blizz aint saying anything on the issue.

Join the Conversation

Return to Forum