FPS Drop, Low FPS, Low performance [Fix] [Windows 7]

Technical Support
Hey there folks, so since I installed Warlords of Draenor, I experienced terrible lag spikes. My FPS would drop below 5 specially while engaging bosses. Besides that, WoW always performed poorly. Minizimg WoW window was a nightmare as it would lag my entire PC and slow it down. Did a lot of research everything came fine and finally a guy in trade chat provided me with a solution and it absolutely worked! Since I realised a lot more had the similar problem, I'll post the fix here and it COULD work for you too.

Credit: Beiting - Hellscream

Windows 7 32 / 64 Bit
    - Right Click on your desktop and go to Personalize.
    - Click on Screen Saver.
    - Under Power Management, click on Change power settings.
    - Select Balanced if it is not already selected and then click on Change plan settings.
    - Now click on change advanced power settings.
    - Under the first drop down, select High Performance and press OK to all the windows.


Note: This works for Desktop PCs as well as laptops.

Additionally, I'd also like to add that under your WoW graphics settings, change the View Distance to Low, that would also improve your FPS dramatically and would help in keeping it stable.

Please let me know if it also works for you, cheers. :)
Vey good tips there, Sir!

Worked just great, I saw my FPS from 5-15 in raid environment before, now at 30-45 (laptop).

Thank you :)
Glad to hear it does help!

Would like more results, although I'm still experiencing very slight lag every now and then but the nightmare has gone.
Damn bro !!

It really working out . I can finally raiding normally :))
Don't think it would help me because a Goren spawning from a mine node in my garrison mine made me go from 90 fps to 12.
That's quite unusual, even when I had terrible lags pikes I never had a single probelm with Gorens or single mobs and players.
12/12/2014 03:52Posted by Escapism
That's quite unusual, even when I had terrible lags pikes I never had a single probelm with Gorens or single mobs and players.


Also get it if i look north from the target dummy in my garrison and also get really choppy fps in the world now all started this week.
12/12/2014 04:28Posted by Mingraved
12/12/2014 03:52Posted by Escapism
That's quite unusual, even when I had terrible lags pikes I never had a single probelm with Gorens or single mobs and players.


Also get it if i look north from the target dummy in my garrison and also get really choppy fps in the world now all started this week.


Did you try setting your view distance to Low?
Hey there I am having these problems too but whenever I select high perfo it autom.returns to balanced? Any advice?

Join the Conversation

Return to Forum