Launcher requires write permission

Technical Support
I just installed Wrath of The Lich King, when I try to run the launcher this error message shows up:
This is the error: "Launcher requires write permission to the World of Warcraft Registry key to successfully locate and rune the game. Please enable write access to the Registry key using an administrator account"

I'm already on a administrator account, and I've tried to run it as admin. I've also seen if the World of Warcraft folder was Read-only, and I changed it but it keeps changing it to Read Only.

Anyone knows how to fix it?

Thank you.
I really need help :/
Can you make sure your user account has administrator permissions, and that you're running the launcher in administrator mode (Windows Vista/7)?

1. Right-click the World of Warcraft icon on your desktop (or Windows start menu) and left-click 'Open file location'.
2. In the folder that appears, right-click the Launcher.exe file and left-click Properties
3. On the new window, click the Compatibility tab
4. Tick the option that reads 'Run this program as an administrator'
5. Click OK to save the change

Repeat the process for WoW.exe in the same folder.
I already tried to run it with admin. Now I started wow.exe and it want's me to install 4.0.0 patch AGAIN. I had fully installed the cataclysm patch, do I've to install the whole thing again?
i have the same poblem. im running win xp
Hey there im having a problem to. Its exactly the same problem as dracast only im using Xp and the walkthru Aennorai explained is different. is there any solution for the problem on Xp?
Ive tried almost everything i can think of and its driving me mad.

I have the same problem and im running on xp, but i am already on an admin account.. what do i do?
hey, i've tried going through properties and running as administrator, but I'm still getting that same error message: 'Launcher requires write permission..' I've done it on several administartive account on my computer, but it just will not work :@ help!
Mine required to "Write permission to World of Warcraft Registry" to confirm the starting path, I reinstalled through my Backup-WoW which is in my outer HDD and it works again.
A program with this price-tag should not be doing this!!!

So, what shall I do now???

I've added permission to the registry key.
But which one? In HKCU or in HKLM??? The error message does not tell!!!

Never mind, I added permission to both.
No success.
I've added permission to the parent key in both registry hives.
No success.

The program was relocated into the Public folder - suggested by the patch installer. Probably this causes the problem.

But what shall I do now?
And why is it me who has to do it???? Why not the programmer?

I'm a bit angry.
If running as Admin does not work you will likely need to completely reinstall the game client.

This error often occurs after an attempt to install Wrath of the Lich King or Burning Crusade from the DVD over the top of a fully patched (4.0.1+) World of Warcraft client.

You do not need to install the expansion data in this manner once patched up to date, the client should stream the missing data automatically.
Saying that is one thing but I had the patcher telling me the game was 'Playable' so I levelled a character to 13 and then I quit to have some food. I try to boot the game back up and the patcher is telling me that it is half way through downloading and no where near playable. So now my game time card is being wasted and I can't access the game even though all the files neccesary are on my machine.

So in order to speed up the installation process I installed wrath of the litch king. Which has led me to being stuck in this lack of access problem.

Blizzard need to sort this out pronto. Simply 'reinstalling' a 10+gb game if you don't have the discs is not acceptable. It means re-downloading that data which takes days for most people.
Why doesn't the DVD installation disk check if you have the relevant files installed already - it would seem the logical and very easy thing to do ??

And if it's because the DVDs are *already out there*, then why the heck was the game patched in a way that makes this happen ? :-((

IMO this is very poor from a company that has MILLIONS of customers ...
ive now got this but i now cant uninstall the game, any help guys
You could try changing user permissions to the game folder. In Windows 7, it's as simple as selecting the WoW game folder, checking properties, and in the security tab change the settings to give full access to the folder for "all users". In *theory* isn't a good way to do it, but should be perfectly safe in most circumstances.
Im having the exact same problem. I've tried changing the permissions and reinstalling the client and all that but it's no use. I didn't expect the game to have an error like this...
Running XP, same problem here, I have not re-installed anything. Was playing today, no prob, tried logging in later, my launcher.exe had gone. Tried copying in a backup launcher.exe - access denied. Renamed wow folder, copied in launcher.exe, named wow folder back & now have the permission error.

My PC hasn't been changed in any way between when I was playing and now. I have full admin rights to the PC. Any ideas out there?

Oh yeah, repair.exe says it can't repair, need to reinstall. I really have 4-5 hours to sit and watch 3 dvd's load and then 2 days to wait for all the patches to re-download. This is a cop out reply, standard IT answer, give us something to keep us busy and hope the problem will go away.
I managed to get it to work to a certain extent.

Run the game from the wow directory and it makes it come up with wrath of the lich king backgound etc then sign in and then it downloads a update after that there was some cactaclysm updater but i quit because i didnt think it would work.
This isnt helping... Uninstalling to reload, would that require me reloading the original game? I put WLK on and now I receive this error. I am running with XP.

Can someone tell a direct way for me to fix this without having to uninstall everything?
Running on 7, just installed Burning Crusade over the Cataclysm patch, and it doesn't work. I've tried running as admin, no luck, so I tried to uninstall and "uninstall.exe" could not be read. Help?

Join the Conversation

Return to Forum