Maybe a solution to stuck on initializing, please wait

Technical Support
For anyone that gets his wow launcher stuck on initializing, please wait... I might have found a solution.

If you got iTunes or Safari you probably also have a map called ´Bonjour´ in your ´Program files´ map.

Rename this Bonjour map to whatever you want and reboot your pc... start your launcher and probably it starts downloading the patch!

Ive tried this twice and for me it worked.

Why this might work?

When you start your wow launcher it also boots `mDNSResponder.exe` on the background which works with IP-protocols to make for example your iPhone work better with your pc if you use internet thetering (correct me if I´m wrong). This might conflict with the launcher. mDNSResponder.exe works with UDP-port 5353.

I´m no expert so everything just seem to be a logical guess.

I´d be happy if it can be confirmed or if it helped anyone out :)
I works. Just ctrl-alt-del and end task for the mDNSResponder.exe process. Starts downloading immediately. Thank you man!
Hi Newton,

Not heard of this fix before, thanks for sharing with the forum!
Apologies for reviving an old thread, but I managed to solve my "initializing, please wait" It turns out that the blizzard launcher uses your loopback address ( I had software on my machine that blocks my loopback address, I added the exception not to block and bam! The launcher works.
Didn't fix my problem, Still stuck on "Initializing, please wait"

This is after last update, 31/08/11
Didn't fix my problem, Still stuck on "Initializing, please wait"

Can't update...
had the same problem, tried everything in the end i gave up and was about to reinstall WoW. thought i would try run as administrator then BOOOOOOM! it worked :)

moral of the story try run as administrator before reinstalling.

hope i helped :)
I found after a bit of experimenting that turning off the download whist wow is running option seems to work as well
As Bellygrub suggested, I ran as administrator and it worked :-))
OMG. Tank You man. It worked like butter. I cannot thank you MORE.
Although how did you find it?
Uninstall Apple Software Updater.
After 3week pain, agony, i found the fix....
Newton, your awesome, thks, bloody thkks

Join the Conversation

Return to Forum