[Linux] Update 6734 breaks the launcher - Qt Platform

Technical Support
Marked As Solution
Hi,

The latest update breaks the launcher by setting all the files in Battle.net.<revision> with the property hidden.
The result is an error: "This application failed to start because it could not find or load the Qt Plaform plugin "Windows".
Reinstalling the application may fix this problem."

The fix I found for now it to manually uncheck the property hidden in all the files contained in Battle.net.6734, which through the Wine files app is very tedious and doesn't seems to work properly as the launcher now present a white page (common issue with Qt/Qml when the main.qml is not properly loaded due to a missing library for runtime rendering), but I might have missed one.

The fix by Blizzard is easy -> remove the property "Hidden" from all the files.
The fix by the user is the same but might be broken with the next patch and `Wine files` app is a real pain to use as you cannot select multiple file and doesn't stay on last file selected.

Fedora 23 Kde Spin, wine-1.9.1 (Staging).

Small update:
apparently you could use the command `$ wine cmd` to get window cmd prompt (do it in the Battle.net folder the tab auto-complete is broken on my machine), then use the command `attrib -H -S /S` to recursivly remove the hidden attribute but I'm having the error: "__winestaging_warn_event: File Not Found"
The search continue.

Another update:
Yep, if you do it thoroughly and don't miss a file, it works again.
I know that Blizzard doesn't support Wow on Linux (even though it works pretty well with wine), but that update wasn't very helpful.
You can try and post on the feedback section of the app forum (or the bug section), but not sure they'll take any notice of it since it's not really a bug. http://us.battle.net/en/forum/#forum9772477
It's a US forum but you can post there since it's just Battletag bound.
thank you very much Vorgos!

you give me a hint for the right direction. dont know why but attrib doesnt worked for me. i changed to Battle.net.6734 (~/.wine/drive_c/Program Files (x86)/Battle.net/Battle.net.6734) and run there wineconsole.
in the wineconsole i run explorer and changed the permissions manually. there works the rubberband and you can change all files in one folder at once. dont forget the qt folders.

worked for me

good luck penguins!
<cut> it's not really a bug. <cut>


is it a feature?
Had the same issue, changing my wine version to the newest non-staging version fixed it for me.

Credit goes to this post:
http://us.battle.net/hearthstone/en/forum/topic/20420204461
<cut> it's not really a bug. <cut>


is it a feature?


I suspect they are referring to the fact Linux is an unsupported platform so issues playing on it won't be supported.
Thanks for the post Vorgos, hopefully this'll help another Linux user!
___________________________________

Let me know how I'm doing!
https://www.surveymonkey.com/s/Lurdlespor

Join the Conversation

Return to Forum