Store Pets Inaccessible Post-Patch

Customer Support
Is this just me? My store-bought pets are all greyed out, and cannot be summoned, since the battle.net patch. Which makes some sense, given that they're b.net account-bound. Is this acknowledged/going to be fixed, soon?

Goes for Alterac Brew-Pup, Cinder Kitten, Dread Hatchling, Soul of the Aspects, etc.

PS - I can't find anything about it in the forum Search, though that thing is terrible, or by page-searching the first few Support pages, so I'm sorry if it's a repeat post.
Hi there Anhagath!

First of all, does this happen on multiple characters/realms? If so, exit the game and Desktop App and do this, reset your Battle.net account password and test again.

Let us know how it goes. =)
-------------------------------------------------------------
Please click here to give me your feedback on this post!
Hi! Yes it does, and I just got around to trying that, and it hasn't worked.

Is it a problem with my particular b.net account, then? I'd assumed it's on Blizzard's end given the specific pets it's an issue with, and I'd figured it wasn't unique to me. Should I just ticket it?

EDIT: Solved, ticketed it and a kind GM informed me it's a common but easily-solvable problem, and restored the pets/mounts. In case anyone else has this problem and comes across this thread!

Thanks!
Uhm my Heart of Aspects mount has also disappeared.
I am submitting a ticket.

Join the Conversation

Return to Forum