Legion companion app not working after 7.2.

Customer Support
Greetings. After update to 7.2. And update my legion companion app, i cant log in.
When i enter app there is no text "connecting" just rolling eye and nothing.
I am using android on galaxy s7 edge
Hello Yvancheen,

Thanks for letting us know, there is indeed an issue currently with the Legion companion app. we will try to get it sorted as soon as possible.

Take care.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Help me get to Exalted with the Blizzard faction
https://www.surveymonkey.com/r/Kraykore
Thank you for fast reply.

I hope you will also fix mob power on gear scaling at broken shore ;)
Still not working...
29/03/2017 09:52Posted by Kraykore
Hello Yvancheen,

Thanks for letting us know, there is indeed an issue currently with the Legion companion app. we will try to get it sorted as soon as possible.

Take care.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Help me get to Exalted with the Blizzard faction
https://www.surveymonkey.com/r/Kraykore

Sorry to say and I know it is not your fault but how about announcing bugs like this?
Communication wise this patch is a disaster...
- iLvl scaling in open world? not announced in patch notes because of "we want to see how you react to this when surprised".
The answer is "annoyed" - sincerely, your guinea pigs

- Companion not working? Oh thanks for noticing but we already know
https://eu.battle.net/forums/en/wow/topic/5207822310 shows nothing, Known issue section is still inked to 7.1.5

Nothing against you and thanks for answering but Blizzard communication policy is non existent (at least if you don't use twitter).
Mine seems to work ok. It auto updated when I launched it. Was ok afterwards.
Maybe you have update issue?
Tbh the Legion app "works" on my end. That is until you reach the character menu wich always has both of my 110 toons on offline, making either of them unselectable. Anyone else experiencing that? Reinstalling it didnt help either.
Thx in forward
I have the same issue. I can get logged in but all 110 characters are shown as offline.
Same issue on my side. Application show characters but looks like my all characters are offlice.
Ditto. All characters are offline.
Same here. Can't select any of the 110 characters with champions (yesterday i used all of them). forced stop. nothing. cleared data. nothing. uninstalled and re-installed app. nothing. totally SNAFU FUBAR.

As usual no notification from Blizz - thought they'd got better than this :(
Same issue.
Well, from the start of the post, they responded quickly. Maybe they are already at it. Hope to get a response soon hence it is really useful when outside like work n stuff.
Got the same Problem. Companion App shows my 110 chars offline.
Same, all chars 'offline'
Same, all toons showing (offline). ETA on fix?
clearly there is a bug where the app isnt able to communicate with the servers properly leading to it assuming they are offline
Same issue here. Let's hope there will be fix soon!
Same issues ... app not working , showing my chars offline ..
Sort of the same issue. Silvermoon chars are working but my Bronzebeards are offline

Join the Conversation

Return to Forum