7.3 performance issues.

Technical Support
Before the 7.3 patch I was able to play WoW fine. I had to put the settings down super low in order for to play at a decent framerate, but it worked. Since 7.3 I've had an error message stating that my device drivers are out of date. I've checked the drivers and they are all in date. Attempting to load the game leads to it failing to properly load. My character is in the middle of storwind yet it only displays a field of grass and a few NPC ID's. No buildings, NPC's or players load.
I have something similar ....my characters are listed but no graphic on the character screen when I try to load in it freezes up although I play with an older computer I have always been able to play. Pretty upset as I am pay to play! I have done the delete folders thing but still no solution as yet !
01/09/2017 17:20Posted by Diobio
Before the 7.3 patch I was able to play WoW fine. I had to put the settings down super low in order for to play at a decent framerate, but it worked. Since 7.3 I've had an error message stating that my device drivers are out of date. I've checked the drivers and they are all in date. Attempting to load the game leads to it failing to properly load. My character is in the middle of storwind yet it only displays a field of grass and a few NPC ID's. No buildings, NPC's or players load.

What are the specs of your computer? People have reported similar issues with computers that have been below minimum requirements for quite a while now, though some reported they could see things normally by changing the game to Directx9.

@Esmereldar, same as above.
I'm having similar issues.

Patch 7.2.5, I had 60 fps on average (yeah vsinc). Patch 7.3, I have 25 FPS on average. My PC is not a high-end rig by any means, but it is more than adequate to handle WOW.

Specs:

INTEL Core i5 7400 CPU
AMD radeon r9 290 GPU
8 GB RAM
The game is installed on an SSD

The graphics settings have positively remained identical to pre-patch, I've double checked.
Same problem ;//
Processor: Intel(R) Core(TM)2 Duo CPU.
RAM:4GB
02/09/2017 21:09Posted by Diobio
Processor: Intel(R) Core(TM)2 Duo CPU.
RAM:4GB

There's more than one type of Core 2 Duo. You didn't say which GPU either, or if it's running through integrated graphics. If you don't know the specs you can always post a Dxdiag file, the support site has instructions on how to do that:
Press Windows Key + R.
Type DxDiag and press Enter.
In the DxDiag window, click Save All Information.
Name the file "dxdiag" and click Save.

Then paste the text here on the forums, please do not upload it to a file hosting service.
Did you try changing the game to Directx9 or was it already running that?
Here's the DxDiag text:
------------------
System Information
------------------
Time of this report: 9/2/2017, 13:25:01
Machine name: JOHN-THINK
Operating System: Windows 7 Professional 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.170707-0600)
Language: English (Regional Setting: English)
System Manufacturer: LENOVO
System Model: 1165AEG
BIOS: LENOVO BIOS Rev: 1.0
Processor: Intel(R) Core(TM)2 Duo CPU E7500 @ 2.93GHz (2 CPUs), ~2.9GHz
Memory: 4096MB RAM
Available OS Memory: 2942MB RAM
Page File: 1838MB used, 4042MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices

It is integrated.
It sounds like you're running the game on a computer that hasn't been supported for a while, the only integrated cards they support these days seem to be ones on more modern CPUs. There's no telling whether they'll change anything that will make the game run better on your hardware again, and I can't really advise you to contact support because most they will just tell you the game isn't guaranteed to run properly on your PC :/
Like I said above at most you can try changing the game to DirectX9 but people are reporting even with that it still runs pretty badly, even if it does load everything. I don't know what they've changed in this last patch to make this happen as there's nothing on the patchnotes that I could see.
My specs were just about standard enough to run WoW, on Vista and even on a sub standard card as well. I could play in every zone quite easily at a reasonable 40 ish fps on lowest settings.

7.3 comes, and i'm literally down to 4 fps in EVERY zone, even if i am stood on a patch of grass and nothing else is in sight. Strangely, mount up, gain a bit of height and my fps climbs into the 40's.

They've obviously done 'something' in 7.3 because the game is now totally unplayable, not even for me, but for people on v good machines too.

https://us.battle.net/forums/en/wow/topic/20758886821?page=1
It has completely crashed my pc - now won't reboot :( Started freexing/not responding following patch
My graphics arent displaying only menus and character lists
really gutted atm coz i just want to lvl up a couple of my other toons
03/09/2017 10:14Posted by Lswindrunner
They've obviously done 'something' in 7.3 because the game is now totally unplayable, not even for me, but for people on v good machines too.

No idea what your particular problem is, nor that of people on good machines (other than that there are issues with every patch for various reasons). The person that opened this thread is just running on hardware that hasn't been supported for a minimum of a year and possibly since WoD. The game also reset the graphic settings for many players, if not all, on patch release. It happens occasionally.

03/09/2017 12:28Posted by Kittygalore
My graphics arent displaying only menus and character lists
really gutted atm coz i just want to lvl up a couple of my other toons

Try changing to Directx 9 if your game is on 11.

Join the Conversation

Return to Forum