Gtx 1060 low fps

Technical Support
Recently, i purchased a gtx 1060 and was really hyped to jump into WoW, but for some reason my fps are 45 at best. I usually get around 30. The settings i use are the optimized from the Geforce Experience. Note that, this only happens in WoW. Every other game runs really smoothly. I tried repairing, uninstalling and reistalling the game, but it didnt work. I have made sure that my drivers are up to date.

Any ideas what i can do?

PC specs:
GTX 1060 3gb
intel core i3-6100 at 3.7ghz
8gb ram
windows10 pro 64bit
GTX 1060 is not exactly a powerful card but I would expect you to get more than 45 FPS out of it.

What are your graphical settings set to in WoW? If you turn everything off does your FPS improve? What happens if you don't use GeForce experience to force the settings?
If i turn everything off, and i mean EVERYTHING, i get 55-65, which is still really low. I know people playing Wow with better performance settings than i am, using a much older gpu.

as for the graphic settings i use are these:
http://imgur.com/gallery/yht6HSy
That's not everything off, it says Custom and you have several things on high settings or above. Also you're running at higher than 1080p, what happens if you change to fullscreen and change the resolution? Is your render scale (which is not in that window, it's in Advanced) at 100% or higher?
Look at the resolution you've got set - you're doing some kind of downscaling. I assume your monitor is 1920x1080, so you've got it configured to render at a much higher resolution (2715x1527) and then downscale it, which will have the impact of running slower (since it has to render a large scene and then downscale it in comparison to running at a native resolution). This means you're rendering the game at levels above what most VR headsets have in terms of pixel count, yet using a card that is below the required level to run that many pixels (the generally accepted minimum for VR resolutions is a GTX 1070)

Set it to 1920x1080 and see if that improves things. You may need to do this in the graphics drivers/GeForce Experience.

Also ensure the scaling option under advanced isn't set higher than 100% as this does the same thing but in game, rather than in the graphics drivers.

Another thing to consider is that running at "high" texture settings on a low end card might also introduce issues, since texture settings are generally controlled by how much RAM you have on the card and lower model cards have less RAM. The same applies to high levels of anti-aliasing, texture filtering, particle effects, etc.
22/08/2017 16:35Posted by Nyshae
That's not everything off, it says Custom and you have several things on high settings or above. Also you're running at higher than 1080p, what happens if you change to fullscreen and change the resolution? Is your render scale (which is not in that window, it's in Advanced) at 100% or higher?


22/08/2017 16:35Posted by Flyk
Look at the resolution you've got set - you're doing some kind of downscaling. I assume your monitor is 1920x1080, so you've got it configured to render at a much higher resolution (2715x1527) and then downscale it, which will have the impact of running slower (since it has to render a large scene and then downscale it in comparison to running at a native resolution). This means you're rendering the game at levels above what most VR headsets have in terms of pixel count, yet using a card that is below the required level to run that many pixels (the generally accepted minimum for VR resolutions is a GTX 1070)

Set it to 1920x1080 and see if that improves things. You may need to do this in the graphics drivers/GeForce Experience.

Also ensure the scaling option under advanced isn't set higher than 100% as this does the same thing but in game, rather than in the graphics drivers.

Another thing to consider is that running at "high" texture settings on a low end card might also introduce issues, since texture settings are generally controlled by how much RAM you have on the card and lower model cards have less RAM. The same applies to high levels of anti-aliasing, texture filtering, particle effects, etc.


The screenshot was taken after i turned everything off as i said, and when i optimized it again, the resolution went to 2715x1527 by default. That was my bad. I changed it to 1920x1080 as i should. My render scale is 100%. My fps still havent changed though.
I dont know if this will help or not but before i purchased my 1060 i had an AMD Radeon Rx470 and it run on 90-100 fps with everything maxed out
i think its because u dont have strong cpu , i have 1060 too in windows 7 always getting good fps
Using 1060 myself. Running everything on max except for "environment Detail"(which is on 7). I have average of 120 FPS...

Check if your CPU and GPU are not overheating, go through power options and also try running fullscreen, rather than windowed fullscreen
Overheat shouldnt be a problem, since they usually both work on normal temperatures, around 45 Celsius. When i had the rx470, i had the same cpu, so this could not be it. I have tried running it on fullscreen, but nothing really changed. I, too, am confused. I cannot find what is the problem here :/
Yeah, 45 is perfect temperature, so that's not the case...

You could try reinstalling your drivers or try rolling back the version when it was fine, just to check. Had that on one of my AMD cards some time ago.
I have same issue with 1060 in Heroes of the storm 10-30fps
GPU load 2%
That's strange. I have the same processor with an RX 480 which is on par with the 1060 if not very slightly weaker and get upwards or 70+ frames on all maxed out settings. Only in raids do I have to turn it down because the 6100 can't handle too many effects.

I recommend trying these:

1. Turn V-Sync off. It's a framerate killer if you can't stay above a constant 60 (assuming you have a 60 Hz monitor)
2. Check your MSAA setting under the "Advanced" tab. You might find it's on 8x which would significantly reduce your FPS.
3. Disable any addons. Doesn't look like you use many from the screenshot but worth mentioning.
4. Make sure your drivers are up to date.
5. Look through your Geforce settings. I have an AMD card as stated earlier so don't know much about Geforce but you could find something that ruins your frames in there.
03/01/2018 17:17Posted by Yanare
I have same issue with 1060 in Heroes of the storm 10-30fps
GPU load 2%

That seems very odd, what other components do you have?
What is your cpu at?
You only need to do one thing.

Change to high performance on graphic card and I promise you will notice difference so did I. I have Gigabyte nVidia Windforce 1060 oc and CPU i7 3770.
PROBLEM SOLVED!
I'm pretty sure I found the problem. Have a new 1060 card. I had 20fps while playing.. reduced all graphics completely but nothing.
Then.......I noticed that I was playing in windowed (full screen) mode. I changed it to completely full screen and it completely solved everything. I run at 100 fps at full graphics settings now.

Join the Conversation

Return to Forum