Mouse goes haywire in wow

Technical Support
01/09/2017 17:03Posted by Zorieke
I disabled the MAX fore and back ground FPS + lowered the mouse speed in the ingame menu.. seems like that did the trick for me.


This seems like it worked for me, thanks :)
Nothinf is working. Disable WoW soon and will do the trick, unfortunately. Guess this will be our last year of playing WoW. After 10 years is time to quit as Blizz have something against Mac. I will not buy a special pc only for Wow.
02/09/2017 14:06Posted by Skorpya
Nothinf is working. Disable WoW soon and will do the trick, unfortunately. Guess this will be our last year of playing WoW. After 10 years is time to quit as Blizz have something against Mac. I will not buy a special pc only for Wow.


It is not like it is a mac issue only and don't act special/superior just because you have a 'mac', no one really cares with such attitude. Just use a work around when one is found for you and otherwise hold out for a bit. Can I otherwise recommend joining the army, my comrades still need help defending against Russia.

31/08/2017 23:37Posted by Arcatir
Someone on the US forum suggested it might be due to ~1000hz mouse refresh rate. People with mouse software (e.g. Razer) might be able to lower this which apparently can fix the issue. I'm off to try it now.

This helped on my side for the major part, now and then still a small issue but not all the time. Though lowering it does not help when playing other games or when working for my new job.
Foregorund / Background limiter seemed to do the trick, however, I'd like to limit my framerate regardless.

Rather have a stable 144 than fluctuating framerate :/
owke for me turning off background and foreground fps worked it hasnt done it anymore so far.

Hope this helps for more people! thanks for getting this post to get noticed!
If you still have problems just leave it here!
31/08/2017 12:25Posted by Jaromirr
Supposedly turning off Razeringameengine.exe in task manager solves this, but seeing as some people here are using Zowies and Steelseries, that kind of debunks that. Interested to see where this goes, glad to know I'm not alone. I just bought a second mouse for FPS in addition to my Naga yesterday, so I was panicking that that was causing it, glad that it's not.


This absolutly helped!
Delete Razeringameengine.exe from the taskmanager!

Thanks pal
I have had this problem myself with a razer taipan for months until i found out it onley happends under high cpu load,i could make it happen on demand by starting up a download at 300mbit wich whould make my cpu jump to 100% load and my camera whould start spinning non stop.

After days of testing i found out that the fix for me whould be putting wow on 144hz and desktop at 120hz, havent had my mouse spinning for about 2 months now.
I wrote a topic about this issue and how to fix it, now it's gone. Anyway....

System -> Advanced -> Disable Hardware Cursor.
Fixed all my problems, which were previously unsolved with any blue post suggestions by the time I did this.
https://eu.battle.net/forums/en/wow/topic/17616802933?page=2#post-31

I would love it if the blizzard team would stopped passing the blame to the users and software providers. Last time the reason was because of a windows update/mouse software issue.

THE ISSUE IS ON BLIZZARD SIDE. This problem happened before the last patch but it was rare it happened and it would be on all the time not on and off like it is now a reload on the ui fixed that problem, After 7.3 patch the mouse as been all over and as killed me a number of times making anything but grinding quest a pain in the backside.

I played PTR and they was never any of the jilting in the mouse sensitivity. i can play with my mouse on 16000 DPI what is fast but the bug go's even faster.

Sort your acts out.
ye it helped ffor me, i disabled max forground and background fps and it stopped gliching !

CHEERS boys
Same here bois but on a Corsair Schimitar Pro.
I got bug with mouse to in wow the mouse is on the low mode on dpi and still go 360 like each 3/10 min and the other to ppl i plan with have the same problem and it do not do in other games so most be a wow bug help plz
I have the same sensitivity problem using both my Logitech G502 and my Corsair Vengeance M60 so it's not a mouse driver issue.
This is a very old bug they never fixed dont set sensitivity uncap fps aka no max fore ground fps and lock cursor to window at mouse options inside interface thats how i set it up havent had issues yet dont enable mouse sensitivity it does't even use raw input and its buggy if its not checked re check it and uncheck it, this will help for anything.
"/console rawMouseEnable 1" worked for me
I had the same issue with my Naga and all I did was disable the heatmap tracking on the Synapse app. Haven't had the issue since then. Sadly I don't know how to fix other brands :(
delete

Join the Conversation

Return to Forum