Arcane shot and multi-shot animation delay

Hunter
Hi.

I have MM-hunter, created from about 7.2, and have annoying issues with two abilities - arcane shot and multi-shot.

They have a masssive delay between the damage and animation appear in 90% of the time. In the dungeons the problem disappears.
It's looks like here - https://www.youtube.com/watch?v=Gj4BGDJ_PIw

I have a stable 115-118 ms latency, any attempts to fix it with "SpellQueueWindow" does not working here.

I reported the problem (Submit Bug) many-many times, long times ago, have no reactions, and still see some topics about it only on us.battle.net forums with no sane answers or solutions.
Amazing, like I said -

24/09/2017 06:40Posted by Mechanicus
still see some topics about it only on us.battle.net forums with no sane answers or solutions.


А fictional problem.
26/09/2017 04:14Posted by Mechanicus
Amazing, like I said -

24/09/2017 06:40Posted by Mechanicus
still see some topics about it only on us.battle.net forums with no sane answers or solutions.


А fictional problem.


It's been reported several times, spamming it wont do much as its low on their priority list of bugs in the game to fix. I'd rather have them put effort into fixing current raid tier bugs (maiden) and dungeons than an animation which they know are buggy. Tickets do the work more than enough
I used to have this problem a couple months ago before I took a break from WoW. Came back a week ago and haven't had this problem yet. All my spell effects are lined up with the damage.

Only thing I can think of is that I updated my nvidia drivers to version 384.94.
30/09/2017 15:56Posted by Treadmiller

Only thing I can think of is that I updated my nvidia drivers to version 384.94.


IDK, have the same version.

Moreover, the same effect began with concussive shot for me.
Nevermind playing this character, or another new hunter MM/BM on other server.

Great, waiting for the growing priorities for this trifle. Half-year, year, 8.0.

Join the Conversation

Return to Forum