Wow was unable to start up 3D acceleration.

Technical Support
Been getting this error on my laptop since yesterday.
I've tried doing a reset of Windows, all updates have been installed and there seem to be no driver updates available anymore.

Any help would be appreciated.

I'd post my DxDiag file, but even when I quote it, the maximum character limit of 50000 gets exceeded.
Hey Évà,

To start with, I would strongly suggest you remove your current Graphics drivers using a Display Driver Uninstaller. Once fully removed, install newly downloaded drivers and test once more.

If that still does not help out, we'll need your System Files to look into this further. Please go through the steps listed here, and create both the MSInfo and DxDiag files. Post them on a page like Pastebin.com or through OneDrive once you have the files ready, and post the links here so we can have a look.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi
I get the exact same problem, but only when trying to log into Live, while PTR works just fine. I ran the Intel Driver scan and it found nothing.
it’s something to do with the new windows update, my wow has this issue since the windows update, haven’t installed the update on my brothers computer and wow works fine
YES, EXACTLY! It all started after the latest update for me too!
This is destroying my soul ive uninstalled wow, uninstalled drivers uninstalled windows updates, still nothing
13/12/2017 22:25Posted by Roachie
This is destroying my soul ive uninstalled wow, uninstalled drivers uninstalled windows updates, still nothing

Too bad you unninstalled system, next time recover previous state of system from before the update, and update when its more stable.
Marked As Solution
Check this:

• Windows 10 Game DVR:

To disable the FSO, simply follow these steps:

1. Go to the game folder for the game you're having problems with
2. Find the game's application/.exe file. Right click the file and choose "Properties."
3. In the Properties menu, click the "Compatibility" tab
4. Click "Disable Fullscreen Optimizations"
5. Click Apply
6. Repeat this for any application/.exe files for the game having problems.
YES!!! IT WORKED!! Thanks Sylvia! :D
15/12/2017 16:10Posted by Sýlvía
Check this:

[quote]• Windows 10 Game DVR:

To disable the FSO, simply follow these steps:

1. Go to the game folder for the game you're having problems with
2. Find the game's application/.exe file. Right click the file and choose "Properties."
3. In the Properties menu, click the "Compatibility" tab
4. Click "Disable Fullscreen Optimizations"
5. Click Apply
6. Repeat this for any application/.exe files for the game having problems.


Interesting. After Windows update my game started to work very badly. Fps dropped from around 140 to 40 and everything felt off. This helped for me as well. Game works like it always did :) Thanks
This solution worked for me too, after Windows update, and I changed the compatibility option for every "Wow" exe. Thank you very much!

15/12/2017 16:10Posted by Sýlvía
Check this:

[quote]• Windows 10 Game DVR:

To disable the FSO, simply follow these steps:

1. Go to the game folder for the game you're having problems with
2. Find the game's application/.exe file. Right click the file and choose "Properties."
3. In the Properties menu, click the "Compatibility" tab
4. Click "Disable Fullscreen Optimizations"
5. Click Apply
6. Repeat this for any application/.exe files for the game having problems.
15/12/2017 16:10Posted by Sýlvía
Check this:

[quote]• Windows 10 Game DVR:

To disable the FSO, simply follow these steps:

1. Go to the game folder for the game you're having problems with
2. Find the game's application/.exe file. Right click the file and choose "Properties."
3. In the Properties menu, click the "Compatibility" tab
4. Click "Disable Fullscreen Optimizations"
5. Click Apply
6. Repeat this for any application/.exe files for the game having problems.


This is my second post on these forums since I started in 2005 , this is the best solution for this issue. My issue started when i connected my laptop with a monitor and this fixed it.
My game starts, but i dont get an image up. I only get the wow mouse and thats it
20/02/2018 08:51Posted by Hustling
My game starts, but i dont get an image up. I only get the wow mouse and thats it


FIXED
I still get the same error. Send help ples.
23/02/2018 20:10Posted by Drowzybetsy
I still get the same error. Send help ples.


same....
20/02/2018 08:57Posted by Hustling
20/02/2018 08:51Posted by Hustling
My game starts, but i dont get an image up. I only get the wow mouse and thats it


FIXED


how did you fix it? i have the same problem. the game is running but there is no screen, only the sound and the wow cursor
I keep getting this problem but *only* after I have run BlueStacks, an Android emulator for Windows. Rebooting clears the error but only if I run WOW first, before running BlueStacks. As soon as BlueStacks is running, trying to run WOW generates that error.

When I open file location, I find four Application files:
BlizzardError
World of Warcraft Launcher
Wow
Wow-64

Changing the Compatibility setting in Properties did not clear the "cannot start 3D acceleration" error for any of these.

Join the Conversation

Return to Forum