WOW51900322: streaming error

Technical Support
Since the last update (7.3.5.26899), I keep getting disconnected with the WOW51900322 streaming error messages. I have been able to connect after having disabled all addons and could narrow the problem, in my case, to the following addons: DejaCharacterStats, Details, Filter, Rarity, SimulationCraft,] TradeSkillMaster, Weakauras2. After having disabled them, I've am able to connect., but I do need some of these addons.

I'm playing on a Linux machine (via Lutris) and the issue seems to only show up for people of the Linux gaming community. This is what I guess from the same thread which is going on on the US servers :

https://us.battle.net/forums/en/wow/topic/20765466460

But I can't post there. So I'm posting here with the hope that the information provided here will reach people there thanks to whatever search engine...
Also note https://eu.battle.net/forums/en/wow/topic/17620271965
In my case I can login with not working character once I clear Cache folder. Just once though, next login will cause that error again. All other characters work fine, except the Auctioneer addon - when I try to do auction house scan (any mode, fast scan or slow scan), I'm disconnected in next second.
Ive just had a disconnect with this error in a vanilla ui (no addons running) on my priest so dunno why i happens

PS: ive also seen the 3x item not ready spam and then it disconnects,Ive just had a disconnect with this error in a vanilla ui (no addons running) on my priest so dunno why i happens
I have this error sometimes just at login with all characters, sometimes at random moments but always just as I login with my recent 110 Goblin Afliction Warlock and always when I'm trying to see the appareances for transmog.
Plus I'm getting this error too when I try to open the summer bags from the dungeon.
I'm using Debian Testing using Wine Staging 3.10, No Addons and Cache and WTF deleted.
Happens since the lat patch at Thursday.
Can confirm this happening on Linux Mint using Lutris. Disableing all addons in game through the AddOns menu works completely fine for me - altough this is not really an option for me.

Just enabling Tradeskillmaster is enough to break it, which is the only addon I can not just "not use", lol
Was the problem for me aswell. Here is a topic on Lutris forum: https://forums.lutris.net/t/world-of-warcraft-streaming-error/2322/3

No solution yet.
It would be great if this could be fixed even though Linux is not offially supported.
This now seems to be happening in a random way for me:(1) after having teleported to Timeless Isle; (2) while trying to loot in the Mechanar; and (3) just now in the middle of a flight in the the Broken Isles, from Dalaran to Tornheim (actually got deconnected twice in a row, could log in at the third attempt my char is now swimming in the middle of see, South-East of Suramar).

Difficult for me to see any pattern in what's going on.
This again happen while flying, this time from Highmountain to Azsuna (I have to add that I'm using standard flightpaths). My char was stuck in the middle of a fall and I was continuously getting disconnected till I decided to disable all addons. I could then connect and re-enabled the following addons: Ask Mr Robot, Atlas, BagBrother, Bagnon, Kui Nameplates, Pawn, TomTom, World Quests Lists, AddOnSkins, Elvui Aura Bars Movers, and Elvui. Things seem to go fine; I could at least get rid of WQs. With this setting, I will try to use the flightpaths tomorrow. Best!
Hey guys,
Just to be clear are you all on Linux based systems? Since we don't support Linux I'm unable to provide you with any troubleshooting steps.

_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh
I don't think anyone believes this is a problem we ourselves can solve.
Post by Blaise form us forums:
Update:

After having logged on all my charactrers from Windows:

I tried copying my Cache/ folder from my Windows install to my Linux one, and it seems to have fixed the issue for me.

Can anyone else try and confirm?


Looks like that worked for me as well. I have KVM/QEMU VM with Windows, so I copied WoW via SMB, "played" for a while, and moved cache back to Linux Host.
So far no problems at all.
Update:

Transmog vendor - pass
Over 50 addons active - pass
Riding - pass
M+ - pass
Leveling - pass

That Cache dir workaround works perfect.
Can confirm the same problem.

Arch linux x86-64 using Wow64 client via lutris. Thou didnt make any difference for fresh prefix with latest wine.

i guess ill try the Cache trick also.

_______________________

Solved the issue by deleting linux side Cache directory and copied Cache upgraded by windows to linux/lutris path of wow. Addons working also.
Confirmation: I could also have WoW working again on Linux (1) by copying the game (with no Cache directory) into a windows machine [a virtual machine (virtualbox), a real pain (have had to enlarge the disk and enable directx9)!!]; (2) simply start the game (couldn't play with fps~0) and (3) by copying the generated Cache directory back into the Linux installation.

When I first met this issue I deleted the Cache, WTF and Interface directories, and they were rebuilt supposedly from scratch(?) when the game is started.. Still have no idea of what's going on.

I feel very sad for those without access to a windows machine .

Best
Hi,

if you disable streaming in the game options in battlenet-window, you can login normally; but if you logout, to change character your account won't be recognized. You will have to restart, reenable streaming login and if the char has an 'streaming error' disable streaming.... and so on. After all, this seems to be a solution for the time waiting for Blizzard to fix the problem.

Best Regards
Hi again,

it's not a solution; i jumprd the gun, you'll get th erro message ingame. Sorry

Brgds
Ran into the exact same situation with a 17.10 ubuntu. (its been going on on and off for past few days)

for anyone who doesn't have access to a windows copy of cache folder, copying cache from wine install of the Beta seems to have fixed the issue (so far)

also US support and lutris threads relevant to this: (I hope it is alright to link these)
https://us.battle.net/forums/en/wow/topic/20765466460
https://forums.lutris.net/t/world-of-warcraft-streaming-error/2322/13
I have same problem on ubuntu Ubuntu 18.04. I hope a linux lover at blizzard can help us.
It getting worse. Yesterday I could login to my main character after clearing Cache directory, and had no problems with other characters. Today (after servers restarts) I can log just for few seconds on either character, and only after clearing Cache. Without clearing I'm disconnected immediately. Game became totally unplayable. Hey, Blizzard, what have I done? I was your loyal subscriber for over 10 years, and now you hate me?

Join the Conversation

Return to Forum