8700K, 1080, Terrible FPS even at low settings

Technical Support
I'm scratching my head a bit here. Tried for hours to figure out what's causing some massive FPS drops on my rig. We're talking something like unplayable single digit FPS in your typical world boss encounter in Stormwind, even at low settings.

I've tried everything at this point it seems. DDU, followed by a clean nVidia driver, dropped my 5ghz OC on the 8700K to factory default turbo settings, checked for overheating (rather unlikely given custom water loop)

I'd put my DXDIAG here but "You’ve exceeded the maximum character limit of 50,000" ...

Edit: Pastebin to the rescue! https://pastebin.com/P7H8Wzf3
Tried for hours including setting dx mode to directx 11? :)
Now quite some people have been reporting fps drops and micro stutters. Seems like Blizz really got something screwed at their end.
Gave up and started playing Overwatch.... and it's showing the same weird behaviour. It's as if every menu reacts very sluggishly. Also the same FPS issues - A game I have been able to Ultra at 1440P with this setup before, is suddenly slow to react on the main menu.
i have the same problem that did not happen before 8.0.1
my computer is very strong 1080 GTX nvidia and loads of hard memory
and i ran the game on ultra without any problem before 8.0.1 kicked in.
i just get to have fps drops from 60-80 on most of the time down to 5-7 when it occurs as random as rain in mid summer/

tried to contact support but GMs only come up with update your graphic driver and windows and delete some background proggrams.
i feel like i want to pluck my hair here...
i mean i ran heavier games than world of Warcraft even after the requirements jumped because of the new expansion.

i starting to think about formating the whole computer to eliminate that option Blizzard employee always bragging about when you contact their support even though i know for certain its not the case.

anyone knows if its going to be fixed untill 14.08?
GTX 1060 using driver 397.54 running DX11, (DX12 sluggish performance).

Driver link:
https://forums.guru3d.com/threads/nvidia-397-54-vulkan-developer-beta-driver.420843/

Examples:
Dalaran - 80+ fps Krasus Landing - 50+ In the city.
Eye of Azshara - 60 to 70 fps

Nvidia Control Panel settings:
Power Management Mode - Prefer Maximum Power
Vertical Sync - Fast

In Game:
Max Foreground 120fps and Max Background 30 fps
Vsync - Disabled

Note: Fast Sync only works on 10 series cards and for it to function vsync must be disabled in any game.

Hope this may help.
Hey everyone,

thanks for the heads-up on this matter, I can relate to the frustration that this caused. With the patch indeed a lot of ingame and tech side changes had been added to the game and the transition is well.. wonky at best.

That's said thanks to Kusagi for sharing some of the steps he did and seemed to even out the FPS across the game. Can you guys check and see if these works for you as well or you still have FPS dips at time?
I have an i7 and a GTX1015, and experienced very low average fps (like in the 30) after the prepatch.. I was able to get a stable 60fps (with vsync) almost anywhere before. I tried everything, from updating drivers, disabling the Intel GPU, restting settings, going from dx11 to 12 and back. Even lowering the graphics settings didn't do anything. I was looking to see if the GPU or CPU was throttling (as I am using a Surface Book 2), but the temperatures was just fine.
But what seemed to do the trick was to "disable full-screen optimisations".

Simply go to your wow folder, find wow.exe, rightclick, choose properties, go to compatablility, and check "disable full-screen optimisations".
Viola, im getting an average of 75 fps, with quality settings around 8-9 (fair shadows and liquids), on DX12.
I also have the i7-8700,16gb,1080.x2@ultra1440p and ran into some problems after pach aswell. though i managed to the fps up to playable Levels again.

In my case i had to DISABLE GSYNC for windowed mode in nvidia settings, and i also had to DEACTIVATE SLI entirely. the per.game settings in nvidia Control panel seemes to have NO EFFEct on wow.exe

In game i notice that the renderscale@200% is much more demanding than the now removed SSAAx4 + CMAA and causes at least 10-20 fps dropped compared to the new option.
So why not use any other AA options? because the 200% is the only that will make the small nametags readable and less blocky in the distance, it also makes my Nice ears in one piece :-) the cmaa post process AA wil make the edges even smoother(specially staircases)
Blizzard could make the renderscale less important just by rendering the nametags with higher quality and save us a whole lotta gold for expensive rendering Power ;-)

As far as DX12 goes.. it dont even work on my system. it just instacrashes before i when i clicky the play button :-(
I also have this issue, my fps is max 15 and regularly below 10 which is not playable. I play on a Macbook Pro 2015 with a 2,5GHz I7, 16GB RAM & AMD Radeon R9 M370X 2048 MB graphic card. Should be more than enough to play with this game with 50 fps atleast...

I tried to disable Vsync, change fore and background fps settings, disabled addons, even put the graphics quality to 1 but unfortunately nothing helped.

I don't know how Blizzard is gonna help all the people with this FPS issue but I hope that there will be a solution for many of us.

Join the Conversation

Return to Forum