Microstutters, help please, out of ideas

Technical Support
I do not get this
Disable Fullscreen Optimizations

it is supposed to improve games, thats what it is for. All other games can run dx12 in fullscreen but not this game.
16/09/2018 17:38Posted by Lekro

- I installed the latest driver from nvidia, that includes directx I believe?


nope
uncheck bing bar during install
https://www.microsoft.com/en-us/Download/confirmation.aspx?id=35
16/09/2018 17:47Posted by Savola
16/09/2018 17:38Posted by Lekro

- I installed the latest driver from nvidia, that includes directx I believe?


nope
https://www.microsoft.com/en-us/Download/confirmation.aspx?id=35

But then how would I run any games at all if I don't have directx installed?
this file is the 1st thing to get after running windows update on fresh install.
always
it contains dev dx libraries required by almost any game, steam installs it everytime when installing any game so there is a chance you may have it. just run it
why ms didnt include it by default in windows is a ten thousand years old mystery
Okay I ran it, going to test how it goes now.

Update: Still stuttering.
Any ideas to solve our problem? It's nearly imposiable to play arena with such stuttering. =(
Try the following:
Enable 'Vsync'
Disable 'Triple Buffering'
Enable 'Reduce Input Lag'

Test this and tell me if you see any difference. I might do, but I need more time with it to come to a conclusion.
Issue is still present regardless of this setting, although seems somewhat better.

I'm still thinking it has a connection to world server lag because it happens more often when the servers are laggy during the evening hours.

Also one time there was a disconnect from the world server (home was still active, I could read and type in the chat) and I started wandering around without NPCs being loaded and all and there was no stutter that way.

I think the client is fetching data ahead (that would explain why it occures when you hover over NPCs that you can interact with, like the Ferry Master) and the server is lagging behind to provide it, making a hiccup in the client.
are you on wifi connection? mtr test looking good?
Wired connection with 0% packet loss. The lag I'm experiencing is the same as others do. The disconnect I mentioned happened realm-wide.
Also for the last few days since the server lag is less, the stutter has occured fewer times than before.
Greetings to everyone. I am only reviving this thread because, just like many of you, i had the micro-stutter problem and after trying to modify absolutely every option in-game and in Windows (DX, Vsync, FPS limmiter, Fullscreen Optimizations, Game Mode, etc., etc.) i was not able to solve my problem.

I will post my set up only because i am 100% sure it was the thing causing the problem, or to be more precise it was a combination of My Setup, The new WoW expansion(DX12 + Fullscreen changes) and Windows 10.
Lenovo y50-70, GTX 860M, intel i7-4710HQ, 48 Hz Screen.

After the patch that removed Exclusive Fullscreen i played while connected to an external 60 Hz and i had no problems. The moment i left home i was forced to use the normal laptop monitor and the problems manifested themselves. Also, out of all the games i play, it only happens in WoW.

I know not all of you have 48Hz monitors and so it is possible that the solution i found may not apply to you but if there is nothing else you can do, and you are willing to make this change, you might as well try.

MY SOLUTION: Revert to Windows 8.1

I know it's ugly but it's just better optimized and tbh most games run slightly better on it. Until Blizzard solves this issue you have 3 options- don't play WoW, play with massive micro-stutter or revert to Win 8.1 (7 will probably work as well tbh). And if you don't have a Win 8.1 key, then unfortunately you are only left with the first 2 options.
Getting the same problems, but only in BFA areas. In stormwing, dalaran or older areas, nothing happens.
For amd gpus the only way I found solved my issues, going on for some time, was updating graphics card bios and undervolt both core voltage and memory voltage by a mere 0.025 volts.

Might not apply to nvidia but worth trying for any amd users.
Tried Saryzan's solutions today, again. This time, the mouse sensitivity and fullscreen ones made some diference... untill I joined an instance. At that point, the microstutter came back. Not as bad as it was but still very much present.
Update: Did not fix.

I fixed my particular issue.

I have an Asus Z97-K motherboard and when I overclocked my i5 4690k to 4.4Ghz@1.2v I set the AI Overclock Tuner option to manual from auto.

This made the BCLK to sit at 100Mhz constant, affecting the CPU, RAM and PCIe clocks. After setting the AI Overclock Tuner back to auto and leaving my OC at 4.4Ghz the stutter is gone. Now my CPU clocks are not even numbers and I believe that is because the auto setting sets the optimal BCLK on the go.
changing bclk from 100 to anything else is always bad idea.
take a a look here, great guide
https://www.overclock.net/forum/5-intel-cpus/1411077-haswell-overclocking-guide-statistics.html
I specifically mentioned that I set the BCLK TO 100 fixed and that was causing the issue, not changing it FROM 100. Setting it back to auto made it variable and the issue is gone.
As an update, what I did was pointless and I only thought it fixed the issue. It didn't.
Waiting for the 8.1 multithreading update at this point.

The last couple days I haven't experienced the issue and I don't want to write things early again but what I tried now is a setting that was completely out of the question and is known for "should be disabled no matter what".
I enabled Windows 10 Game Mode for WoW.

Now I did benchmarking tests in other games and the framerate shows no impact over multiple tests but in WoW I never got these frame skips since then.

Fingers crossed, I won't be updating this thread anymore even if this turns out to be not working again.

I hope 8.1 will fix it for everyone. Or try Game Mode if you haven't, worth a try, you can disable it afterall.

Thanks for the inputs everyone.
are you on win10 october or still april update?

Join the Conversation

Return to Forum