Mage Challenge bear skin bugging ALL skins animations

Druid
1 2 3 5 Next
Completing mage tower challenge had side effect of bugging animations for other skins of guardian druid. They use only autoattack and roar animation for every spell. We are lacking of information from Blizzard seeing this problem since Legion. It drive me mad to see wrong animations for every skin expect default bear.
We had topics about no dance animation for werebear but this is more than this. Sometime u want and need to see animations of your attack instead of same autoattack animation for every single spell. I tried to post it in general forums but it was flooded by random topics about nothing.

#Edit
Video proof https://www.youtube.com/watch?v=jdWDezIvmac
Have posted in every relevant forum, reported bug, made suggestion, even a topic on Reddit about the complete lack of animations/bugged animations and the fact that new trial druids have correct, functioning animations when t-mog to the Claws.
No reply, no acknowledgment. At this point in time I'm considering to just run base bear after seeing what all the legion skin animations should be, compared to what we get now.
Huh? That bug doesnt occur with everyone, because I dont have it.
You may not, and that's great for you! But a lot have this issue. I have unlocked every single skin on this character but when I t-mog (and before with the artifact) to Claws, I have no animations for any of the skins. Just auto attack and roar.

However when I make a trial I can see all the animations working perfectly fine.
Same for when I swap weapon in combat on this, they'll work for a few seconds then vanish and revert to auto attack animations.
There's posts on both EU and US about this and it seems to affect the druid that unlocked the skins, not alts made after that didn't unlock it.

Either way, it's been around for a while and it'd still be great to have some sort of reply as to whether it's being looked in to or at least acknowledged as not working as intended..
27/08/2018 12:26Posted by Uvireath
Huh? That bug doesnt occur with everyone, because I dont have it.


Have you completed Challenge Appearence from Mage Tower?
Holy Crap, I just tested that. I didnt know Bear has so many animations, I didnt use the basic form since Legion. I thought Swipe and Roar are the only ones.

Okay, now I´m pissed! Is there any reaction from Blizz because of this bug?
Not a word. As said I have posted on EVERY forum I could think it would apply to, and bug reported/made suggestion/Reddit. But nothing.

I REALLY want some kind of feedback already. No blue posts for Guardian class feedback threads and nothing for glitched animations... :(
We have to get more expose about this, link this post to your friends and let them upvote it and maybe post here to get better view count. I hope for fix ASAP.
27/08/2018 11:30Posted by Aurelliea
Have posted in every relevant forum, reported bug, made suggestion, even a topic on Reddit about the complete lack of animations/bugged animations and the fact that new trial druids have correct, functioning animations when t-mog to the Claws.
No reply, no acknowledgment. At this point in time I'm considering to just run base bear after seeing what all the legion skin animations should be, compared to what we get now.


I'm genuinely very happy that you've put my immense frustration into.. well, pretty normal, polite wording.

27/08/2018 13:03Posted by Aurelliea
You may not, and that's great for you! But a lot have this issue. I have unlocked every single skin on this character but when I t-mog (and before with the artifact) to Claws, I have no animations for any of the skins. Just auto attack and roar.


Exactly the same issue. I first reported this.. something like 13 months ago, now. I thought it'd be patched in 7.3. Then I thought it'd be patched in 7.3.5. Then I thought it'd be patched in BfA....

I've made bug multiple bug reports.. sometimes several in a week. I made a Reddit post but it was just ignored. I've made multiple tickets - at least one forum thread, though I think I've made several, and my earliest is still open.

We're just straight-up being utterly ignored. Why are Guardian Druids the only spec in the game that aren't able to transmog to their artifact weapons without breaking their entire set of animations?

I wish I could fill you all with hope and I do genuinely recommend sending in bug reports with all the details often. But genuinely I've given up.
Yesterday I transmoged to 1st Artifact skin, blue bear with red fur. Animations here are peak of being wrong. Mangle use wierd broken animation, running with barkskin makes bend character left and right. It's just horrible how things like this can be live in-game for so long.
Whats worse is that there is no word from Blizzard for it. Its not like its a minor bug.

Well, when you look at the state of Feral and Balance, maye being broken is our new class fantasy.
I have recorded this abomination of animations on dummy. This not represent whole problem but rotational abilities are shown here. Sorry for bad editing but I am no mean a expert on videoediting. I hope this will help blizzard REALISE there is a problem.

https://www.youtube.com/watch?v=jdWDezIvmac
Editing was absolutely fine in my opinion. It at least gets the point across - that ability animations (ANIMATIONS, not spell effects, big difference that people sometimes get confused over) are bugged for some Druids while using the artifact forms.

This doesn't affect newly created Druids that start to use the artifact forms, and it doesn't affect Druids using their base form. It's completely related to having A) The Artifact actually equipped, or B) Your weapon transmogrified to the artifact form.

Please, please address this. It's been 13 months. I want, I REALLY want, to be able to play as my bright purple bear sometimes - or hell, any of the skins that I earned over the 2 or so years that were Legion. It feels unpleasant to feel "unable" to use any of my artifact skins, where any other spec in the game can without messing up all their combat animations.

Don't get me wrong, I'm happy to use my default bear for a bit, and would've been using it for a bit of a while anyway. But eventually I'm going to want to start changing it up.. and right now, I feel I can't.
Your video was just fine, Vovi. And I completely agree with you Tamrah.
I just find it really disheartening that completing something like the Mage Tower could so adversely affect every other skin we've put time and effort in to obtaining.
And the lack of feedback/acknowledgement is just meh...

Not to mention a totally new/weird bug (for me at least) started happening yesterday with every other skin except the MT yeti.....................

https://imgur.com/a/R9iu1TC

Basically my bear decided to fold in on itself when being hit/dodging/I have no clue what else. In large packs my bear was constantly convulsing like that.
Reported it yesterday, and today.

A simple "We're aware and are looking in to it" or whatever would feel SO good right now.
30/08/2018 23:24Posted by Aurelliea
Basically my bear decided to fold in on itself when being hit/dodging/


It's on dodging. I noticed this and actually recorded it elsewhere, and a "BlizzardCS_Scout" said: "As fascinatingly macabre as this bug is, this is something we're currently investigating and looking into! Thank you for the video. ~TW"

So, we can probably assume this weird convulsion bug is going to be fixed very quickly. Which.. honestly makes me even more sad, because all artifact animations have been broken for 13 months, but this thing that's been weird for I think 2 days now is immediately being looked at.

Still, at least they ARE looking at that one, I'm fairly sure - they're definitely aware of this bear form dodge bug and definitely going to fix it! No idea if they even know about the Mage Tower animations one unfortunately.
Well, that's something at least I guess. Will be able to use all the animation-less skins as opposed to just the MT without having to find a very good chiropractor.

I guess we can only cross fingers that they'll actually look at the animations in general at this point.
I've just noticed it, but they evidently fixed that silly dodge bug, which is nice. I got excited because maybe, just maybe they would have noticed everything and fixed the artifact animations bug at the same time.

... I was wrong. Please, please don't let this die, though - just try keep up hope, send in a bug report about it every few days. Eventually if enough people keep sending in consistent bug reports, surely they'll at least notice and acknowledge it, if not actually fix it?
I'v tried to post video I made on reddit but it clearly didn't catch that much attention. We can post here and on mmo-c but I don't think they will even notice it.
Yeah, I made a text post about it a little while back and it got no attention, unfortunately. I think Reddit is more for larger / gamebreaking issues - this is a very minor issue compared to most things, hence why nobody really cares, even though it's been 13 months or so. More bug reports!

Join the Conversation

Return to Forum