launcher doesnt work since patch 4.2

Technical Support
1 2 3 9 Next
WoW launcher doesn’t work since I installed patch 4.2 - it loads but when I click the Play button nothing happens and the launcher window disappears. I tried disabling my antivirus software, and my firewall to see if it was being blocked but it made no difference.

I am currently loading WoW directly from wow.exe which works fine but I would still like to get the launcher working.

Does anyone have any ideas?
The same has happened to me :S I don't know whats wrong... It maybe work tomorrow or something because it is a big patch... Hope it starts to work again.
Hello Lockcast,

Please right click on the launcher and select "Run as administrator" and see if the game starts properly with the Launcher then.
hmmm same issue here too.

When i click Play the launcher just disappears and nothing happens. If i right click on the launcher and choose *run as administrator* again nothing happens. (it will offer me the choice to change blizzard launcher settings via the win7 thing, but after that nothing). The game will only load if i enter the game files and use wow.exe, which is a little fustrating.

any help would be appreciated. ( i should also point out that this a new issue today and yesterday it was working fine after both the main patch and the little hotfix one a little later)
Same issue here,and blizzard still havent found a solution for this.Nice customer service blizz.I think this problem only exists in those who use windows 7
same problem here,I've tried too the "Run as administrator" and nothing, I've tried also to go in the folder and manually put the compatibility-> run as administrator on both launcher.exe and wow.exe but nothing too
Same here
Sounds like the issue I reported yesterday
I got the same problem i reinstall the game after it was installed i could play when i quit the game start it over nothing happens it doesn't work on normal start or as admin
I managed to fixed mine - I deleted the Launcher.exe from the installation folder and then ran the repair tool, which downloaded and installed a new one. That new one works perfectly.

Edit: Ok, so it worked to get the launcher working so I could download the patch but still doesn't open wow.exe. Guess I'll have to do it from wow.exe from now on. :(
I got Vista and it doesn't work to. I delete the patch and instal it again but still wont work
repair doesn't work even if you delete the launcher.exe : it doesn't download nothing,neither a new one launcher
Same happens to me, but i can see it running on my computer though not directly on my desktop! :((
30/06/2011 11:44Posted by Efesto
repair doesn't work even if you delete the launcher.exe : it doesn't download nothing,neither a new one launcher

Repair tool downloaded a new one for me. I'm using Windows 7. The launcher opens now for me so I can download the patch. the only thing it doesn't do is open the wow.exe when you click play
Same Here

Running Windows 7 64bit

Tried deleting Launcher.exe, running the repair tool, this replaced Launcher.exe
but still when you press Play, the launcher dissappears and the game doesnt launch.
Its also being run with "Run as an administrator" box ticked.

Please resolve this issue.

[EDIT] - Directly running WOW.EXE will let me log into the game, so this must prove
there is an issue with the launcher and not with my pc.
WoW.exe is also ticked to "run as an administrator"
Same here..come on Blizzard give us the answer.

It was fine yesterday after the patch..what have you done since then?
I have set the launcher to run as admin open launcher click play then NOTHING.

run repair....Nothing

sort it out please and don't leave us all here hanging.
Ok guys Just forget about the launcher, go into your wow folder and click your wow.exe file and your in.
It's easy to say that when managed to update your version of WoW. I tried every single trick and advice I found on this forum and on google. I have spent around 12 hours trying to find a way to make that damn Launcher work again. These are my conclusions:

- is there something wrong with my computer or software? NO
- is there something wrong with my ISP ( from Blizzards point of view )? YES. I do live in a campus for now and i cannot use P2P. STILL until yesterdays patch, the launcher was working just fine which proves that Blizzard changed something with the new version and those of us living in campuses have a Zero chance of updating WoW to its latest version. NO, i cannot convince my ISP to just drop the restrictions they have on their routers, that will never happen.
- to make things worse, I have uninstalled my WoW to try and reinstall it but since every single damn file must pass through the Launcher, I am stuck I have to keep watching the same "check your internet connection" little window whenever i start the accursed thing ... There is nothing wrong on my side, was working until yesterday just fine !!! :(

Anyways, Blizzard might consider reverting whatever change they made to the Launcher that doesn't allow users like me to update. I know that the other version of making an .exe file available on the internet mirror is highly unlikely to happen..... WHY oh WHY should i ever have to remove half of my computers software to install a game? If i don't manage to find another ISP to do the update, my only other option is to sit remove WoW and cancel the subscription. I am sure there might be others like me so try and do something about it while you still can, before you realize in your next months statistics that 5-10% of your users haven't logged into the game and have stopped playing.

This was not a troll or flame post, i am just frustrated that Blizzard never admits the fault sometimes lies with them, not with the users :(
I have the same problem but i think the problem is with Win7 Updates, atleast for me.

I'v tried to delete and re-install WOW, didnt work. Then i tried to reroll Win7 back a day before Win7 had an auto update. and wow worked. But now im having problems again, and the only way i can start up the game is from the wow.exe file. So i dunno if it's with Blizz or Microsoft but something is wrong here.

Updates im talking about is named
(KB2552343), (KB2547666), (KB2545698).

And maybe Servicepack1 for Win7 not sure cuz it's not installed on my comp atm but was the first time i had probs.

Hello Lockcast,Please right click on the launcher and select "Run as administrator" and see if the game starts properly with the Launcher then.

Btw. tried that, dosent work.

Join the Conversation

Return to Forum