Interface frames becoming non-interactive.

Interface and Macros
Greetings. I've been experiencing this problem for a while, absolutely no clue what causes it, I got lots of addons, but none of them seems likely to cause such a problem and due to the nature of the problem it'll be impossible to identify a possibly buggy one by disabling them 1 by 1. And there goes the problem:

Every now and then, my interface becomes non-interactive. Atlas bugs out and all bosses disappear - I go to the Firelands map, instead of having the list of bosses to the right, I get a blank empty area. Same for all other instances. Quest log gets buggy too - "share/abandon/etc" buttons become unclickable, like they do not exist. Equipment manager, and mostly the part where you mousover an equipped item while holding Alt and it displaying all possible items that fit the same slot in your inventory, also gets buggy - it show only random items, and misses a lot of them. Like , if I have 10 trinkets altogether, it will display 3-4 randomly, like I dont possess more. Or if I have only 1 more Helm, it'll decide to display like I have no other Helm. World Map also gets buggy and when it's in quest-tracking mode (as in, the map itself gets smaller and to the right/bottom you get the quest description+objectives) - map is smaller, but random objects are displayed above the areas with text, something like the game gets confused if I am using clear world map or quest-tracking version, and tries to fit them both in. Needless to say, parts of it are non-interactive too.

When I had that before, it got fixed by a simple /reloadui. Now (without me doing anything special that I can remember of) it gets fixed only after I exit the game completely. Also I think (can't confirm though) that it happens more often in raids or when I am questing. If I am idling in Orgrimmar, it doesn't happen (or not too often); but again, I'm speculating about it, might be wrong.

I've tried to delete my Cache folder. Doesn't help.

Anyone ever experiencing anything like that, or any possible ideas as to how to fix it?
Thanks in advance.
I don't know if it happens with addons disabled as I need to test it in a raid and I can't raid without addons hehe. As for repair tool, not now, but in the past, I have used it, can't remember it having an effect on the problem not appearing, but I might try backing up my WTF + Interface folders and try again
Tried the repair tool, nothing. Problem still persists. Anyone who think they are deep enough into UI stuff to identify the possible addon that could be related to the problem if I post the list of addons I'm using?
Try without addons and go do some quests, PvP, instances or whatever for a few hours and see, what happens. Addons can do some pretty weird stuff it out of date, but this sounds very weird. You could also try deleting your Data\Cache folder. You will probably have to redownload some patch data again, though.

Join the Conversation

Return to Forum