Quests doesn't register my kills and loots after 4.3.3?

Customer Support
My girlfriend and I have had some really awkward issues while questing after the release of patch 4.3.3. At times it doesn't seem like the game register any thing towards our quests at all?

She is levelling a Blood Elf Mage in Stonetalon Mountain and all of sudden she was unable to loot quest items, and killing mobs for several different quests simply didn't do anything. We are 100% sure it was the right mobs as the game told us so, we checked with WoWHead and everything and the static items she was supposed to loot like the diving helmet thingie in Stonetalon Mountain was simply not lootable for the half an hour she tried to loot it and rebooting the game didn't resolve anything.

So she simply stopped playing and started over the next day, everything worked fine for a few hours until it all started all over again, no kills was registering towards the quests and quest items was not lootable and things like that.

Now all of a sudden these issues has started to affect me as well, on a different system on a entirely different network. She is playing using the Mac OS X Lion client on a MacBook Pro 17" 2011 model trying with both the 32-bit and 64-bit client on a optical fiber connection form Altibox while I play on a Windows7 64-bit system trying with both the 32-bit and 64-bit client on a optical fiber connection from GET. And now we are both facing this very same issue.

I was trying to do my Fireland dailies today until I figured none of the quests registered anything, killing Firey Behemoth's at Sethria's Roost in Mount Hyjal wont count towards my "The Protectors of Hyjal" quest neither does the mobs drop quest loot towards the "Treating the Wounds" quest. I have slain like 20-30 of these and the game hasn't registered a single kill towards the first quest I mentioned, and there has been no loot dropped of the later quest I mentioned above.

I have tried rebooting my network, rebooting my system, launching the 32-bit client, the 64-bit client, tried running DX9 API and DX11 API without any luck.

Not being able to do quests pretty much renders the game completely useless for us, we are both playing on EU-Outland server.
Are you sure you're not in raid groups?
04/03/2012 14:14Posted by Ananda
Are you sure you're not in raid groups?

This! I had a similar issue on my hunter, he wasn't in a raid group, but he'd been in one earlier in the day and the game seemed to think he was still in it. Was like it for 3 days before I realised what it was, I cleared my cache folders and it was fine after that.
Aha! RAID group it is! Wasn't even thinking about that, was doing Molten Core solo and had my girlfriend in a RAID group so I could enter.

Seems to be stucking for quite a while, because I was in no RAID group today but getting added into one, and the leave it made everything work again.
Hello there Blazestorm,

I’m glad to hear that this was enough to help resolve things for you both, and I’ll make a note of the fact that there may be some issues with remaining in a raid group without further notification present, as we do seem to have been receiving a number of similar or potentially related reports recently. :)

However if anything like this happens again, and you’re certain no raid groups are involved, don’t hesitate to make an in-game ticket so that we can investigate further.

Join the Conversation

Return to Forum