Android WoW Armory application problem

Customer Support
since last update of application I can't create auctions.
I'm getting message: The armory encountered an error handling this request.
Canceling or bidding auctions is no problem.
I'm using SGS2 with ICS. Anybody having same problem?
yes, im having the very same problem after getting the update the other day :-S Highly annoying >_<. Phone: HTC Gratia
i just got it , it looked great................. but after i payed the 2.99 euros , it all went pairshaped i cant create auctions , phone htc desire HD
Try uninstalling, and then reinstalling
I got the same problem in the morning after updating the app.

I tried uninstalling, reinstalling, clearing app cache etc, nothing fixed it.

Problem still persists, a whole day has passed, it seems nobody cares. This coupled with the web based AH problems make it seem a very expensive subscription fee...
I have the same problem after recent update. I have cleared cache, reinstalled, but still cannot use the AH facility.
Hi there,

We're aware that the Android Mobile Armory application doesn't seem to work correctly after the latest Android update, this is currently being investigated by our mobile team and hopefully it should be working again soon.

We'll let you know as soon as we get any updates on this.
Idem here, LG Optimus One,.
Tried re-installing, but problem still there.
Why don't you perform a rollback for the time being?
Being a developer myself, I find this lack of swift reaction on an elephant-sized problem quite offending.
Indeed how can this not be tested? We are paying for this functionality on a monthly basis. Hopefully this will be fixed soon and blizzard comes with a proper compensation.
+1, Having the same issue, I'm with SGS2 with 2.3 android.
Any progress with investigation? Can you give us ETA of repaired application? It's payed service and it's not working... I know there's web-based auction house, but I'm not always on computer...
I'm afraid that we are unable to provide any ETA's but this is a high priority for our mobile development team right now. The only update I have is that the issue only appears to be affecting European users, but I'm fully in the loop now so if there's anything else I can share then I will be sure to do so here in this thread.

We apologise for the inconvenience this is causing for all of the mobile auctioneers out there.
Its been long enough now...the old version before update worked fine with latest android version on my phone...Why can't the old version be linked or a full roll back ?
This is very poor customer service indeed.
I have to agree with Ooch and as a Software developer myself, if you have introduced a breaking change into production that can not be resolved within a few hours then best practice is to roll back and continue your investigation in the QA environments. Production is not the environment to be investigating bugs.

This is now day 3 and I don't have access to a service I am paying for. How many more days will this continue before you either roll back or offer a refund for this months sub.
Seemingly the Android customer base is so small... almost invisible.
Morning everyone.

Could you please re-test this now? If it still does not work for you, please post on the address that is experiencing the issue with the name of an item that causes the error message to appear.

Hi Natryndon. I tested this out this morning with multiple items on multiple different realms as all seems to be operational again.

Posting auctions now works. Thank you.

Join the Conversation

Return to Forum