WoW launcher x64

Technical Support
Hello Support

I've updated my tools, but when the installation is complete the launcher errors and I am unable to run the game from it. I can run direct from the .exe without any issues.

Here's the information from the log about the launcher :

3747 Updater failed due to an internal or XML data problem. Message is 'Blizzard Updater was unable to start up.This update does not need to be applied. It requires a version of "WoW.exe" older than, but you already have version

Is there away I can get around this?

Simply because it's the easiest thing to start with, I'd try deleting the Launcher and then running the Repair tool so that it will download a new one. This will tell us if it's a problem with the launcher itself or if the issue lies elsewhere.

Also, can I ask if you have recently been playing on one or more US realms?
Thanks for the speedy reply Doomsinger.

Doh, I didn't even think about doing that. I'll delete the launcher now.

No, I haven't played on any US realms. In beta I have, but not on this account.
Ah, that's fine since the beta has an entirely separate installation.

I'm not promising anything with that suggestion, but given that it's far and away the quickest and most simple thing to check, it's always frustrating to spend hours helping someone only for that to solve it in the end. :-)
Ok, new launcher in and I still get the same error message in the logs.
I regret nothing!

Do you have a Temp folder in your World of Warcraft directory? If yes, please delete that, and regardless of if you do or don't, please remove the Updates folder.

Once you've done the above, try the Repair utility again.
Deleted the two folders as you suggested. Ran the repair tool, still getting the same error when running the launcher.
Well, I know you won't like this, however I'm aware of one player who solved this problem when deleting the Updates folder for the second time, and a further player who had the issue resolved after going through four Updates folders.

Can I ask if you are running the Launcher by right-clicking on it and selecting Run as Administrator?
I'll try again with deleting the updates folder a few more times.

No I don't runas admin, I've just tried runas but get the same error. Just running the repair now.
The only other thing I can think of is booting your computer into Safe Mode with Networking.
Finally got it sorted now Doomsinger.

After numerous attempts of removing the updates and launcher folders / file and running the repair tool, I was still getting the same error.

I download and installed the x64 client again, tools updated and completed the game update successfully.

Thanks for you assistance today.

Glad to hear it's working now :)

Join the Conversation

Return to Forum