Patch 5.0.4 Stuck at checking for updates...

Technical Support
Hello, this morning I try to dowload the new patch but It gets stuck at checking for updates.... then after 5min it says failed to run a program agent ect.. I tried to delete the agent file but It says I can't because It is in use.. Please Help me NOW!!!
Need a blue reply!!
Please HelP!!
Someone please help...
you are one out of many that have this problem amongst many other problems, start reading posts and solutions, fx. the sticky on this forum has some great ideas.
demanding a blue with that little information, when you probally havent read around on the forum is just absurd.
I know that But I can't delete a folder it says it's open in another programm...
Skelery please dont spam the forum with this

- look out after other topic with same problem, and i'm sure you will be able to find a Blizzard answer somewhere :)

- Best regards, Rhanus
I still don't get it to work, i've tried everyting even reinstalled the game but the Checking for updates error persists. You guys got any other idea on how to make it work?
@Goxezz. I have same problem, am told to run Wow Repair, done it a hundred times all is well. But the Launcher stops/halts on ca 20%, and after 10 sec, it says "Your installations files are corrupt, please run Wow Repair..."
My wow repair works but can't come past the Checking for updates screen :(
Just got it working. i just needed to delete a file where the Agent.exe where launched from. to do that you:

Alt+Ctrl+Delete-> Processes-> Right click on Agent.exe-> Open file folder-> click on in the top of the folder menu-> Delete the File-> start the wow launcher again.
yea that worked out ! and remember to shut down that Agent.exe : )
Hey guys I can't delete the agent file in folder. It says " The action cannot be completed because the folder or a file in the folder is open in another program" Please help..
that means that you need to open the task manager (ctrl alt del at the same time) Click on the processes table find Agent. mark it and click on the end procces buton and you cna now delete the file!
seems like skelery doesnt care to reply now that his problem is solved so ill do it for him, thanks for the information it was very usuful
If anybody is still having a problem with the launcher on windows 7. Try running it in compatability mode for windows xp service pack 3. It worked for me :D
Guys i got the same problem i suck on checking for updates i try everythink but not work please help me
i stuck i mean no suck i need fast help before the download its stucks and i get an error message
ok i found what worked for me after days of trying there is a hidden folder called program data in there is a battle net folder delete it, and it worked fine for me. Only thing i found after that i couldnt log onto the game as it was trying to log me on a non eu realm so i went to and just clicked the reinstall on my account and it fixed it took minutes. The folder should be on your c drive just enable hidden folders and it should pop up under program files.
now i do that think with the agent and i wait on updating files it has download 500mb and still downloading

Join the Conversation

Return to Forum