Fix for Updating setup files! I did it!

Technical Support
For me it says "Failed to extract the files from an Archive" when I try to start WoW after having followed these steps. Just my luck... The fix probably works, but I guess I screwed up somehow.
WoW Is stuck. Me and my friends were doing Tempest keep and it bugged 4 times. WoW is corrupted and dead I must say >.< Fixes should be coming, but this might be too many problems for them.
i need help i can update setup files is frozen on like 70% since relase on wensday on eu i need help can sum1 help me please
join the club namudan ive tried every fix there is even deleted the game
TY i lay down thy top hat to you good sir its reconfiguring files now hopefully it works
Hey i've done everything the op said to try and even tried everthing in this link http://eu.battle.net/support/en/article/BLZPTS0000F, after uninstalling the game i went to reinstall but i keep getting the same stupid error and when i ticketed blizz about it there response was to try the solutins i told them that i already tried but to no success.
Has anyone got any tips or that on how to get back playing?
Help would be really appreciated at this point.
YEAHHHH <33 thankyouuu
The correct way to fix the updating setup files issue if you use windows 7 is:

Click Start -> Right Click on Computer -> select "manage" -> click on services and application -> click the submenu Services -> right click on "Secondary Logon Service" and be sure it's set to automatic
@Snowshooter

thank you thank you thank you sooooo much works fine everyone do what he says it works!!!!!!!!!!!!!!!
May i ask what does it fix. The "0% Download completion" ?
thanks worked for me !
After hours of trawling this forum i could not find a solution that worked. For me, a combination of deleting the ProgramData\Battle.net & ProgramData\Blizzard Entertainment\Battle.net folders did not work. I had already completely uninstalled the client so i could not check the compatibility options. However, i did eventually find this from a blizzard employee:

http://eu.battle.net/wow/en/forum/topic/5207772317?page=1#3

I had been stuck overnight with "updating setup files" and as soon as i enabled the "secondary logon service" the installer ran immediately with no waiting.
All those files are gone for me o _ o

Repair.exe is gone form my list.
All i got is wow(64)
wow.exe
world of warcraft launcher.exe

Join the Conversation

Return to Forum